DeNoise 3.7.2

Note: Users on Ventura may need to go to Privacy & Security settings and allow DeNoise AI to run due to new Apple security measures.


Note:
If you updated from inside the app on Mac before around 7:40-8:00 PM CST on February 13 then you may need to re-install from the full installer. Those updating after that time should be fine.
Latest installers:

Windows (v3.7.2): Online | Full
Mac (v3.7.2): Full

Released February 22, 2023.

  • Fixed models failing to run on pre-10.15 macOS

Windows (v3.7.1): Online | Full
Mac (v3.7.1): Full

Released February 13, 2023.

  • Updated color correction model
  • Updated libraw and openimageio
  • Improved compatibility with new Intel CPUs and GPUs
  • Improved intial model loading time on Mac
  • Improved performance on Nvidia RTX GPUs
  • Fixed transparent square artifacts on Mac
  • Fixed crashes from various RAW file types
  • Fixed some crash on exit issues
  • Fixed crop origin being read incorrectly from metadata
4 Likes

Just updated to this from 3.7.0 on Mac and it now crashes when launched as plug in from Affinity Photo2. Was working perfectly pre-update. Any fix / help appreciated.

I just updated to this latest version and it is crashing when trying to open from Lightroom Classic. How do I revert back to version 3.7.0?

I re-installed from the Download page and it worked fine after that. Thanks

try reinstalling 3.7.1 from the downloads page. just did it and now its working again for me.

1 Like

If you re-install from the full installer it should work. There is an issue we are fixing right now where the in-app installer on Mac does not update the model files correctly.

2 Likes

Thanks finally! :heart_eyes:

Thanks, I will try that.

Thanks!

Updating main post as well, but the in-app updater issue on Mac should be resolved as of a few minutes ago. If you already installed from inside the app on Mac, then please try to install via the full installer linked above.

There is also another issue that is on Apple’s side that may show up. If you’re on Ventura there are new security settings you may need to allow for DeNoise. This will show up as something like the image below.

If you see this image, then go to Privacy & Security and click “Open Anyway” (Second image)

image

Just updated on my Win10 pc.
Performances are extremely worse than 3.7.0.
I have an old rig (Pentium G3240, Amd Rx550, 16Gb RAM), but the same picture that needed about 90 seconds to get denoised & sharpened with 3.7.0, now takes about 15-20 minutes!
The same happens obviously with previews.

Installed on WIN10 pro with I7 13700k cpu and RTX 3070 TI GPU . Seems to work fine and is faster

Installed it three times now, only standard model works. “currently selected model is missing. …reinstall…” Mac OS Ventura 13.2

1 Like

Exactly the same problem as lars.larsson

Keep getting the error “currently selected model is missing. Uninstall and reinstall from the link…” Reinstalled from full installer many times and it still doesn’t work

Same issue as phucnguyenswe. Uninstalled and reinstalled from the in app link initially, have tried installing from full download page, still no success with the same error. MAC user. Apparently, the issue is still not resolved.

Same issue here. I read all the postings. I removed and reinstalled the full installation (Mac version) several times and I keep getting the same error that the models are missing. Somehow, I have the ‘clear’ model working only. I even removed my antivirus. Anything else I should try ?

A quick update: I was able to reinstall the previous version 3.7.0 successfully and all the models are now loading properly. Not sure why I can’t load the models with the newest version. I will wait to get a possible solution by reinstalling 3.7.1

I can confirm that DNAI no longer crashes when batch processing in auto mode. Most of the 150+ images took around 10 seconds, but several took over a minute. It could be that I was performing some other task at that point.
Mac mini M1 16GB RAM

same for me does customer service ever reply, frustrating

I just reinstalled (2/15/23) in on my MAC via the link above and I’m still getting the Processing Error. Only model that is working is “Clear”.

Please provide guidance on how to roll back to previous version until the bugs associated with the newly released updates are resolved for MAC users.

Thanks.