DeNoise 3.1

Learn more about the new features in DeNoise AI 3.1

v3.1.2
Release June 3rd, 2021
Windows: Online | Full
Mac: Online | Full

Change log

  • Fixed app not being able to open on older hardware
  • Fixed crash when memory usage was not set correctly
  • Fixed crash when writing CFA EXIF tags in TIFF/DNG images
  • Fixed Severe Noise not allowing 0 on the sharpness slider
  • Fixed previously proced image appearing in background of fully zoomed out image
  • Fixed slider not matching mouse position
  • Fixed masking brush not matching drawn strokes
  • Changed estimated time remaining so it doesn’t jump around as much
  • Added support for transparency masks in DNG output when input is 4 channel image

Known Issues:

  • DPI values sometimes do not save correctly
  • GPS values when saving to Lightroom may not save correctly
  • Saving an image while zoomed in before a model initializes can cause saving to get stuck

v3.1.1
Release May 19th, 2021
Windows: Online | Full
Mac: Online | Full

Fixes:

  • Fixed metadata not saving back to Lightroom

v3.1.0
Release May 19th, 2021
Windows: Online | Full
Mac: Online | Full

Major Changes:

  • Updated AI engine with performance improvements and crash fixes
  • Added plugin support for Photoshop running natively on Apple M1 silicon
  • Added new model “Severe Noise”
  • Added new optimized models
  • Added “Submit Feature Request” under Help menu
  • Moved post processing into the AI engine to improve performance
  • Changed Photoshop plugin so that Last Filter applies automatically
  • Changed comparison view to allow swapping of 4th model
    – Added a one-time message to describe how the changes work upon entering comparison view
  • Chroma noise reduction range reduced by half
    – Still 0-100, but halved internally
  • Renamed DeNoise AI to “Standard” and AI Clear to “Clear”
  • Removed color profile selection for PNG output

Fixes

  • Fixed pixelated preview issue
  • Fixed undo/redo not resetting update preview button state
  • Fixed various JPEG loading issues
  • Fixed some EXIF data crashes on CR2 files
  • Fixed inaccurate count with file saving panel
  • Fixed file saving panel staying open when opening an image
  • Fixed some color desaturation on DNG saves for some RAW types
  • Fixed app not closing until preview is processed
  • Fixed Select All being left checked if you double clicked a checkbox quickly
  • Fixed mouse wheel scrolling getting stuck on sliders
  • Fixed long save paths overflowing the save dialog
  • Fixed not saving model between program runs
  • Fixed login password field not accepting spaces in middle of passwords
  • Fixed processing time overlapping controls when opening preview after saving
  • Fixed original view not working in when in masking mode
  • Fixed writing of fractional values in metadata for TIFF/DNG (Windows only)
  • Potential fix for chroma noise reduction sticking at 100 when loading app

Minor Changes

  • Added tooltips to the letters in the file list view
  • Added more warnings when a watermark will be applied
  • Added login buttons to watermark prompts to hopefully reduce confusion when not signed in
  • Added a total images loaded section next to the “Select All” checkbox in batch mode
  • Changed how DNG thumbnails and images are written
    – This is not meant to fix the small size issue on Windows
  • Changed some EXIF data so it trims ending spaces
  • Changed how external editor files are saved
    – Should no longer leave an 8kb file if the save fails
  • Changed buy button so that it shows the login screen as well as opening the website
  • Changed spacing around the app name and version
  • Changed file list view model indicator style
  • Changed some wording across the app (e.g., Mode => Model)
  • Sliders now go all the way to the left and right with no padding on the highlighted section

Known Issues:

  • Masking brush radius may not match stroke size
  • Last filter settings for Severe Noise may not be accurate
6 Likes

IHi all after installing this update the exif is missing from my Nikon files when invoking topza thru LR. on my Mac.

Was this data previously kept? Can you list the tags that are missing?

Everything is missing … only file size remains… even in preview on Mac its shows black .

grt Jolanda

is there a way I can upload a few screenshots to show what is missing ?

You can upload images, screenshots, and logs here: https://www.dropbox.com/request/RZJRZVKs6t0UclKVfUWM

Is there a way to roll back to the previous version? Version 3 will not run on my laptop?

i have uploaded two shots… before. and after in LR

Jolanda

1 Like

Which version are you looking for? You can go to the DeNoise forum and go to whatever thread has the version you want: https://community.topazlabs.com/c/releases/denoise-ai

I’ll take a look at this for a future version, but for now if you have a version where this worked previously let me know. You can use the forum to find previous versions if you want.

thanks… yep everything worked fine before this version… so ill go back to 3.0.3.

btw im running macOS fastest versioning adobe CC. subscription .

Greets

Does this new version download models or are they all included as before?

Downloadable models aren’t implemented for this one yet, at least not in a user facing way. The installer will drop all the models still.

Hmmm… I have a sample image, and serious that the Standard and Clear models do not de-noise in automatic mode?

The newest version 3.1 strips away two important EXIF fields (used in Photoshop Lightroom):

  • Date Time Original
  • Date Time Digitized

For that reason, for example, sorting by Capture Time messes up.

Olli

This is currently being worked on. For now I believe LR has an option to overwrite metadata by clicking the small arrow on the top right of the edited image.

image

Replying again to let you know 3.1.1 was just released specifically to fix this issue. If you can, give that a try.

Installed updates today (Windows on 5/19/2021) and after choosing the best DeNoise format, it starts processing to save but will never save it, processing forever. Really needs to fix this bug ASAP.

Adam. 3.1.1. fixed the exif troubles for me… thanks for the quick fix

Regards Jolanda

1 Like

Could you help and provide a bit more info so I can try to debug this? Is it an issue in all modes, or a particular one? And can you upload logs here: https://www.dropbox.com/request/RZJRZVKs6t0UclKVfUWM