DeNoise 3.1

Impossible to install the patch 3.1.1?? ( App data/local temp/topazdenoise 3.1.1 windows -64 online insta ) she don’t saw the files topaz??? in local temp??? Same for sharpen program always the same message in opening! miss kernell32.dll and HDDLapi.dll.

This has been a long standing problem with DeNoise AI for me and I previously reported with samples and was told it was a LR issue (NOT). The EXIF is not really missing as in over written rather masked and only a few elements visibly reported after processing with DeNoise AI. If you take a TIFF export from LR or Capture 1 Pro (latest version) it will reveal full EXIF data. Now process that file in DeNoise AI and review the processed file you see a reduced set of EXIF elements only. Now take that DeNoise export and process with Capture 1 Pro - 21, PS, LR, or Affinity Photo and re-save the file, the EXIF data is once again visible. The only app that seems to overwrite the DeNoise EXIF is Mac Preview which seems to make it permanent as a reduced set and unrecoverable.Post%20LR LR%20Export%20Post%20DN_AI DN%20save%20post%20Save%20in%20AP

I just upgraded to the latest version a few hours ago. When I run an action in Photoshop to run DeNoise, it processes the images and doesn’t give me a chance to change any of the parameters. I rerecorded the action and the problem still persists. Annoying. Strangely, I also find it much faster for some reason yet the changelog doesn’t mention performance updates.

I just read the correct release notes and saw that it automatically applies the last model used in Photoshop actions. How do I stop it from doing this as I don’t want this behaviour.

Toggling the “toggle dialog on/off” setting at the left hand side of the actions panel in Photoshop seems to work.

image

It looks like Denoise AI now supports actions and maybe even smart objects the way I would expect them to work. If so, it is a great step in the right direction.

2 Likes

All it does is stop the step from running, that doesn’t solve the problem I have. I don’t want it to run the last model automatically because it will likely be wrong for the image I’m working on, I want to be able to specify the options in the plugin. If the plugin supported the auto configuration option that might be useful but it just appears to take the last run info and use that. If you are working on a high noise image and then the same action on a low noise image, you’ll get the wrong type of noise reduction

Not the tick box, the little icon next to it. Then you should be able to change parameters.

That worked like a charm, thank you!

I’ve actually noticed this and have been trying to fix it, but unfortunately it didn’t make it into this release. I’m hoping I can pull out the EXIF data and write it in a way that’s not super nested so other apps can pick it up properly.

The issue they were bringing up though was actually dropping all EXIF from LR, not just writing it nested. That was fixed in 3.1.1.

1 Like

Looks like I’ve hit the limits of running Denoise under WINE on Linux. Program loads and runs but it won’t load any images. Even the demo samples provided don’t load with the loading icon sliding back and forth endlessly.

3.03 works fine here, so will just keep using it.

Is there any way I can reverse this update? All my photos are getting messed up after going through the AI–very pixilated and worse than before using the tool. Everything worked perfectly before the update. Please can I go back.

If I get ambitious, I might try using the Crossover program, the ‘commercial version’ of WINE, which has overall improved compatibility over the ‘free’ version. WINE has been around for over 20 years now, is a pretty mature project, and they have successfully ported something like 10,000 games and other windows applications over to it. The company that makes Crossover and Wine has hit the big time lately with the meteoric rise of gaming under Linux (which they are primarily responsible for) and offer a service to software companies to port their programs over to WINE. For a fee, of course.

Older versions are posted on this forum in different threads, so if you have an issue with this one you can go to those threads to download the older installers.

However I’d like to get more information on this if possible, so if you could provide screenshots, example images, logs, etc for this issue I’d be interested in seeing what the root issue is. You can submit files here: https://www.dropbox.com/request/RZJRZVKs6t0UclKVfUWM

1 Like

I can’t think of any change that would break this directly, so that seems kind of strange. It’s not supported and I don’t even have a setup to test it, so likely not something that can be fixed directly as well.

Not to worry, I never thought WINE would indefinitely support all versions of Topaz products. It’s possibly a compatibility regime that will come and go. 3.03 is still on my machine, and works fine. One advantage of Wine is I can install multiple copies of Denoise or Sharpen and have them loaded all at the same time, each in a separate container, so I can test infinite varieties at no inconvenience at all.

1 Like

Update: I re downloaded v3.0 and the issue seems to have resolved. I uploaded a pre and post photo in the dropbox link of an example of the problems with v3.1. Just did the same photo I uploaded on dropbox with v3.0 and it’s great :slight_smile:

EXIF problem was fixed in 3.1.1. Thanks for that!

Olli

1 Like

I get an error message when trying to launch version 3.1.1 on Windows. I tried uninstalling and re-installing and rebooting the system. Nothing works. Version 3.0.3 was working fine.

I have uploaded an image of the error message in Dropbox.

The new “Severe Noise” model is amazing! Great job!

1 Like

I just installed this update. When I bring an image to Denoise through the Photoshop plug-in, it automatically begins processing. Is this happening for anyone else? I can’t find a way to turn it off.

(Note: This is not “auto preview” but that it actually starts processing it…I have to cancel it to be able to pick my settings and update the preview)