Crash with v3.0.3

I installed the latest 3.0.3 Photo AI update yesterday (1st June) and I’m now having problems, sometimes it will load up to preview stage before crashing and other times it crashes before the preview is complete.
Is there a way to go back to the previous version as this is not working at all for me.

hi. I updated to v3.0.3 yesterday and the program does not work, it crashes, locks up. I find I need to hover over the righthand top expand icon to initiate something to work. I also tried to activate my account and it led me to subscride again which I did and it still does not work. frustrating is not the word.

@trevor.baker-6928 @dazeaton58

I’d like to get some more information to help troubleshoot the problem you are having.

Could you send us your computer’s full system profile?

Also if you can, please try to recreate this crash in Topaz Photo AI, then go to Help > Open Log Folder, please send me all of the files within that folder. You should be able to attach them directly as a response to this thread.

If you would prefer you can securely submit your files(s) to my Dropbox using the link below. Make sure to send me a note to let me know you sent something. :slight_smile:

Dropbox File Request

Mine won’t load a pic. Can’t get the log files - it doesn’t find a log folders at all. This is what I get from Event Viewer. Will send dxdiag.

Faulting application name: Topaz Photo AI.exe, version: 3.0.3.0, time stamp: 0x66590184
Faulting module name: Qt6Core.dll, version: 6.6.1.0, time stamp: 0x6556fafd
Exception code: 0xc0000005
Fault offset: 0x00000000000fffea
Faulting process ID: 0x0x9C8
Faulting application start time: 0x0x1DAB59BE569CB70
Faulting application path: C:\Program Files\Topaz Labs LLC\Topaz Photo AI\Topaz Photo AI.exe
Faulting module path: C:\Program Files\Topaz Labs LLC\Topaz Photo AI\Qt6Core.dll
Report ID: 25199af1-9f6a-4042-9d9b-1864f1dffe16
Faulting package full name:
Faulting package-relative application ID:

Hi John, I have uploaded a folder to Dropbox ‘Trevor B Topaz AI 303’
The program loads and stays open until I open a CR3 file, it generally starts to analyze but then crashes, sometimes it will get a bit further and then crash.
It was fine with the last version and has only caused problems with 3.0.3
I have only recently swapped to this laptop as my old one developed problems.
regards
Trev

Hi John, did you get all the files in Dropbox, just wondering if it is possible to go back to the previous version as a work around for now.
regards
Trevor

Thanks for sending in those files, and sorry for missing your initial reply on here.

We are still investigating why this crash is occuring for you, in the meantime I would recommend using the following link to revert back to a previous working version as you suggested:

Hi John. I went to 3.0.3 with the new nVidia driver and it at least opens, loads pics and processes. It can also export standalone. But it still can’t export properly to/from LRC. In Edit In… approach from LRC, it gives an error Error: Cannot open output file. In Plugin Extras…it just stalls on exporting. Unfortunately whenever I click log file folder, it shows nothing. Nothing moves. The first time I did it, it showed the root folder of the C drive. Now … zero. Same for show presets folder. Same problem on different versions as well.