Corruption of filenames after Photo AI

Using batch processing with files sent from LR have processed files by Photo AI V 1.3.9 with corruption of filenames. This problem was previously seen with Denoise, can’t remember which version. The image of the NEF file and the TIF file is different after Photo AI processing. This issue was not seen with V 1.3.8

Hi @smwong348, are you able to send some examples of what is happening to your file names here?

Hi Preston,

Appreciate your fast response.

Unfortunately I do not have those files anymore, because I have reprocessed those affected files individually to resolve the issue.

I can descript the issue to you, only see this with V 1.3.9

  1. The issue only arises when I process in batch by sending the files from LR to Photo AI.
  2. It only happens to TIF files. I have tried with JPEG files, no issue
  3. The corruption is not the filename, but the image of that file is not the TIF file generated from the NEF file sent to Photo AI, it is some other image of the same batch. This has occurred with Denoise before, it was resolved.

Apart from this mismatch of filename to image, I also raise the issue with the following errors using Photo AI, also only to TIF files processed in a batch sent from LR. There is no error when those affected files are processed individually. This only surface after I upgraded from V 1.3.8 to V 1.3.9

  1. Unable to read file, surprisingly, preview could be generated, error occur during final processing
  2. Unable to apply model.

I also raised the issue of failing to copy over keywords and rating of a TIF file when processed in large batch. Only one file in the batch is affected. Apparently, it only occurs when the batch size is large. I have tried batch size of 10, no issue. The issue surfaces when I processed a batch of 53, can’t tell you from what size it starts to have the issue. At times, the affected TIF file also shows color shift. Can’t remember from which version onwards the issue started to appear, certainly many versions before V 1.3.9

I also encountered a one-off issue of not seeing all the files sent from LR to Photo AI. Example, if I sent 300 files over, could see less than 300 files in Phot AI. If I try to send it again from LR, all files appear in Photo AI. Don’t seem to have this issue with V 1.3.8

Could you send me the link to V 1.3.8, V 1.3.9 is simply not usable, I need to processed the files individually if Photo AI report file cannot be read or unable to apply model. I also need to go thru individual image to find the filename and image mismatch to process those files individually, some of my images are so close that need to compare the NEF and TIF files to spot the issue.



Soong Ming

Hi Preston,

I tested batch processing of JPEG files today, same issues are seen, so it is not only affect TIF files.


Soong Ming WONG

You can roll back to a previous version of Topaz Photo AI by getting the previous version here:

Here is a direct link to the v1.3.8 release:

I am processing some images to try reproducing this issue.

Hi Lingyu,

Thanks for the link to V 1.3.8. I have rolled back.

The issue with of “Unable to read File” and “Could not run Model” did not appear when I ran a batch of 91 photos.

The issue of wrong image associated to the filename also does not appear.

The issue of having one TIF file with Keywords and rating removed after Photo AI when running large batch job still exist.

The issue of not having all files sent to Photo AI from LR with “Edit a Copy with Lightroom Adjustments” option selected in LR still exist. I tried to process 91 files from LR, only 63 appear. I shutdown Photo AI, select all the 91 TIF files generated previously in LR and send them to Photo AI, all 91 files appear in Photo AI. As I mentioned before, this issue is also present in Denosie.

I was not able to reproduce the keywords and filename issue with batches of TIF files that I processed on my computer.

Can you try updating to v1.3.11 and let me know if you still see the could not run model error or the unable to read file error?

For the unable to read file error, could you send me one of those files so I can check what is happening? You can securely submit your image(s) to my Dropbox using the link below.
Dropbox File Request

Hi Lingyu,

The filename issue is resolved with V 1.3.11, but the missing keywords and colour shift of the file with missing keyword is still there.

Did you try running all the 50 files launch from LR as a batch. The missing keywords does not seem to be an issue if the batch size is small. Tried 10 files in a batch, no issue with missing Keywords, don’t know what batch size onwards will have the issue.


I did try running a batch of 50 images, all Raw files, and was not able to reproduce the keyword missing or the color shift.

Is this always on the last file in the batch you are running?

Hi Lingyu,

Sorry for the late response.

Upgraded to Photo AI V 1.4. More issues surfaced. I have feedback the issues in one of the threads.

I have reverted back to Photo AI 1.3.12. V 1.4 is totally not usable due to serious color shift and corruption of Filenames. The corruption of Filenames was solved with V 1.3.11, then it cropped up again with V 1.4.

As for the issue with missing Keywords and color shift, I think you simulated with Windows 10. Apparently, the issue is only seen with Windows 11. I tried running the same files on another computer with Windows 10, there was no issue. I did it twice to ensure it is repeatable.

As for V 1.4, missing keywords is occurring on Windows 10 and 11.

I hope those tests will help to improve the software.



Soong Ming WONG

Thanks for sharing this information and staying on top of the problem.

We are building some stress tests for batch processing to better understand and fix this issue. I noticed more reports of this with v1.4.0 as well.

The batch processing issues are hard to confirm so the stress test will help. Let me know what else I can help with in the meanwhile.

Hi Lingyu,

Thanks for the update. I am seeing update V 1.4.2. I will conduct test of this version on my secondary computer running on Windows 10. Too much trouble updating and roll back on my Windows 11 computer which is my main work horse.

As for V 1.4.1, still seeing color shift processing Z9 files with High Efficiency Raw format. I can share with you how bad it is if you wish, I believe is mis-interpretation of the data.

Missing Rating and Keywords and color shift still present with V 1.4.1. For the same batch of files if ran multiple times, the affected file is random, not the first or the last. I am seeing this issue even with a batch of 39 files, apparently batch of 10 is not happening.

Corruption of filename is still happening happening with V 1.4.1, happen to both Windows 10 and 11.

I am a very heavy user of Photo AI, processing hundreds of files a day. Photo AI is a good application, if all those issues can be resolved, it will be very good.



Soong Ming WONG

Hi Lingyu,

Encountered repeated issues with TIF cannot be read by LR after being processed by Photo AI recently. In the past, this problem did surface occasionally, but with V 1.3.12, it is happening all the time. I believe the team must really do more robust testing with files sent from LR.

The other issue is, not all TIF files generated by LR (right click, Edit with Photo AI) are sent to Photo AI. Few days ago, 2 instances of Photo AI was started to cover all the files sent from LR. Today I tried sending 92 files from LR to Photo AI, only 73 appeared without a second instance. Tried closing Photo AI and select the 93 TIF files generated previously by LR, selected the option of “Edit Original”, only 73 files appear within Photo AI, without a second instance. I have split the batch into 2, a batch of 55 and another 37. Both batches generated one file each with Rating and Keywords removed. This issue did occur in the past, can’t remember which update eliminated the issue, it is cropping up again.

Hope all these feedback will improve the Application.


Soong Ming WONG

Thanks for this information, I passed it along to my team to see if we can check this metadata issue with the tests.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.