Constant crashes of Photo AI while exporting

[Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]
I keep getting crashes or Photo AI doesnt process all the photos from the batch and few keeps stuck. I use it to upscale output of Stable Diffusion, Deforum individual frames for animation. 512x512 to 2k once exporting over 300 images it crashed on 99 and havent fully processed previous four. See attachments.

Steps to reproduce issue:

  1. Step 1 - import 600 photos / frames of video
  2. Step 2 - set all to the same use for example sharpen, and enhance apply to all.
  3. Step 3 - export to folder.

Crash happens 70-80% of the time. I am on M1 Max Macbook 13.2.1

Tried latest 3 versions with same result. Now on Photo AI 1.3.5 (6.7 MB) (15.3 MB)

Couldn’t post 3 links as new user, so here is source if you need to see it. (1.9 MB)

Thanks for sending the files. I documented this issue and will bring it up with my team tomorrow so we can look into a solution.

From the logs I can’t tell exactly why this is happening yet. I can follow up once I have more information about this.

1 Like

I wonder if its something to do with memory. I have 32GB of ram tho.
I had to run batch twice, second time with fewer/remaining files it usually worked. Ones I attempted three times. Then i had to find those individual random files from the batch, that haven’t been processed / were stuck on export. So there is kind of two issues: crash is one and files getting stuck on export is two.

I sent the logs to my team but it’s not showing the cause unfortunately.

Do you have an Apple crash report that you could send?

Please open Topaz Photo AI and go to the Topaz Photo AI > Preferences > AI Processor menu. In the dropdown menu, select M1 and process some images like that.

Let me know if that changes the behavior.

1 Like

Hey, thanks for coming back to me. I had that already selected upon installation.
Screenshot 2023-05-30 at 21.59.24

Also, I cant find any crash logs from Topaz Photo AI in my logs.
Only thing semi related I found is realesrgan crashes for upscaler from Stable Diffusion / Deforum.
If this can be useful here they are. (9.9 KB)

Do you possibly have a version that would leave more detailed logs? I am happy to test it and run the same scenarios.

We don’t have more detailed logging for this issue unfortunately.

Are you overwriting files or exporting new files?

Could you try uninstalling and reinstalling and see if that changes the behavior?

Hey, I will try that with the new update.
I am exporting new files in the new folder, always. Haven’t tried overwriting yet.
Will give it a go tonight and let you know my findings.

Reinstalled with 1.3.6 tried exporting 900 images with 4x had to do it in batches of 120-130 it crashed several times. Luckily it wasn’t missing any files, i could pick up from last processed #no and continued with another batch. It seems like smaller batches have better success rate. Tho one crash happened after about 60 photos processed.

Is it happening with v1.3.7 as well?

I am getting crashes with 1.3.6 through to 1.3.8 and very frequently now. To the point where if I do more than 3-4 photos it’s almost guaranteed to crash. Super frustrating.

Will aim to share some logs on the next batch.

1 Like

I can confirm it is happening with 1.3.7 and 1.3.8 as well tested both. 1.3.8 was little better as managed to process more pics but crashed for me still. I have several logs for you and console logs. For some reason diagnostic reports show up as Siri search logs, attached in case its helpful. (2.7 KB) (2.2 MB)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.