Colour cast on processed raw images

I am still getting a colour cast when I process raw photos using Topaz Photo (via Plug-in Extras). If I process a photo from Lightroom (via ‘Edit In’ path ie a TIFF) there is no cast.

I first reported this issue in August 2023 so it is frustrating that the issue persists, even in the latest version of Topaz Photo.

See attached photos. Will there be a fix soon please?



Topaz Photo AI v2.4.0 on Mac

Would you mind sending in some more information to get a better understanding of the problem you are having with this particular type of image? Please send the following information:

  1. The original image file.
  2. The processed image.
  3. A screenshot or description of the settings panel so I can see what adjustments were turned on.

You can securely submit your image(s) to my Dropbox using the link below.

Dropbox File Request

Please be sure to send me a note to let me know you sent something.

I’m seeing the same type of color shift in high-ISO Olympus RAW files processed with PhotoAI. In addition, the processed file does not reflect the ‘baked-in’ lens corrections that Olympus applies. If I export the file to Photoshop and use the PhotoAI filter from there (non-RAW processing?) I get a file with the correct lens profile and colors.

Hi John

I processed another photo this morning via the File/Plug-in extras path with the same result. I have uploaded the original ORF file and the Topaz processed DNG to your dropbox account. There were no settings applied to the ORF file before sending the file to Topaz Photo AI, as you can see from the screenshots of the settings from the Library and Develop modules which I have put in your dropbox account.

The photo was taken with an OM System OM-1 camera with the 150-400 4.5 TC Pro lens and the 1.4 teleconverter attached. Shutter speed was 1/500th sec at F8, ISO 1250.

Please let me know if you need any more details.

When I raised this matter last August, I sent the affected photo to Lingyu at Topaz and he confirmed (email of 15 Aug) he received the photos and could replicate the colour cast problem. He said he had tasked his team with finding a fix. I sent a followup email on 27 Nov 2023 but got no reply. The topic I created at the time was titled 'Spot removal in Lightroom undone by Photo AI 1.5.0’ because I was also experiencing a problem with a spot removal in Lightroom being undone by Topaz and I assumed the colour cast was associated with that issue.

Anyway, I hope you can fix this issue as it has been outstanding for too long.

Thanks

Paul

Can you try updating to the latest release of v2.4.1? This new release has a fix for the OM-1 camera series.

If you are still experiencing problems after this update please reach out to us at the following link:

Topaz Labs | Support Page

Hi John

I updated to v2.4.1 and processed the same photo I sent you before. I still get a colour shift. I had a look at the list of fixes in the release notes for 2.4.1 but I can’t see the OM-1 fix mentioned. The only fix mentioned for OM system camera is a fix for OM-1 Mk II photos not saving.

Paul

My apologies for the mistake on those camera profiles, I had misspoke about the OM-1. I’ve worked with the image you sent in and was not able to replicate this color shift through the File > Plugin Extras > Process with Topaz Photo AI plugin.

Please reach out to us at the following link and we can continue troubleshooting this with the team:

Topaz Labs | Support Page

I am having the same problem from my Z8 and Z9. I export the DNG from LRC then drop it into PHoto AI 3.0 I apply only denotes and sharpening but the saved file has massive color shifts. This is why I use either Topaz Denoise or Adobe denoise from within LRC. Massively annoying. Also, very upset that you are no longer supporting Denoise and Sharpen as these allow the user much more control. You are losing serious and pro photographers. Please rethink.

Same here, opened a ticket as well in march 24 but up to now no news,

This topic was automatically closed after 60 days. New replies are no longer allowed.