CLI broken in 2.0.7

The CLI is once again completely broken in the new release (as was in 1.3.3, 1.4.0, 2.0.0, and so on).
I did a complete fresh install, all preferences default - only “CPU” only is selected in the prefs.

Steps to Reproduce:
Open Windows Command Prompt
cd C:\Program Files\Topaz Labs LLC\Topaz Photo AI
tpai c:\Windows\Web\4K\Wallpaper\Windows\img0_1024x768.jpg -o c:\Projects
(where you would replace C:\Projects with a writable folder that actually exists on your machine)

Checking if log directory should be pruned. Currently have 6 log files.
Log file count is within bounds
Logger initialized
Change the following settings within the preferences panel in the app
Application settings:
Overwrite Files: 0
Recurse Directories: 0
Input File Count: 1
Output Folder: c:\Projects
Output Format: Preserve
Jpeg quality: 95
Png compression level: 2
Tiff compression: none
Tiff bit depth: 16
Autopilot settings:
Auto apply filters: true (Forced)
Face Detection: auto
Face Strength: 80
Face Parts: hair,necks
Sharpen Model: Auto
Sharpen Levels: medium,high
Sharpen Strength: 3
Upscaling Model: Auto
Auto Upscaling Type: auto
Auto Upscaling Factor: 2
Upscaling Denoise Strength: 3
Upscaling Deblur Strength: 3
Resolution Unit: 1
Resolution: -1
Remove Noise (non-RAW) Model: Auto
Remove Noise (non-RAW) Levels: medium,high,severe
Remove Noise (non-RAW) Strength: 3
Remove Noise (RAW) Model: Auto
Remove Noise (RAW) Levels: low,medium,high,severe
Remove Noise (RAW) Strength: 3
Remove Noise vs Sharpen: auto
Default Subject Type: Subject
ExifTool loaded!
Warning: failed to load, something strange about this perl…
[ WARN:0@3,018] global C:.conan\918058\1\source_subfolder\modules\core\src\matrix_expressions.cpp (1334) cv::MatOp_AddEx::assign OpenCV/MatExpr: processing of multi-channel arrays might be changed in the future: core: inconsistency of addition for multi-channel Mat and Scalar · Issue #16739 · opencv/opencv · GitHub
Error | [CLI] Engine canceled processing

I don’t understand - can’t you create a simple functional/integration test that runs the tpai.exe with a predetermined picture file and check if an output file (> 0 bytes) was written? That would ensure that the CLI at least does something before a release.

This is very frustrating, as this is the fifth time (or more) that the CLI is completely unusable in a new version of Photo AI… :frowning: It still worked in 2.0.6…

P.S: Could you please add an autopilot preference to always force “sharpening” and “remove noise” (additional entry in “Enable when” saying “Always On”). It’s the only thing I still can’t force for the CLI - and there are many cases, when a picture is blurry and PAI doesn’t see it that way. I know what pictures need sharpening (I named them with a _blurred suffix), so I need some sort of way to force PAI CLI to sharpen them.


Topaz Photo AI [v2.0.7] on [Windows]

1 Like

I’ve got similar issues, doesn’t do recursive one bit, but it does work for single folder items.

I always use it with single files, not folders. In 2.0.6 it still worked, 2.0.7 no more… :frowning:

Three simple automated tests would do to continually ensure this functionality:

  • call tpai.exe with a single file, check output (at least file exists with size > 0; better: read image file and compare the target resolution to an expected value)
  • call tpai.exe with a single folder, check output for every file in your inputs
  • call tpai.exe with recursive folder, check outputs

I would go one step further and output an “OK” message at the end of processing, like
“Successfully processed file xyz.jpg (output resolution: 4096x2160)”
And I would then capture outputs and errors from the called tpai.exe (since it already outputs lots of info). And check for the success message at the end of these tests.
Plus checking that the ExitCode is also 0 (=Success) at the end of the process.
That’s pretty basic stuff. Someone just has to do it :wink:

After the new update the app will not let me choose a crop of 4.5 if I do the app then force close

@tim.he Can you tell me if there will be a fix in 2.0.8? Thanks.

Another user just reported the same CLI issue for 2.0.7:

Seems to work again in 2.1.0, therefore I am marking this as the solution.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.