"Chessboard" effect on RAWs from Canon R5 C

Hello everyone! Can someone help me solve a problem? It’s about the fact that after converting from CR3 to DNG in Lightroom Classic, a ‘chessboard effect’ appears on my photos. Even when I don’t make major edits, just use autopilot, it becomes visible on the photos and they are simply unacceptable, not suitable for upload. The output files are high-quality RAWs, so there’s no question of too low input quality. Unnatural cuts in tonal transitions are visible. The greater the contrast in post-production, the more visible it becomes. When I increase the clarity or dehaze levels, the effect becomes increasingly noticeable. With minor editing, this checkerboard is less visible, but still present. For example, I increased the clarity to high values to highlight this effect. I should add that this checkerboard effect does not occur on the CR3 file after applying similar editing. Please help.





Well, I can actually see the effect in Topaz, without export


Oh guys look at this example. The more denoise effect, the more artefacts on the picture.

Would you mind sending in some more information to get a better understanding of the problem you are having with this particular type of image? Please send the following information:

  1. The original image file.
  2. The processed image.
  3. A screenshot or description of the settings panel so I can see what adjustments were turned on.

You can securely submit your image(s) to my Dropbox using the link below.

Dropbox File Request

Please be sure to send me a note to let me know you sent something.

Hey John thx for your answer. So I’ve just sent you 2 files. I only run autopilot and set sharpening and noise reduction. Denoise normal strength 16, minor 1 and sharpen standard 66/63. Just look at the image, it looks really bad because of the squares on it. best regards

Hey could anybody check that problem and respond me pls? It actually appears on all my CR3 images from Canon R5 C

best regards

OK I found solution. When Dual Pixel RAW is enabled, some error appears. One’s have to either turn it OFF or first export file as TIFF through Photoshop and then use Topaz and it works without these weird artefacts.

My apologies for missing your replies, I’m glad that you were able to find a workaround for your images. I will be sure to share this insight with the developers in order to help with future updates and the progression of the application.

This topic was automatically closed after 60 days. New replies are no longer allowed.