Can't save some pictures, unknown mistake with "can't save"-failure

Hey there,

Not with every picture, but with some random ones I have this problem.
I have deleted the picture and reloaded it and the same error occurs.

(using apple photos with the plugin) works 9/10 times.)


Hi there! Please be sure to include your computer’s system profile and your logs from Topaz Photo AI so we can troubleshoot. You can gather your log files from the app by first recreating this behavior within the app, and then going to Help > Open Log Folder. Upload all of these log files to this thread and we can review them.

How to Obtain Your System Profile (Windows)

How To Obtain Your System Profile (Mac)

I have been having the same issue for the last week or so (after last update?). Very intermittent - usually works but occasionally can’t save. An additional note but not confirmed that if I edit with another app such as Pixelmator Pro and then use Photo AI, it at least a few times was then able to save (while it failed when working off the original Photos file).
I have also noticed that sometime it can’t even open Photo AI from Photos on some photos if there have been any changes to the original (again, very intermittent).

  • updated: just had 2 more failures to save which, by editing in Pixelmator Pro through Photos first and then using Photo AI, they saved properly. Feels now that this is a good clue to the potential problem :grinning:

Attached are my system profile and the last 5 Photo AI logs (had to open it separately to access the logs as when it fails to save, the app has closed.)
2023-06-09-22-31-49.tzlog (9.8 KB)
2023-06-09-22-29-21.tzlog (145.8 KB)
2023-06-09-22-28-23.tzlog (111.7 KB)
2023-06-09-22-26-23.tzlog (12.6 KB)
2023-06-09-22-18-0.tzlog (146.2 KB)
iMac.spx (7.2 MB)

@mhdpost @jhunkins It looks like there is a conflict with Apple Photos.
Let’s try resetting the plugin.

Please follow the steps below:

  1. Close Apple Photos completely.
  2. Run the Topaz Photo AI installer again. Get a new one from the downloads page:
  3. Open Photos and run the plugin from the Edit menu.

That will re-establish the connection between the applications.
For more info about the plugin, view this article: Apple Photos | Topaz Photo AI

Hi Tim, thanks, tried that, same issue.
Sample picture and system report attached.

MacBook Pro.spx (5.2 MB)

Thanks for trying that.

Because we haven’t had other reports of this for Photo AI, I’m starting to believe it’s a conflict on Apple’s end. I’m not seeing anything unusual in the log files or system profile either. Plus, it sounds like going through Pixelmator Pro is working fine.

I hate to be a “go talk to them” type of support person, but in this case I think that’s actually the best way to proceed. I’d be interested to know what they say and of course I’d be happy to continue troubleshooting from there.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.