Black regions showing up over video

This may be a stability-related issue with GPUs so I’m hoping to gain some advice. About 50% of the time, a video that I am upscaling will be suddenly covered by a large black region. The size and location is random. Once it shows up, it persists for the rest of the upscaling process.

br

I can stop and restart the same video, and perhaps it’ll work next time, or perhaps not. Is there something I can do to improve stability? I’m using an RX 480 GPU, mostly with Artemis models. 1.9.0.

Is it possible you have some kind of picture-in-picture enabled?

Something like that could be a glitch while using this program.

Weird issue, hope you figure it out.

I experience the same issue with the latest version. Also the black is not always half of the image, but it is always a totally black rectangle.

First off, have you opened a Ticket with Topaz yet?

When you pay for a subscription service it better work and if not they should either help you figure it out or refund your money.

Your card is not that old, but you didn’t list Operating System. Besides you might have corrupt software or a driver issue. AMD graphics cards have not been embraced by a lot of companies yet, so it could just be a compatibility issue. AMD graphic cards have to be program differently than NVIDIA or even Intel built into the CPU graphics.

Also, there is the fact this company doesn’t guarantee that their software will work well on a retail graphics card. They just say it should be doable.

I haven’t been able to figure out if a Maxwell graphic card is still supported with their software, but Pascal runs like a champ. If you’re not doing this professionally and got time to spare. Try getting your hands on an a refurbished small form factor business computer off eBay and slap an NVIDIA Quadro P2000 in it. As long as it has at least 16GBs of ram in dual channel and a couple of SSD drives in it. It should upscale 2 or 3 TV shows a day with no problems.

My dumb butt wanted it all in one machine and eventually figured out that an NVIDIA Quadro P4000 could do everything I could want for now without having to use any system memory. Got lucky and only spent $500 bucks on it and it was a spare card for some business too, so the packaging wasn’t even opened.

I’m a crazy man though, so I don’t recommend my route. Plus running two graphic cards that don’t act as one graphics card somehow, does get complicated. Like having to tell each program your using which card to use. Couldn’t even watch YouTube without doing that step.

Best of luck and remember to put in the solution into this threat if you figure it out.

It appears that this was related to the factory OC settings. My GPU is one of those OC edition cards, which is basically overclocked by a mild 10% or so. I had a previous issue with colorful artifact squares showing up in random places, and that was resolved by “underclocking” my factory OC card to just below what a normal RX 480 would operate at.

Well, somewhere along the way, either through a reboot or a driver update, my underclock settings got reverted back to factory specs. I dialed it back down, and now the blank area issue is resolved.

Moral of the story: VEAI must have some kind of parameter that is based on the GPU model’s standard clock. OC edition cards will cause what I expect is a race condition, which creates either artifacts or blank areas. Underclocking these OC edition cards solves the issue.

I will report this to the devs. I’m not sure how high of a priority this will be, but I feel there’s enough OC edition cards to justify it.

Also, I have a business machine with a Quadro T2000 and it performs quite nicely!

Running Windows 10 in 64 bit and an Nvidia RTX 2070 Super Gaming X here. Same issue appears now and then. All drivers are up to date.

If you can post a link to the exact card you have, I can tell for certain if you have an OC edition card. From the “Gaming X” piece, I’m assuming you do, and if so, you need to underclock it down to OEM 2070 Super clock speeds (1605 MHz base). If that doesn’t work, then try 1410 MHz.

If 1410 MHz works, but 1605 MHz doesn’t, I’m willing to bet the software doesn’t recognize the 2070 Super as a unique card, separate from the 2070. It would be good to know either way.

Ok, for reasons I do not understand, that card only lists the Boost clock which is 30 MHz higher than the regular 2070 Super. So yes, it’s an OC edition card.

Download MSI Afterburner and set the clock to 1605 MHz. Let us know your results.

1 Like

First I tested with standard clock settings again and yes, even then it might happen. Next I might test with lowered gpu clock. Edit: Guess what: Now Windows ended up with a blue screen telling me something went wrong and it has to restart. After that I replaced the Nvidia gameready driver by the Nvidia studio driver…