Bizarre color pattern during frame interpolation (GPU only)

I’ve been using Topaz Video AI for weeks in various capacities and haven’t witnessed any rendering artifacts. Yesterday, I started getting these random half or quarter-frame color patterns while running some clips through Apollo and Chronos (adjusting framerate). They are inconsistent, and only seem to appear while using my GPU for rendering.

I have a Core i7/6700 and I’m using a Radeon RX-580, which I know is basically garbage for this application, but in terms of render times, it’s MUCH faster than using my CPU, so I’m happy with the results for now.

Here’s what the artifact it looks like:


This was while rendering a simple 2s preview of Apollo (x3). It’s happening with Chronos Fast as well, but not as often.

The video card temperature and power consumption are all stable during the render. It doesn’t appear to be overheating, and again, it’s worked just fine for several weeks with the same source file, and the same rendering options. This appears to have started yesterday after updating Topaz.

Hi Matthew,

Yes that is definitely a strange artifact! Could I take a look at the app’s log files so I can consult with our dev team on what could be causing this error?

To gather logs, please select Help > File Logging and make sure that there is a check mark next to File Logging. Next, recreate the issue and then return to the Help menu and select > Get Logs for Support and attach the zip file to your reply.


Hi Tony, thanks for taking a look.

logsForSupport.tar.gz (1.2 KB)

This was a 1s preview of apollo x6. First artifact is at frame 13, but there are seven in total.

Thanks for sharing your logs, our dev team will take a look and I’ll update you with their findings.

Hi Matthew,

Our developers are suggesting that this could be caused by overheating of the GPU and they recommend using AMD’s Adrenalin GPU control tool to reduce the maximum clock speed of the RX 580 to about 80% of its current value to improve system stability and prevent artifacting.

Thanks for looking into this so quickly.

The GPU temperature stays stable at 59C throughout the render, which is the same temperature that I see with other intensive renders (like a x4 gaia upscale). The fan speed and power consumption are conservative, and the clock speed doesn’t appear anywhere near maxed out (though I’m new to Adrenalin).

I’ve found a bit of workaround. I can get an artifact-free interpolation render if I use Chronos or Chronos fast without film grain. Adding grain causes artifacts for those two. With Apollo, I get artifacts even with grain disabled.

I’ll play with Adrenalin a bit more. I’ll try your suggestion of underclocking.