Artifacting, Intel GPU, Artemis (and possibly other enhancement models)

[If you are posting a new bug, please include the following]

  1. Black artifacting/boxes form at some point of the videos while using Artemis. The artifacts stay and progressively fill up more of the video until the video is only a black screen. The file size output is also incredibly small, so perhaps the video isn’t rendering at all. Strangely, in the file I most recently tested, the main image was affected but the burned-in subtitles (part of the video, not an additional track) lasted just a little bit longer. I tried Proteus in the past where I think the issue is less common (I have another test running atm).

  2. Your system profile
    DxDiag_XC_2024_06_26.txt (124.6 KB)

  3. Your log files (Help > Logging > Get Logs for Support)
    2024-06-26-13-02-32-Main.tzlog (112.3 KB)
    2024-06-26-13-16-38-Main.tzlog (3.3 MB)
    (It’s in the middle of trying another render using Proteus model instead, which started at about 1515 so perhaps then and after is not relevant).

  4. Any screenshots as necessary
    frame 1

frame2

frame 3

by frame 7, (you can see a portion of the screen remains unrendered per frame)

frame 267 (the “karaoke” subtitles somehow, but the rest of the image is missing

frame 18353 (just a random time, to show that the video never returns after the portion is lost during the task)

It’s interesting that the portion of the image remains until its been covered in the black artifact, but once that happens it never returns.
The file result is 47.3mb, and the original file is 494mb (no scaling has performed, only Artemis was run, for the sake of the test.

This issue does not occur on the other system which runs an nvidia gpu. Both systems updated Topaz just before attempting this test.

Unfortunately the program can’t be used in this state

Usually the black frame issue is representative of an issue with the GPU not being able to process correctly. Tend to see it when the GPU gets hot and can not keep up with the AI models and processing requests.

Thanks for the perspective.
The Proteus task failed, but instead of trying again, I’m considering what you mentioned. Thinking about what I have control over, I instead considered maybe the CPU can contribute to the issue, since usually when it runs a task, its sitting around 95-100c (basically it’ll hit 100, then the clock rate lowers and it then it speeds up again until it again reaches the temp max). Well, I lowered the Max gpu memory to 80% and tried again. Also, I’m noticing something that wasn’t happening before (I think), that both GPUs seem to be running the task, I don’t think they did that, could they possibly be seen as only a single device, since they are both identical cards?
image

Strangely, with the same settings except gpu memory allowance of 80%, the task seems to be about 3x faster. I’ve no idea what to make of that.

image
Currently, all temperatures look much more relaxed, with a higher task speed… huh? By the way, originally the settings (when this post was made) were the default gpu memory usage of 98%.

I mistakenly posted a comment about the probably related known issue in the most recent ARC drivers, in a different topic I had started.

I meant to post it here

Hey, just an update.

Topaz VAI 5.2.1 and Intel Arc driver 32.0.101.5762 seems to be a working configuration. The patch notes for Intel’s driver mention it’s still a known issue, but I have been able to run proteus and artemis on the same video mentioned earlier without any of the previous issues.

Good luck with anyone else working through a similar situation

1 Like

Thank you for updating on this. Glad to hear they are back to working together.

The newest model Rhea (super cool by the way, looks nice when I run it on an nvidia gpu), looks like someone stuck butter in an old casette reader.

(original)
(rhea)

Artemis decided to be a jerk again (no changes to drivers) -v

Gaia seems fine -v

Theai -v

Nyx -v

Iris -v

Proteus -v


Guess I lied, not sure why it succeded fine with the first test. Then again, it’s still an issue being worked on.