All Attempts at Enhancement Cause Resolution Error

[If you are posting a new bug, please include the following]

  1. First time using the app in a year. Paid to upgrade to the latest version

  2. System is Mac Studio Apple M1 Ultra Chip with 64GB of memory. Sonoma 14.3.1.

  3. Attached (308.7 KB)

  4. n/a

I have searched on this issue but each one seems to be a specific advice for their machine. Honestly user shouldn’t have to jump through hoops to get the application to work given the excessive annual cost involved. Trying to upscale 4K to 8K and no matter what AI Model used get the same ‘Resolution error’ trying to generate a 2s preview.

I’ve come across the ‘Resolution Error’ before and it can be quite arbitrary. In my experience, it’s usually related to the target codec rather than the AI model used. For example, when trying to render HD upscaled to 4K (2160p) with the H265 (HEVC) codec in the MacOS, I’d get the error, while the same file and model rendered to H264 would have no problem. Alternately, in Windows via Bootcamp, the same file and model upscaled to 2160p would render to H265 with no problem, but I’d get a ‘Resolution Error’ when trying to render the same resolution to H264. Generally, If I set the target resolution slightly lower, like 2048p or 1920p, the error would go away, but sometimes, the resolution is non-negotiable.
I’ve never tried 8K, but if you have the hard disk space, maybe try rendering to Apple ProRes codec to see if you still get the error. If not, then the file size will likely be huge, but you’ll have the option to convert to a more efficient codec in another application after the enhancement processing is done. That’s been my last resort in the past. At the very least, you should be able to render a 2sec preview at your preferred resolution and AI model.

When going above 4k resolution you will need to swap from H264 to either H265, ProRes or another codec that can handle the larger resolution.