3.5.0 Iris preview diagonal lines and glitches

logsForSupport.zip (651.6 KB)

  1. Preview is generating large diagonal lines / glitches across half the screen
  2. M1 Max MacBook Pro / 13.5.2
1 Like

I’m having the exact same issues similar setup. The input doesn’t seem to matter either. I get it even if I give it a solid gray video.

1 Like

Hello, I have the same issue on my M1 Mac Studio ultra

I’ve done some more experiments with this issue.

The problem seems related to certain upscaling sizes. Starting from 720x486, I get the problem when scaling 2x, 1280x720, and 1920x1080. I don’t get the problem when any other preset sizes are used (4K is fine, 8K, 4x, any of the SD sizes. All good)

Custom scales sometimes do, sometimes don’t. Here’s some of what I’ve tried.
No problem:
2048x1382, 1920x1296, 2000x1350

1600x1080, 2048x1152

I tried various source sizes. 720x486, 720x480, and 640x480 all produce the exact same diagonal lines glitch. Starting with a 1280x720 source and going to 1920x1080 results in a similar but finer diagonal line pattern.

So specific image sizes and ratios seem to be an important part of the issue.

It also may be specific to Apple Silicon. Iris works fine at any resolution I’ve tried so far on Intel Mac. Same with an AMD/nVidia PC.

I’m running and M1 system and so far it sounds like everyone else with the issue is too. Has anyone with an M2 tried Iris in 3.5.0?

1 Like

same issue with an m1 max mac studio

No line artifacts here on an M2 Ultra with a 1280x720 2x upscale using Iris V2.

But then I remember that someone reported a nearly identical issue with the 3.4.x betas that was then solved later on - just to reappear now?

Hello, Thanks for reporting this bug. Our developers are aware of this issue with Iris v2 and are working on a fix for our next release. This currently only affects some Iris v2 outputs on M1 Max and M1 Ultra.

Hello @chad.mitchell, @micah.haun, @ronald.victoria, @steve.hugh, and everyone else,

We have identified that it is affecting Iris-v2 at 2x on M1 Max/Ultra. We have fixed the models and uploaded them.

Please do the following steps to fix this:

  1. Locate the model folder. You can find it in the Preferences > Directories > Model Folder.
  2. Delete the coreMLCache folder in the model folder.
  3. Delete all the iris-v2-*-2x-13-mlp.tz files in the model folder.

The next time you run the process, it should download the fixed models.

Please let us know if it solves or doesn’t solve the problem. Thanks.

1 Like

yeah, that seems to fix it- nice work!

1 Like

Where is the Folder “coreMLCache” located? I can’t find it on my Mac

Here for me
/Applications/Topaz Video AI.app/Contents/Resources/models/coreMLCache

It’s inside the Topaz application so if you’re going through Finder, you’ll need to right click Topaz and click “Show Package Contents”

The lines are gone, but I did notice when I go to export a file, it says “iris1” at the end of the filename instead of iris2. Is there a way to check which version it’s using and force it to download use 2 if it’s fallen back to 1?

After comparing results, it appears that the M1 mac is using Iris v1 even when told to use v2. To test this, I enabled old models on both my intel and M1 mac. Then I made 3 outputs of the same source file: iris v1 and v2 from the intel, and “iris v2” from the M1 mac. Comparing the results, I get differences between the “v2” outputs made on each machine, but I get solid black comparing intel iris1 to m1 “iris2”.

Seems to be fixed! Thank you very much.


Can you confirm this is getting you iris 2 and not just iris v1? It seems like it’s not actually running iris v2 for me after following the fix steps. I’m not sure if it’s just me. See my earlier post for more details.

Hi @micah.haun, is it possible that the iris-2.json file got deleted from the Model folder? Please note that the steps require to delete only the .tz files. Even if it has happened, a clean install with the DMG should solve it.

To verify, turn on the Enhance filter and select Iris. Press Cmd+Shift+P, and you should see tvai_up=model=iris-2 somewhere in the command. Also, after running the process, the Model Folder should contain the iris-v2-*.tz file.

Please let me know if you are still facing the issue. Thanks.

It seems to have somehow fixed itself today. It’s now saying “iris2” on the end of the files. I reran the same test and now it’s nulling with the iris2 results from the intel mac and not the iris1. Not sure what to make of that but I’m glad it’s working.

I didn’t delete the json file. Just the tz files. I did try restarting Topaz a few times when it was having issues and that did nothing. I think I ran a system update which restarted the laptop somewhere in between. Maybe that made the difference?

I think I figured out the iris1/iris2 issue I had. I was using a preset I made in an earlier version. When I used that, it was still setting it to iris1. If I build new settings for scratch it would be iris2. I don’t have “Enable Previous Models” on so it’s strange that this happened. I deleted the old preset and made a new one.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.