2020 iMac bricks when only using VAI

Ever since I updated Mac OS to Sonoma, TVAI bricks my Mac while converting. It seems to clip either the GPU or CPU I can’t tell but I do know the fan spins up quite a bit before it bricks my computer. I then need to hold the power button down to shut down the computer, it then takes about 20 seconds before it will be begin to reboot and the Mac feels very hot to the touch so I think it;s overheating the GPU. This was never an issue before Sonoma and I would let movies run overnight without any issue, this is specific to Sonoma and has only been an issue since upgrading. I even ran VAI version 2.6.4 and it still bricks but it takes much longer. I have attached my system profile so hopefully this helps diagnose the cause. At this point VAI is useless to me and I have been using for 2 years without issue.

Thank you


iMac.spx (7.8 MB)

I had Mac computers exclusively between 2008 and 2018. They all were great machines with a lot of power but not made for the hard work and often got mechanical problems after three years. I even had the first model of the 5 k iMac and that one ran hot - 99 °C CPU and 105 °C GPU - and loud when the single fan ramped up to only 2000 rpm. It was a hard decision for me in summer 2018 to go back to Windows, but for Video AI it was the right choice!

This isn’t really fitting here because:

  1. as he said TVAI did run until Sonoma - so this is likely a software problem. And we’ll never know if it’s Apples or Topaz’ fault I guess.

  2. Yes, that rig is quite slow / at the lowest end for TVAI - but this especially due to the use of “windows”/ standard PC hardware. You must compare Apples computers to Notebooks or mini-PCs as they used the same components due to their form factor.
    And there was nothing only remotely powerful from neither Intel, nor AMD, nor Nvidia. Which was (one of) the reason(s) for Apple to go with its own chips oil the first place. And the AppleSilicon machines are really fast (again: compared to Notebooks/mini-PCs)

@matt.lonzi: I can only think of three “solutions”:

  1. Try the Sonoma 14.4 Beta if this solves things again
  2. do a downgrade to Ventura (OK, I know this is painful)
  3. Try to enable the “low power mode” in TVAIs settings (under “Processing”). But this will likely bring a big speed penalty.

Thanks for the reply.

I have enabled low power mode and it has made a big difference. I have been running VAI for about 30 minutes along with Youtube and there has been no issue. That said, it leads me to believe that VAI is clipping the GPU causing it to freeze. Perhaps Topaz can have a suggestion pop up when launched on Intel Macs running Sonoma to run it in LP mode to avoid any crashing/freezing issues.

Thanks again for the help and suggestion.

If using low power mode avoids the problem then it seems the hardware is stressed more under Sonoma than it was under Ventura :-/
Maybe a heat issue? Try if you can get TVAI running without low power mode by setting the fans manually to maximum…

I’m a little disappointed. “To brick a computer” means to (usually accidentally) turn a working computer into something as useful as a brick—with no option to get it back into a working state.
I feel like I fell for clickbait.

Even with that, I still hope you get it figured out.

Your iMac has not the computing power to work faster. It is still a good machine but not for this type of work. :disappointed:

1 Like

Our developers are currently in contact with Apple about an issue related to Mac systems with AMD graphics cards. We don’t have a full solution currently but you can change the max memory % in the Preferences Panel to 20% and turn on the low-power mode.

Without a solution from apple to address the hardware issue we are not able to move forward on this. You can open a ticket with the Support team for further options.

Thanks for reaching out.

I have enabled low power mode and reduced the memory maximum to 95% and there has been no issue the past few days. It does run slightly slower but the results are working.

Thanks again.

1 Like

For the record, downgrading to Ventura will NOT solve your problem. I’m using a 2019 MacPro with an AMD Radeon PRO W6800X card, MacOS Ventura 13.6.1 and I still have to set it to low power mode to avoid hard crashes. This behavior started (for me) with TVAI v4.0.1 and if possible I’d go back to 3.X, but for some reason, it appears that I can’t. Running in low power mode is not a ‘solution’, it’s a ‘workaround’. But if we’re waiting for Apple to provide some sort of permanent solution for a random application on their Intel Macs, then I wouldn’t suggest holding our collective breath.

The first time it happened my Mac wouldn’t reboot for almost 9 minutes. I thought it was toast.

Sorry to ‘click bait’ you. But the workaround is posted if this is an issue you are finding on your computer.

1 Like

My point being, a ‘solution’ and a ‘workaround’ are two fundamentally different things. For a ‘solution’ I would gladly cough up the money to upgrade to whatever the latest version of the software is. For a ‘workaround’, I’ll stay right where I am as it’s better than nothing. Particularly since there appears to be zero movement on this over a month later.

And i don’t want this thread to die.

The iMac series have a good computing power overall but some models especially the early ones with the thin case lack of cooling: Apple fitted only one fan to cool down both the cpu and gpu making an early 5 k iMac run on 99 °C cpu and 105 °C gpu all the time during play for example. Video AI is even more demanding. These Macs are made with the priority on the design and that’s what causes such hardware issues I am afraid. I had 4 MacBooks and 3 iMacs between 2008 and 2018 and reverted back to a Windows PC which was a hard decision but at the end a logical one. :frowning:

I absolutely agree that you made the logical choice. However, as i mentioned before, I own a 2019 MacPro with both an AMD Radeon W6800X and a W5700X card installed, not a MacBook nor an iMac. Even so, I still have to use low power mode and reduce Max Memory percentage to avoid hard crashes that force a system reboot. VAI is the only app I use that causes this. The fans don’t even kick in before this happens, so heat is not an issue. When I run low power mode and reduce max memory, VAI works ok, but slow and I can run several other apps at the same time while it runs in the background, which is nice. I just wish I had the option to run it at full capacity and see a corresponding speed boost for those times I really need it.

I am not too familar with the latest Mac Pro series. If it is still an Intel machine maybe set up Bootcamp for native Windows as a workaround just in case that works without any issues. :eyes:

Well, it’s certainly not the latest MacPro series, but it does run Bootcamp. Still, I never thought of that! You mad genius! :wink:
I usually only boot into Windows to play games.
I’ll run a few tests and see how it goes. :crossed_fingers:

1 Like

I am simply running VAI in low power mode and everything is fine. Its not much slower than normal mode so I don;t miss it. I run my 2020 iMac LP mode and memory set at 95%. No issues since. No need to run bootcamp, you won’t notice much of a difference.

Did you try it or is this just an assumption?

I’d definitely give running a native Windows through Bootcamp a try as the gfx drivers are mostly better there and much more up to date.

Ok, I did a bit of testing under Bootcamp, and yes, I can run VAI at 100% max memory and no low power mode without it crashing (low power mode doesn’t seem to be an option on the Windows version - at least not in the version I’m paid up for - 4.0.9).

To matt.lonzi’s point, no, there isn’t that much of a difference - at least not in Bootcamp. The last time the AMD drivers for Bootcamp were updated was in June 2023, but maybe in a purely PC/Windows environment, things may be better.

For me, under the MacOS with the max memory reduced (I don’t use low power mode as it seems to work fine without it), upscaling and enhancing HD video to 4K takes about 0.75 seconds per frame to process. Under Bootcamp (Windows 10) at 100% max memory, the same file takes about 0.64 second per frame. A small, but not insignificant speed boost. Windows has other idiosyncrasies that make it a pain to deal with, but when a heavy workload and tight deadline hit, 0.11 seconds per frame savings could make all the difference. Good to have the option.

Still not buying the update until the Mac version is fixed, though.

When you use Bootcamp you do have a “purely PC/Windows environment”.
Since this is then a native Windows install on normal PC hardware and behaves exactly the same as it would on a notebook or mini-PC with the same hardware. The install cannot “know” that it’s a Mac its running on…

1 Like