Workaround for TVAI crashes in Windows, encoding errors

I’ve been using Topaz Video AI on my machine, which is pretty powerful – with 96GB of RAM, an i9-14900KF processor, and a GeForce RTX 4090 GPU. Even with the max memory set below 100% and selecting GPU as the AI processor in Topaz Video AI, I was perplexed as to why a machine with this horsepower would crash during processing.

However, after stress testing the CPU, RAM, and GPU, all of which came back without error, and ensuring my video driver is the studio version and up to date, I found a couple of workarounds that have helped me:

Machine Crashes: If your Windows system crashes using Topaz Video AI, try lowering Windows’ CPU power consumption by 1 or 2%. To do this in Windows 10 or 11, search for “Edit Power” in the Windows search bar and select “Edit power plan.”

This will take you to the Power Control Panel. From there, click on “Change plan settings” next to your desired power plan, then select “Change advanced power settings.” Look for the “Processor power management” option, expand it, and then adjust the “Maximum processor state” downward by 1 or 2%. I have mine set to 98%. This tweak has helped me prevent crashes during processing. Lowering the power consumption might change the FPS processing rate by 2 FPS. I’d rather have a slight speed reduction than a crash and an unusable clip.

Clip Encoding Errors: Sometimes, even without a crash, Topaz Video AI might stop with an error for a particular clip. In such cases, I’ve successfully reencoded the clip using Handbrake. After reencoding, I upscale/enhance the clip with Topaz, which usually works without any issues.

It would be great if TVAI could somehow limit the CPU power consumption from inside the app while it’s running. Regardless, I love using Topaz Video AI, and I hope these workarounds help you too!

If the machine crashes, it’s not TVAI’s fault. It’s your system that’s unstable. TVAI is an excellent stress test (benchmark) to ensure you have a stable system.

What you can do to verify that it is indeed your system that’s unstable and not the software, run Prime95 on low process priority. At the same time load up furmark and run AIDA64 memory benchmark simultaneously.

You want to stress your memory controller to the max, while saturating all your CPU cores, the video memory controller and generate as much heat as possible from the GPU and CPU. If you can run like that for an hour without a system crash, then you have a stable system. Once you’ve validated you have an unstable system, you’re already on the right track as indicated by you fiddling with the energy settings. Limit CPU power consumption (e.g. under clocking / lowering core voltage in BIOS) if you still get crashes, try increasing the voltage to the DRAM a bit, then tune your memory timings. If all that fails, either your PSU is underspecced or your memory isn’t good enough; so look for SK Hynix a-die memory.

I had to spend a week to and from doing such tweaking on my Ryzen 9750x with 128 GB DDR5 RAM and (also) a 4090 before mine was stable.

Thank you, and IMO, for these suggestions.

Let’s be clear. I said I love the software. I am not trying to fault TVAI. I was simply looking for a solution to help me upscale footage for a project on which I had a hard deadline.

And, with practically every other GPU/CPU-intensive bit of software I use – including Blender, After Effects, and Premiere - my system is rock steady.

My amateurish workaround worked, albeit with my CPU not running in turbo mode.

I hit my deadline. And really, that was my goal. I didn’t have a week to tweak, poke, and prod. I had to get assets out the door.

I appreciate your suggestion, Jojje – and running Prime95, Furmark and AIDA64 per your suggestion bore no crashes

I have since rabbit-holed to deeper solutions inside the BIOS on my machine.

I found that my BIOS was defaulting to CPU power consumption way beyond Intel’s recommended specs. I have set two key parameters based on the recommendations.