Wierd fuzziness bringing image in from PS

I am trying to to process an image of a leopard which is pretty sharp in PS. In PS I’m just going Filter/Topaz Studio/Clarity which opens Topaz studio. As soon as it comes it it looks really blurd. I set the clarity workflow to 0% in case something was being added. I have not had issues that i have noticed before with previous sets of images. The processed image is just terrible compared to the original.

Its like either the image has come into topaz at much lower resolution or some fuzzy adjustment is being automatically applied somewhere. Any suggestions appreciated


Way to go @masplin welcome to the Topaz Forum! :slight_smile:

There is a lot of information you haven’t stated.
1 Is this the first time you have used Topaz Studio or has it been ok and just recently started to look blurred?
2 What Graphics card are you using (use the Help menu > Graphics Info)
3 Have you tried using Topaz Studio without PS and are the results the same?
4 Clarity is a preset list (or one of the Basic adjustments), not an adjustment in Studio so the PS link looks odd. It should just be filter/Topaz Studio.
I’m not tech support and don’t have this problem but if you contact them you should give them this info.

  1. Been using it about 6 months. Processed a bunch of tiger pictures a few months back which all came out great. Only really noticed the blurring because the hairs are so crisp on the original NEF.
  2. GTX 960 Nvidia (same card as before)
  3. So I tried two things. directly opening the NEF file in Topaz studio, but in looking like their was a mist over it. Using “Edit in” from LR directly to PS. LR creates a TIFF to send to the external editor. I then saved that TIFF in Topaz for comparison. The TIFF sent by LR looks the same as the NEF, but the one saved in Topaz is blurred. So the blurring seems to occur as the file is opened in Topaz.
  4. In my PS when i click on Topaz Studio under filter it shows me several choices, one of which is clarity. The bottom one is Topaz studio again, but outcome is the same.

The only thing I’m aware of that has changed since i last did this is a topaz software update. sadly i just processed several hundred building pictures. i didn’t notice the difference as no really fine detail.

I’ll fire something off to tech support with the extra info.


I have complained about this since the introduction of Studio and was told it was a known fault. I would have thought it would have been fixed by now…

I don’t use Studio because of this.

Thank you so much for that. Been told by support it’s a problem with my graphics card or something!!! Bizarrely it’s only on some images and even if I reboot still the same image.