Video Enhance AI V 3.2.0 Transport Stream Videos?

Running Video Enhance AI under Windows 10 Pro 64 bit.

Downloaded a video from Dailymotion. Video is using the TS (Transport Stream) container. File size is 320 MB, and video resolution is 632 x 480 and in progressive scan format.

Tried to upscale this file 2x using the 2x upscaling option in VEAI. Encoder selected was Prores 422 LT.

On running VEAI, the appropriate module was downloaded and installed to VEAI. Then on the start of the actual upscaling process, the process stopped with an error. The error message was not specific, so it was unknown what caused the error.

Tried several times to upscale the video, but the process stopped every time with the same error message occurring.

Can Video Enhance AI (V 3.2.0) actually process transport stream (ts) videos for upscaling?

If so, then why doesn’t VEAI upscale my video?

.ts files are well known to contain errors as they are generally live stream recordings… I work with them everyday. That saying it should be able to process the file although prob with sync issues.

Try using the ‘auto’ setting for the audio instead of ‘copy’. Using copy gives me an error on .ts input as well.

1 Like

Good point I remember I had problems with streams that used the opus audio codec a while back.

1 Like

it should work (on v3.2.0)

image

mts is not ts :stuck_out_tongue_winking_eye:

1 Like

it the same family :slight_smile:
Anyway, FFV1 (lossless) the TS file in Hybrid (or AviDemux), then use the FFV1 file in Topaz. problem solved…

(ignore the de-interlacing portion of the post in case your TS file is progressive scan)

Might be the same family but .mts adds a 4 byte time code compared to a standard .ts stream and is only found on camcorders, Blu Ray disks unlike .ts which is broadcast.

1 Like

Comments noted, thank you!

Tried to upscale the ts video again (x2) and checked that the Audio setting was on Auto (which it was). Unfortunately VEAI once again stopped with the error message “Unknown error”.

If anyone has the time and inclination to check out the video I’m having issues with, this is the (download) link -

Thank you.

hello, as akila said, import it into hybrid, put the filters of your choice, without using qtgmc if it is already in progressive, and export it in lossless ffv1, or lossless h264. it will solve your problem.

I don’t know how your grabbing it but I’m getting it in mp4 format not ts.

1 Like

with Internet download manager it appears to me as “ts”

image

Screenshot_20230419_185312

Just a quick sample with Proteus Auto

It downloaded as a .ts file for me with IDM as well. Got an error trying to use copy for audio but had no issue processing it with auto set for audio:

Edit: I used v3.2.2

there’s a way to download a video from the internet with microsoft edge, in the same quality as it is on the streaming platform, so it works with some sites, with youtube it doesn’t work, and dailymotion I don’t have tried it, do it like this:

on the web page of the video, press f12, it opens the development console, you have to go to the network tab, reload the page and start playing the video, in the “type” tab at some point it there will be “media” which is displayed, right click on it, then on “open in a new tab” and from this one you can download the video.

it’s a good way to download videos in the best quality when it’s on not very well known sites or it doesn’t work with apps, for dailymotion normally there is not too much trouble, but all the videos that I downloaded, whether online or with apps, on any platform, it was in mp4. the bitrate varies depending on the source of the video, as does the resolution of the video.

I got it like this with 4k video downloader

I downloaded this video using IDM as well. Resulting download was in ts format as stated in my OP.

Upgraded VEAI to V 3.2.2. Tried to process the ts format video again, by selecting x2 upscaling (with Proteus), encoder set as ProRes 422 LT, audio set on Auto.

Guess what? Once again the video failed to be processed with an “unknown error” message again!

So even with the very latest version of VEAI, I still can’t process this ts video using the settings as described.

So it seems I’ll have to convert the ts video to ffv1 first, as mentioned above, and then process the video using VEAI(?)

1 Like

well the best yes is to re-encode it in mp4 lossless or ffv1 lossless, making sure to convert it to avi. but you will have to download it directly in mp4 on an online site or you put the links of the video directly. strange that you got it in ts, I actually tried with a vob file, from a dvd apparently, it didn’t work either. in fact for the ts format, I never tried it seems to me.