Video Enhance AI exports variable framerate conflicts with Premiere Pro

I am getting some great looking results from Enhance AI but am having new issues when importing the files from it into Premiere Pro. I previously was able import and work with these full files in Premiere, but after some system reconfiguring and new attempts in Enhance AI, which improved the quality of results from Enhance when played back externally, now I can’t seem to access the full files in Premiere. I don’t know what has changed that is causing this.

The full video file appears to have processed, based on watching the progress within Enhance AI, looking at the file size (very large) and runtime (the accurate length), and watching the file in an external video player (where it looks great and plays all the way through). However, when I import one of these files into Premiere Pro and bring it into a timeline, it only shows 30 seconds or so of the file in the timeline. (Same in the Source window - it only shows a fragment of the file.) The full file just doesn’t seem to be accessible at all in Premiere for some strange reason.

This is an issue I was not having before - I had previously been able to work with full files, though we were having other glitching issues from Enhance AI that are now resolved after our system improvements. Anyone else have this issue or have insight? Thank you!

You may want to check on the Adobe forum also.

Good point! Doing that now. Thanks

This file plays fine in some external video players, but I did get the error message when trying to open it in Quicktime: “Error -2002: a bad public movie atom was found in the movie [file name]” and I don’t get this error message when I try to open movie files previously processed in Enhance AI that do work in Premiere Pro.

I spoke with Adobe support and they thought the file might be corrupted. I tried some more small tests with the same settings. When I processed very short clips through Enhance AI, they came out fine and play fully in Premiere Pro and Quicktime (without getting the above-mentioned Quicktime error message). However, all of the recent longer videos I’ve processed through Enhance AI do not fully play in Premiere and get the Quicktime error message about “a bad public movie atom.” I was able to process long videos with the same settings on our old computer and they worked fine in Premiere Pro, however they did feature visually jittery playback caused by repeated frames. Our new system is faster and the videos processed by Enhance AI now don’t have the problem with jittery playback/repeated frames, but now we’re getting the problem of the full videos not playing. No adjustments to settings, just a new computer (new hardware and they copied our old startup drive to preserve our programs). Sorry for all the details, just been doing some troubleshooting and looking into all possibilities. I’m excited to have Enhance AI generating files we can actually work with in Premiere Pro, because they look beautiful.

Update from Adobe help: they said the problem was due to the variable framerate of the video and it would need to be transcoded to a framerate of 30fps or lower in order to work in Premiere

So now the question is: is there a way to have videos come out of Enhance AI at an acceptable framerate for Premiere Pro?

Or is there an alternate method of transcoding besides Handbrake (which would compress and reduce the quality)?


I’ve successfully used Enhance AI previously, but after a system upgrade, I’m running into problems with (as far as I can tell) the same settings in Enhance AI creating video files that are unusable in Premiere Pro and Quicktime, though playable in other video players.

Adobe support seems to think the culprit is the variable framerate of the videos coming out of Enhance AI.

I’ve been processing them as MOVs and was previously able to edit these in Premiere Pro (though I was having trouble with some repeated frames, so something strange might have been still going on with the framerate). But now when I bring the newly created videos in, they only show up in Premiere Pro as the first minute or two. (Current short test videos from Enhance AI work fine in Premiere/Quicktime, but longer ones have issues.)

In Quicktime, the problem filesdon’t open and I get the error message “Error -2002: Bad public movie atom.”

The codec for both the old (functional) and new (non-functional) files is Apple ProRes 422 HQ (apch). The framerate is different between the old and new, with the old ones being at 59.940060 and the new ones being at 59.940176 and I do see ‘Decoded format: Planar 4:2:2 YUV 10-bit LE’ in the Codec info for one of the new files, and this is not present on the old ones (or on the other new ones). However, I ran a few tests of very short clips of the same footage through Enhance AI and got new files that do open in Quicktime (and with no error message) and are at the same framerate as the other new files (59.940176). It seems with the longer files that something goes wrong.

Could there be bad frames? Or corrupt files? When I process the problem files in Handbrake, the resulting files play in their entirety in Quicktime and Premiere Pro, but I can’t use these, as they are compressed and too small, and we need to be able to work with higher quality files.

Adobe help suggested transcoding a framerate of 30fps or lower in order to work in Premiere. Is there either a way to do super high quality transcoding somewhere (in Handbrake or another program) or to (and this would be optimal, if possible) process files in such a way in Enhance AI that they would be usable in Premiere Pro? It’s odd I could get ones that worked previously but not now!

Any help would be greatly appreciated!

[Additional note: Adobe Media Encoder has the same issue as Premiere with these files.]