Video Enhance AI doesn't seem to be using my GPU

H, I have an HPz820 PC with dual 12core 3.5Ghz and a Quadro K5000 GPU. Despite setting the process to use the K5000 (and restarting) when I start rendering and go to the Task Manager the CPU is near 90% and the GPU is showing 0%. Am I missing something? At the moment frames are taking around 9 or 10secs to render.
Using VEAI v 1.2.3

Thanks
Nick

1 Like

Actually I think you have set on CPU Processing
Otherwise if it is GPU.
Click on one of the 4 usage boxes and change it to CUDA :slight_smile:
From your screenshot the GPU memory usage is not being used so I am pretty sure you are set on CPU

Definitely set to GPU my choices are CPU or K5000 and I have it on K5000. Can’t see a setting for CUDA. Where would that be? Interestingly if I switch to CPU the programme crashes after it Initialises the AI engine.
Screen shot of process settings for K5000:
https://drive.google.com/file/d/15xRGGYET29Tvd9QpqSnOc359rRF8GJGX/view?usp=sharing

Hey man, sorry I mis-understood you the first time I read it. I m not sure if K5000 is supported or not as a GPU :frowning_face:

NVidia K5000 is a 4Gb Cuda capable GPU.
Topaz minimum specs are: Any Nvidia GPU with 3.0GB of Dedicated VRAM and 3.5 compute capability or greater. I’ll check driver and OpenGL version but I’m pretty sure I’m running the latest.

1 Like

My experience and tech support information may be relevant. I have a very powerful Quadro M4000 8GB video card which works very well with all of the Topaz AI programs except Video Enhance. Tech support had me send them various troubleshooting files and told me why it was not working.

All of the RTX video cards have built in hardware AI processing capabilities, which Video Enhance requires, and although my Quadro had them, they were not new enough to do the processing. So I was out of luck. So I ended up buyin an RTX 2070 Super card w 8Gb (PNY blower version) which works just fine. I hope this information is helpful.

Thanks for the info Dan. Sounds like that may be the problem. Would be nice if Topaz chimed in to clarify.

I’m having the same problem with a Quadro p2000 - basically no GPU usage despite selecting it in the preferences, restarting the app, etc.