Video AI 3.0.0 - Nvidia Driver Error

When I set the encoder to H264 (NVIDIA) of H265 (NVIDIA) the video fails to be processed and “Driver error” is displayed. I suspect this is down to my having a relatively old Nvidia driver installed on my Windows 10 system, i.e. v456.71 and hoping it’s not down to my GTX 1070 video card no longer being supported.

Can someone please enlighten me as to what the MINIMIUM Nvidia driver version I need to have installed for Video AI 3.0.0.

My current driver and setup works fine with Video Enhance AI.

the actual driver is 522.25

1 Like

That’s the very latest driver. My question is what is the minimum or earliest driver prior to 522.25 that works with Video AI? Or is 522.25 the minimum required?

1 Like

I have 512.96 installed on my GTX 1060… but I detest the results of the H.264/5 encodes from it at any setting—so I have not tried it to see if it works.

Thanks @ForSerious. From what I read 472.12 and 512.95 are the most stable recent releases so I installed 472.12 and found that this was enough to get H264/5 encodes working on Video AI 3.0.

I’ve found that the encoding speed is about 20% slower with Video AI 3.0 compared to Video Enhance 2.6.4. That said, the encoding speed is extremely slow at around 1 fps or 1 second per frame. My GPU usage during encoding is minimal (max 5%) even though I have my GPU selected in the settings. I have to wonder if the GTX 1070 is supported for GPU encoding.

@ForSerious - what encoding speed and GPU usage do you get?

What model are you using, what is the source resolution and the target resolution?

It can actually take longer to upscale a 1080p source to 4K than a 480p or 720p original because there are more pixels to process.

FWIW, I am upscaling DVD rips of Star Trek Deep Space Nine. These have always been tricky to upscale because the live action is 24fps, but the CGI is 30fps. In TVEAI 2.6 it took about 2 hours to upscale a 45 minute SD original, but produced an output that stuttered frequently. TVAI 3.0 takes closer to 3 hours, but produces a perfect VFR output. BTW, running two upscales at once took 5 hours, not 6 and running 3 at once took 7.5, not 9 - so if you have multiple files to process there is a definite advantage to running 3 at once.

My rig is an Intel i9-12900 with a Nvidia 3080Ti (AIO cooled). Using Proteus I push GPU to about 50% to 60% on average, when running 3 upscales - I also pull about 600watts, according to my UPS.

1 Like

Just noticed that you have a GTX-1070. That doesn’t have any Tensor cores for AI processing, so all it can be used for is floating point calculations and basic DirectX functions like compression and muxing the output. Everything else is on your CPU.

It’s not amazing. It’s like 0.175x. I’ll check in about an hour to see what FPS that translates into.
For my 1060 I have to look at graphics_1 in Task Manager to see how much it is being used.

Oh I just remembered I never installed 3.0.0 on that machine. It’s running early release.
It’s getting 3.7 FPS on Proteus 853x440 to FHD scaling.

I’m running 512.96 of the Studio driver and it works fine provided I pick an encode option the card (RTX2060) supports, e.g. H.264 High (Nvidia).

Thanks for highlighting the need for Tensor cores. I’m pretty new at this so still learning. So, I guess that means I have to suck up the slow processing or upgrade to a different GPU. Good to know.

A quick test on Video Enhance AI 2.6.4 gives me 0.8 sec/frame using my GPU, but 7.8 sec/frame using only my CPU. So even with my current GTX-1070 GPU I get an enormous speed boost so that’s good.

BTW - currently I’m processing some old 8mm cine footage that has been captured at 1440x1080p 24fps. I’m putting it through Artemis Low Quality to denoise it and add black sidebars to output 1920x1080p.

I just upgraded my driver earlier today. I believe that the minimum is 520, in the popup. This is not available from Nvidia. If you download the driver from Nvidia today, it will fix the problem. If you cannot use the driver, just download the latest version.

Yeah, looks like v3.0.1 now requires Nvidia driver 522.25 as a minimum. With v3.0.0 I had it working with Nvidia driver 472.12.

1 Like

FWIW, I updated my driver today to the latest version and 3.0.1 still says my driver is too old. FFMpeg also keeps screwing the pooch, so basically I’m stuck on 2.6 on my windows machine, and can only use 3.x on my M1 Mac, which, you know, ain’t great.

10/18/2022 522.30 released

So I just got my RTX 4070Ti And I keep getting this error even tho I have installed the latest driver. I think that instead of a game ready driver it requires a studio driver and my friend is telling me to buy a quadro gpu and I cannot afford it since I am trying to save money so, I have came to a conclusion that it requires a good gpu and a good cpu (I think) so it render with no struggle.

For me on my GTX 1080 Ti I am getting around 105% faster encoding/processing speed gain with TVAI v3.5.0 compared to what i am getting o VEAI v2.6.4 with the same video/settings.
But also bear in mind that since v3.0.0 (which you are running with, based on your post title) there were two major releases that focused on performance.

If you just want to run TVAI, a Quadro will be a waste of money. There is a difference in NVENC with the 4070 ti compared to any card you might have had before. You may need to reinstall TVAI to resolve that—if you’re getting the same error as the opening post. If that doesn’t do it. Maybe try DDU (Display Driver Uninstaller. Search for it.) to clean out anything leftover from your old GPU. Then reinstall the 4070 ti drivers.
Lastly, there is no real difference in game ready and studio drivers. They are the same, but the studio driver is released less frequently in the name of stability.