Upscaling X-Men animated series

Using multiple AviSynth filters and VEAI

This is the best I could do after trying all sorts of filters for like a year.

I have a quick question - A lot of my early CGI mucking around used filters and process in Topaz specifically designed for this kind of animation.

I am curious how this would fare to your efforts and whether it might help, or may also make things worse, especially the time you said you have put into it. I don’t have this original DVD content however.

Are you able to upload the opening/ending sequence only from the original VOB for me to play with? (If that is at all possible). Obviously not entire episodes as then copyright has an issue, and I only need an extract.

Entirely up to you, I am just waiting for a new DVD set to arrive so I am inbetween starting a newer project.
Using TMPGEnc MPEG Smart Renderer 6, no re-encoding

I have a feeling that the DVDs were sourced from VCR master tapes, and the people that did the conversion to DVDs tried to deinterlace the VCR source, but then had to interlace the files for the DVDs, because lot of frames are blended, especially the interlaced ones. There also seem to be sharpening halos all over. There’s also screen shaking from unstable film reel?? Disney should get back to the original film elements and remix the series.

Ok so I spent way too many hours in one evening trying to decipher what was done to this footage. I think, with a bit of confidence though could be wrong as Anime conversions I don’t look at often, that in general the following occured.

Anime is notorious for being VFR content, so it looks like the underlying sequence was field blended to 23.976 and then Telecined to 29.97 for broadcast on NTSC. When TFM is run on it, virtually all evidence of interlacing is removed, which is what happens on telecined content.

The blending looks like it was done on the original framerates of the source, which vary depending on the timecode and what frate the original happened to be at the time - so attempting to revert the field blending using SRestore gives me examples where I can recover a bunch of frames in a row, and then blended frames come back up again.

I trying using various cycles for the frame blending, but the only results I kept getting was the cycle that was the “least offensive” so to speak. That is, I think it would be virtually impossible to recover the original content properly from this source, only mitigate the damage.

On the actual upscale, I spent so long working out how to deal with it, that I basically threw it into Topaz with few adjustments, so it will not mimic your efforts to get it as best as possible by a long shot - I didn’t even experiment with pre-processing filters to try and clean up the footage - but the older CGI model for this kind of content can be quite good, so I just upscaled it to see how it went.

This was that result. If there are aspects that you like more, I posted below explicitly what I did just n case you want to experiment (make sure to download the file to watch, don’t stream it):

Process was just export via Avisynth to images with this script, after generating the d2v file on it:

SetFilterMTMode("DEFAULT_MT_MODE", 2)

srestore(frate = 23.976)


Then upscaled using Gaia CGI in version 1.5.3 of Topaz. Note that this version is important. Version 1.6 broke the CGI model and it hasn’t worked properly since.

I’m trying tp use filldrops and srestore plugins. I think I’m getting smoother motion with those. I’ll also do another 24fps version and see how it looks like.

I wanted to try v1.5.3 but the download link seems to be broken.

Apologies, been a little sidetracked - if you mean the official link on these forums, yes I have no idea why they broke most of them, but they don’t seem to be in any hurry to provide them.

Thankfully Glynn on Facebook has been maintaining a sheet of versions with links you can use to download just about any version you can think of:

But for 1.5.3 - VideoEnhanceAI-1.5.3-RELEASE-windows-installer.rar - Droplr this one should work.

I will mention a couple of notes before using this:

  • The installer will overwrite the existing install and it doesn’t gie you an option. These older installers will also delete the existing directory contents even if you cancel before proceeding, so make sure you have the version you also want to keep copied, or the install file for it available to return back if needed.
  • I cannot work out if this is just a me issue, but sometimes in the last 12x months, the older versions broke for me slightly. When you preview or process it sits for ages trying to load the model, and will either do nothing or crash. In the logs it suggests its trying to communicate with Topaz for something, which has since broken, so I think it gets stuck. If this happens to you, my workaround is simply to crash it, reload and choose reload last and try again and if nothing happens within a minute or two of trying, repeat. Usually after 2-3x attempts of doing this it will then work normally. No idea why - just very temperamental on my machine.

But if that last point is just my machine issue, you may not experience it.