Unable to install topaz studio 2 (Solved)

I had topaz studio 2 beta installed on my PC.
The software asked me to update for a new version.
Since impossible to install the latest version the download for multiple files crash.

Here is some pictures of differents messages!
topaz2|505x511 topaz


Thank you in advance for help me to resolve my problem.

W10 Build 1909 18363.535
Antivirus Malwarebytes 4.0.1


Problem solved!

Stop the execution of Malwarebyte and install again Topaz studio 2, after installation restart Malwarebyte.



Having exactly the same problem and same screen coming up on 2 separate computers; neither of which is running any Malware software?

So this is another problem that must be investigated …
and I don’t have the solution.
Maybe disable Windows antivirus software???

Done that already, can’t be bothered with it anymore. I’ve still got the original Studio installed and I thought it was a better interface anyway, I’ll wait for the next update and see that installs OK, Had no trouble installing the beta Studio, although I don’t remember it being called a beta when I installed it?

There is no beta available for the general public, probably just the text on the installer. The only location to download the installers is from here:


The current version is v2.2.0 and if you have trouble installing make sure you have admin privileges.

I’ve downloaded the program from your link although it’s called Studio and not Studio"2" which adds to the confusion. It installed with no problems and works OK, it hasn’t however integrated into Photoshop and only runs stand alone. The last version I tried would install itself OK but when it ran it would come up with a sign in screen but before you had chance to sign in it would once again go to an installation screen and start installing itself again and it was this second install that would crash out every time giving the same reason for crashing as in the pictures above byAlainC. I have noticed that the previous installation file that I’d been using had underscores as separators and all lowercase as in “topazstudio2_online_installer.exe” but the one I downloaded from your link uses hyphens as separators and each word begins with a capital letter as in “TopazStudio2-Online-Installer.exe”. I have also noticed that as well as a Studio2 icon being placed on the desktop using the the installer from your link that there is now also an Installer.exe icon placed on the desktop and if you click on the Installer.exe icon it does exactly what it did before i.e. crash out! So it looks like the alternative Studio2 installer was jumping straight from the successful install to the other installation file without any user interaction and crashing out every time. Weird or what? Anyway it’s in now but without PS integration?

You must run Studio, or Studio 2, as a standalone first ensuring that PS is not running at the same time to install as a plugin.

Is the only valid installer.

I did use your link to install and Photoshop wasn’t running, I’ll persevere with it.

Have you:
topaz topaz2

Help/About for the version!

Got it going in Photoshop now, it installs Studio2 into a folder called “Topaz Labs LLC” within the Program Files folder and not into the “Topaz Labs” folder in the Program Files Folder, I should have noticed during the install process but as usual I just kept pressing “next” . If you copy the Studio2 folder from the LLC Folder into the Topaz Labs folder in the Program Files (x86) (which is usually the folder Photoshop is already using on a 64bit system for plug-ins) or into the “Program Files” folder if you’re using a 32bit system it will integrate into Photoshop and show up in the menu.