TS back to only one opening in PS after Glow update

After the latest update I have found that if I use Glow I then have to reboot PS!! The other plugins still work fine but Glow…Come on Topaz, we just went through all this over the last few weeks. Surely the people working on these "updates’ are aware of the dissatisfaction caused by this problem after the last fiasco?
Are there no product tests done before release?
Not very happy, again!!


FYI for you to use any PS plugin after updating whilst PS is open you will need to close PS and Restart. That is because PS preloads plugins on start-up.

Can you give the version of Studio you are using and the computing environment it is running on please. And if this issue is happening please outline the steps you are taking before it happens.

Note I just retested with PS and there no issues on a Windows 10 environment. Can call it multiple times.

My apology to Topaz & the Studio team. I was busy at the time I tried the updated Studio & had not rebooted PS to update the plug in.
Everything works fine once I did the correct thing
Again, my apologies.


Don, I have just posted a retraction & apology on the forum. You were right, I was busy when I tried & had not rebooted PS to update the plug in.

Sorry. Everything is fine


1 Like