Trying to sharpen blurry shot (medium out of focus) with Video AI and it seems to be doing nothing?

I bought a license for Topaz Video AI for the specific purpose of using it to sharpen some soft (slightly out of focus) footage.

I just spent some time running through all the models under the Enhancement menu (both with upscaling 4x and not) and increased the Theia slider to 100 for sharpen (and tried with focus fix). Nothing changes (and yes I clicked preview).

I tried searching YouTube for solutions and the best I found was from a couple years ago where a guy used Sharpen AI and an image sequence:
(can’t post link, guy’s channel is StanArthur)

Just tried a test and this DOES seem to work. So Sharpen AI, the older program, actually sharpens, but the new program I just paid money for does not.

Hopefully I’m just not checking a setting or something and it’s not that the program itself does a worse (non-existant) job compared to its predecessor?

I read the “Your Topic is Similar to…” posts to the right of mine where others have had a similar issue and there are no solutions.

Can anyone help? Thanks!

It would be easier for others to make suggestions, if you can provide screenshots of the output your currently getting (before/after) and maybe a small input sample (1 or 2 sec) if possible.

Thanks for the reply!

And sure, happy to provide samples.

Here’s the clip I’m trying to sharpen in Video AI 5. I just screengrabbed the before/after view, but take it from me, it’s identical, nothing seems to be changing.

And here’s the same frame when I run it through the latest (discontinued) version of Sharpen AI, you’ll notice there is a clear difference:

The other thing that’s weird about Video AI5 vs Sharpen (v4.1.0) is that in Sharpen it takes a good, 10 seconds for the one frame to process and for the program to do its thing. In Video AI when I click “Render 5 frames” it does all 5 frames in like 3 seconds, which reinforces my suspicion that it’s not actually doing anything.

Any advice?

Thanks!

PS
Here are my Video AI 5 settings (I tried it with Focus Fix on Strong and off and neither seems to do anything):

For sharpening this video I would try Proteus v3 (you’ll have to “Enable previous model versions” in the preferences to be able to select it), and crank ‘sharpen’ and ‘deblur’ to the maximum:

Screenshot 1

If you can’t see a difference, try ‘Focus fix’ again.

That’s expected because Sharpen AI is just designed for still images, not video. Depending on your gpu, TVAI will process multiple video frames per second.

EDIT: Make sure to step through the frames you process, as sometimes the first frame selected isn’t processed. Also try viewing at 100%, as it can be easier to see differences.

If you’d like us to test a sample of your clip and see if we can make any recommendations, please open up a support ticket at help@topazlabs.com

You can securely submit your file(s) to our Dropbox using the link below. Please be sure to send me a note to let me know you sent something, we don’t get automatically get notified when something is uploaded.

Submit File to Dropbox

make the pixel size of the video file smaller before processing with video ai. that might help.

Thanks for your help! I just tried all of this and none of it seemed to work. My clip still looks identical after processing.

An observations: every time I click “render 5frames” the activity box lists that it’s “Downloading model” - why is it always trying to download the model? And when it does, it seems to complete in 2 seconds or so. But when I click to download individual models in the model manager, it takes a good 10 - 15 seconds to download.

As per a support email, I’ve also tried manually uninstalling and reinstalling the models I’m looking to use, and nothing changes.

Thanks anyways!

Great, thanks! I just uploaded my file - file name starts with “240614”. If you could please take a look and let me know if you have any suggestions, thanks!

Thanks for the reply! Just tried bringing the output down to 1080p and same result - it doesn’t do anything after render. I also exported my clip in 1080p and tried running it on that, and same thing. Appreciate the help!

Just replied to your last support ticket email with a sample for you.