Tried to update DeNoise AI now it won't open

I have unistalled and re-installed a couple of time, When I try to open I get this system error message.
“The code execution cannot proceed because CuteLogger.dll was not found. Reinstalling the program may fix the problem.”

I have reinstalled and get the same system error

1 Like

I have the exact issue with DeNoise and Sharpen. Tried multiple ways to override including uninstall, reinstall, removing files etc., so very frustrating.

Unfortunately this was an error in DeNoise 2.2.6 and Sharpen 2.1.2 due to build changes. You will have to download the current versions on the downloads page (2.2.5 and 2.1.1) which should still work fine.

2.2.7 and 2.1.3 will be release tomorrow morning which will address this issue, and 2.2.6 and 2.1.2 have been taken down.


This was driving me bonkers as I just picked up Sharpen for the first time (though I’ve had DeNoise for a while now). 2.1.1 came right up… What bad timing I had, but happy it’s addressed.

1 Like

I’m extremely sorry that this was your first experience with it, but I’m happy to hear 2.1.1 works for you. Now that this issue is known it shouldn’t happen again, so 2.1.3 and 2.2.7 will have the proper updates.

1 Like

Just an update here, DeNoise 2.2.7 and Sharpen 2.1.3 have both been released now. Me and several people on the team have verified it works for both new and previous installs, and the in-app updater works as well.

If you ended up with a broken installation, please go to the downloads page and download the latest version. If your DeNoise 2.2.6 or Sharpen 2.1.2 installed successfully, you should be able to use the in-app updater.

The DeNoise 2.2.7 worked for me. I am up and running. Thanks

1 Like

Just updated both DeNoise and Sharpen, both are up and running. Fantastic. Thank you.

1 Like

2.2.7 is not working for me, it opens up but when attempting to make adjustments nothing happens. Ive already uninstalled and reinstalled