Topaz Video AI v3.2.6

Hello everyone!

A new release of Topaz Video AI is now available.

v3.2.6
Released May 16th, 2023

Downloads: Windows | Mac
Changes from v3.2.5

  • Added frame number display preference
  • Removed preview indicator bar
  • Improved error message dialog
  • Fixed end-of-file playback issues
  • Fixed color flicker issues
  • Fixed trim and duration issues
  • Fixed enhancement filter presets
  • Fixed Proteus V1 and V2 usage
  • Misc updates

Known Issues

  • Videos with mismatched metadata and streams will display incorrect duration
  • Chronos V1 does not work on M1/M2 Macs
  • Frame number preview length may shorten on app restart

Submit files here: Dropbox


Please take a look at the Video Roadmap Update for more context on what we’re focusing on right now. Thanks in advance for your feedback!

12 Likes

When triming a video to export it. the video hangs at the begining. Just like the previews did before you removed audio for the previews. Triming is esencial for using the software because a lot of the time you don’t need 3 hours of video only a few minutes, and then you have to take it into an editor to re-trim the video. Other than that Video AI is improving quite a lot and getting faster to use. I can’t wait for new models that improve the monster face proplem. Maybe make the faces a little focused without the full on effect of the models. Like maybe face detection options with adjustments to reduce noise and sharpen to improve quality without the AI models smoothing them out and distorting the face completely.

1 Like

:fireworks: f̷ i̷ n̷ a̷ l̷ l̷ y̷
good day to start be precise

2 Likes

Still, preview for some 23.976 fps content is out of synch. This doesnt happen for example with Alpha v3.2.1.3a (that’s just a version that I still have in parallel installed for testing).

2 Likes

The copy button on the Show Preview/Export Command dialog doesn’t seem to work. I have to select the text with the mouse and press Ctrl+C to copy the text to the clipboard.

1 Like

Either the benchmark changed or performance tanked for 2x and especially 4X Artemis + Proteus and also on APFast on my AMD 7950X + 4090 system (I checked with parallel installed recent alpha and it performed normal, so it’s not a system problem).
Update: just re-installed 3.2.5 without reboot and performance in 3.2.5 is fine

3.2.6
image

3.2.5
image

4 Likes

Little question: Will you also include one day the compatibility of HDR10 files? because I just tested on a movie in HEVC HDR10 and the preview image is as bland as if I read the movie on a PC without HDR, HDR10 or HDR10+ playback compatibility.

WHY the model downloads are tooooo slow… waiting 5/6 hrs for the download!!! pls help

2 Likes

@xuan.liu @suraj

Also seeing similar massive performance drops in the benchmark for this version…20-25 % drop in the Artemis and Proteus 2x tests…

2 Likes

Do you by chance have an ASUS motherboard?

@xuan.liu @suraj

Benchmarks for 3.2.5 and 3.2.6 show huge performance drop in about half of the tests.

Topaz Video AI  v3.2.5
System Information
OS: Windows v11.2009
CPU: AMD Ryzen 9 7950X 16-Core Processor              63.14 GB
GPU: NVIDIA GeForce RTX 4090  23.59 GB
GPU: AMD Radeon(TM) Graphics  0.47446 GB
Processing Settings
device: 0 vram: 1 instances: 1
Input Resolution: 1920x1080
Benchmark Results
Artemis		1X: 	41.06 fps 	2X: 	19.14 fps 	4X: 	04.65 fps 	
Proteus		1X: 	36.79 fps 	2X: 	16.36 fps 	4X: 	04.57 fps 	
Gaia		1X: 	15.29 fps 	2X: 	10.80 fps 	4X: 	04.69 fps 	
4X Slowmo		Apollo: 	40.75 fps 	APFast: 	64.56 fps 	Chronos: 	31.84 fps 	CHFast: 	35.93 fps 	

Topaz Video AI  v3.2.6
System Information
OS: Windows v11.2009
CPU: AMD Ryzen 9 7950X 16-Core Processor              63.14 GB
GPU: NVIDIA GeForce RTX 4090  23.59 GB
GPU: AMD Radeon(TM) Graphics  0.47446 GB
Processing Settings
device: 0 vram: 1 instances: 1
Input Resolution: 1920x1080
Benchmark Results
Artemis		1X: 	36.35 fps 	2X: 	13.21 fps 	4X: 	03.57 fps 	
Proteus		1X: 	31.82 fps 	2X: 	12.12 fps 	4X: 	03.31 fps 	
Gaia		1X: 	15.65 fps 	2X: 	10.85 fps 	4X: 	03.49 fps 	
4X Slowmo		Apollo: 	40.78 fps 	APFast: 	65.60 fps 	Chronos: 	32.14 fps 	CHFast: 	36.05 fps 	

2 Likes

@topaz257 @david.123
For users reporting benchmark differences.
Color correction is now part of the benchmarks now. This makes the benchmark results for enhancement models is closer to the actual processing.
Color correction is largely CPU bound and applied on the output, so the performance for 2x and 4x reflects the impact of it more than the 1x on higher end GPUs.
Originally, the benchmarks were designed only to show model performance without encoder/decoder and post processing. This led to differences in benchmark fps and observed fps on machines with slower CPUs or powerful GPUs. This change to benchmark is more inline with the processing times seen by the users.

10 Likes

Thanks for the explanation!

1 Like

Thanks for the explanation, which suggests no change to actual processing speeds between 3.2.5 andx 3.2.6, if I read your comments correctly.

However, the changes do now make it hard or impossible to compare new and old results in the 3.2.x benchmark thread, something that users who, like me, are considering system upgrades find to be a valuable resource.

I suggest starting a new benchmark thread to enable future comparisons to be done on a level playing field.

6 Likes

This is very frustrating!!! Model download is taking too long time…

Please provide a separate link for downloading the Models at a time…

Thanks

3 Likes

This is very frustrating!!! Model download is taking way too long time…

Please provide a separate link for downloading the Models at a time…

Thanks

Maybe something is blocking your IP address or your Internet provider… try a free VPN service Or download the models you need manually. Like this; http://veai-models.topazlabs.com/prob-v3-fgnet-fp16-256x352-1x-rt806-8500.tz

Can you give any estimate as to when you think Proteus v4 will be in a final release?

3 Likes

I can report that when the hard drive becomes full, an entire folder with tiff is deleted. Before one can take off when it stops.

And when one tries to find the error, the drive is not full anymore, so it can be somewhat hard to find.

1 Like

Why a same/existing AI Model (already downloaded and exported successfully) downloading each and every-time in a batch Export… This is very annoying… Pls help… Thanks