Topaz Video AI v3.1.11

Hello Everyone!

A new release of Topaz Video AI is now available.

Released March 28th, 2023

Downloads: Windows | Mac

Changes from v3.1.10

  • Remembers sort order and all/previews/export filters between sessions
  • Max output resolution is set to 32000 x 32000 for image sequences
  • Shows updates even if the user is not logged in
  • ESC closes the in-app updater dialogue
  • Disables some menu items if they don’t apply when no file is loaded
  • Fixes locked filters not turning off when switching to a preset that doesn’t use those filters
  • Fixes model shown enabled although it isn’t in some cases
  • Fixes image sequences looping
  • Fixes image sequence not previewing when exported with trim and keep frame number
  • Fixes input size not shown correctly when multiple inputs/outputs are shown together
  • Fixes grain enabled alone not working after changing output resolution to Original
  • Misc bug fixes and improvements

Submit files here: Dropbox

Please take a look at the Video Roadmap Update for more context on what we’re focusing on right now. Thanks in advance for your feedback!


When will AMD AI Cores be supported?


I’m probably being really dense and/or uninformed, but the release notes read more like for Topaz Photo AI? :man_shrugging:t3:


How to download all models at once?

Have they improved the trimming function yet? This program needs an IN and OUT button like 2.6.4, where I can navigate to a specific frame using the arrow keys and then press the in or out button to set it.


It has been in the software since v3 was released. just a different key combination.

Such as:
Shift+[ (for Start/IN) Or Shift+] (for End/OUT)


Awesome, thanks! Can I use the arrow keys to move frame by frame? I don’t believe that’s been in since 3.0.

1 Like

He’s talking about cutting and exporting by frames, which no is not in these new versions. We were just discussing that at end of last release thread.

Ah ok, my bad then.

Although I do use the arrow keys still to move left and right along the timeline. But yeah not by frame count specifically. Although for my use, I can find the start or end frame/s that I need and start it from there just fine.

Yes the issue though is for those of us that require the same kind of control previous version have.

If, for instance, I need to target frames 21456 to 22522 with a specific model, and then change it for frames 22523 to 27111, it is a nightmare in V3, but piece of cake in V2.

Additionally, for example, I tried to export the image sequence of an example in V3 yesterday to compare to one from V2 - and the frames didn’t match. Frame 52000 for example, which is the same in V1 and V2, is the same frame on both input and export - IE I can take frame 52000 input and 52000 output and direct compare them with no issue.

Last night, I tried to do that with V3 and the export frame was “labelled” 52000 but was not the same input frame - it was off by at least one. The actual output frame was 52001. I suspect this is what causes the issues with the preview frames not matching - the output frame numbers literally don’t match the input frame numbers.


Well damn that sucks, will have to see how and what they do with that moving forward…

All I see are updates to the GUI, and no progress in updating the scaling AI model :upside_down_face:


Yeah, the change log is strange for Video AI.


The preview seems like it has been broken for a few weeks now. If you preview something and you click on the screen to toggle back and forth, the frame is not the same.

1 Like

Hi everyone,

Is me again, I still got error “Unknown Error” when upscaling video from 480p to 4k, i have try with video only 1 nimute 30 seconds is ok but when i use a video with above 1 hour i got that error. I have try to use max memory usage on setting. With video 1 minutes is success but when I see a video after i upscale is still blurry. I have use codec H264 and h265 is the same, i have set profile to “Upscaling to 4K” and i keep default, i just modify the output setting and start process. Can anyone help me with this ?


When using models Theia, the settings sliders are reset to zero

1 Like

How much space do you have in your OS drive?

If the Topaz update is just to cope with a weekly release, then I suggest you cancel this release schedule.

I completely agree with the person who said that updates are more on the GUI side than anything else… Why doesn’t the Topaz Video team focus on models? Their updates? To put back the old models by creating a new model manager, to put back the old artemis 7, 8, 9 and others so on? What are you waiting for Topaz Video team to focus on this now? Besides, I don’t understand why you changed the version number? Why not put 3.2.0 for example why 3.1.11?


Topaz may plan to launch Apollo Soft in 3.2.0, but their production capacity is completely inadequate, they are updated to cope with weekly updates.