Topaz Video AI v3.0.5

Little explanation (for what it worths lol)

it’s not a trick : it’s how external subtitle works because .srt/.ass file was there before MKV format appears or became popular. it appeared when the first hardware mediaplayers were available, with PopCorn Hour A100 and the trick to install the 1st version of Kodi on an Xbox from 2002 (it was revolutionnary at this time). back then, it was Avi (Divx/Xvid) + external subtitle file.
MKV format is as well sill not taken in charge in video editors natively for most of them. Premiere pro ask a use of a third party plugin, and MKV support on VegasPro is still in beta since Vegas Pro 14 or 15.

the trick is very easy to use : Kodi and many other software use this instead of the Mkv one because it allow the download of subtitle file, stock them in a separate folder or with the source file.

  • .srt file in the same folder than the original video file.
  • same name of both files
  • if the media player or tv allow it, .it can support multiple external file : which must be named: , ,, etc…

it’s work like that since the .srt / Subrip format is available as a faster way and more convinient to use than .sub/.idx dvb files at this time.

I would suggest if your tv support it , to stay with the external .srt “trick”, because the subtitles are embedded forever if you brun them in the picture. if you want to remove them, change them, or have a better tv one day, you’ll not be able to do any change. like doing an upscalling on a movie with burned subtitles :smiley: .


it has certainly been reported before but the email notifications about new posts in thread on the topaz forum is broken. Notification on the profile in the forum is still working.

Last FFmpeg messages:

-vsync is deprecated. Use -fps_mode

Passing a number to -vsync is deprecated, use a string argument as described in the manual.

Invalid value 2 for device, device should be in the following list:

Failed to configure output pad on Parsed_veai_up_3

Error reinitializing filters!

Failed to inject frame into filter network: Invalid argument

Error while processing the decoded data for stream #0:1

From DVD to HD I get a HD image but the screen is smaller within this size

So big black borders all around the image. The preview doesn’t show this.

Any ideas to fix this?

HI there
I see you are using MAC. If I right click on the input source in Windows I get this which does not show the framerate setting. I’ve tried clicking everywhere so I’m either Stupid (maybe…) or Windows is not showing the frame rate option. I’d rather see a frame rate option under Chronos instead of slo-mo numbers like 2x 4x etc. Makes no sense to me if I want to convert from say 25fps to 16 or 18 fps with Chronos.

Is that a .mov behind the menu? I’m on Windows and I open png sequences quite often and can set the framerate.
Bonus: you can type in any framerate you want—even though it’s a drop-down menu.

Help me
i am a regular user

Because on my pc the last version of early (v3.0.0-XX) is suitable
Could someone please give it to me?
Unfortunately I deleted it.

You can find it easily. Click on the Topaz logo on the top left of this page, then you will see the link for Topaz Video AI. When you click it, you will see the whole list of releases.


You can achieve this in FFMPEG all in one hit, here’s a more complete example with audio too (needs same length videos):

vf_tvai.mkv = upscaled video, wrong audio (f=foreign, e=english), no subs - say from tvai.
vfesss.mkv = original video, wrong audio, correct audio, foreign subs x2 then eng subs

Command (doesn’t need Topaz’s version of FFMPEG):

ffmpeg -i vf_tvai.mkv -i vfesss.mkv -shortest -map 0:0 -map 1:2 -map 1:5 -codec copy output.mkv

output.mkv = video from first file, english audio and english subs from 2nd file, no re-encoding

You can use mediainfo in Windows to check which stream is which, or play in something like vlc and count streams down the menus. Usually video is 0, audio is 1, 2 … then subs are next free ones. First input file is 0, then 1, etc.
If you change the output file’s extension (e.g. to .mp4) it will put it in that container (but .mkv is probably the best if subs are involved).

1 Like

Great. BUT why my Sharpen AI and Video Enhance AI 2.6.4 hasn’t the same issue?

They just changed the authentication scheme in the beta to browser based so I would expect to see it in the 3.0.6 release - hopefully that solves your issues.

3.0.5 DDV3 model.
Such lines in many places:
source - Armitage Dual Matrix DVD

It’s definitely supported by windows. I’ve never had trouble playing nor editing prores on windows. Idk where you got that info from.

in 4k the sample works as it should, but when you rendcer /export the full file, its horrible.

and whats worse , when doing it in 8k, i can only assume that theres an issue with the coding, because even the sampling has playback issues and even gives a flicking green screen. and some players have an issue playing it at all.

and sadly, i think i said it before. for this setting of anti, you seem to HAVE to upscale it for it to actually take affect. which means when you load up the recent exported file, you then have to go to 8k.

also i wish as the user, we could have full control over the settings of the encoder.

also im not exactly running with an old system. and yet when im rendering for the export, im only ever getting around 0.7fps

I think it would be nice if the app recorded and displayed a simple log of your conversions. I’m constantly wanting to look them up later after they have been converted and didn’t save the data. Could there not just be a simple text log that you can reference and re-import/copy/paste settings back in? Would be really clutch. Unless I’m missing something and this exists, I’m surprised it does not. I’m a new customer and this was the first thing I looked for and have had at least 3 times in the first month where this would have “saved me.”

1 Like

I copied the line in the .json and pasted and changed the setting to “os”: “windows”,
and removed the line from the copy that was about the os version (since other windows lines didn’t have that).

Since doing that I can select “ProRes 4444 XQ” in Topaz Video AI (and I can use the ProRes 4444 codec in After Effects so it shows there’s nothing wrong with the codec) but when I press export in Topaz Video AI (in windows) it says “command error” in the interface on the far right of the video file name. It doesn’t show what the problem command was.

If I select “ProRes 422 HQ” for the codec in Topaz Video AI (in windows 10) then export then it starts exporting okay.

This is what I added to the encoders.json file (by copying and changing a bit the Mac section for it):

    "text": "ProRes 4444XQ",
    "encoder": "-c:v prores_videotoolbox -profile:v xq -pix_fmt p416le -allow_sw 1",
    "ext": [
    "transcode": "aac",
    "os": "windows",
    "minSize": [2,2],
    "maxSize": [15360,8640],
    "doNotScaleFullColorRange": "always"

edit: maybe I should try changing “prores_videotoolbox” to “prores_ks” as it says “prores_ks” in some of the windows ones.
edit: I tried changing that to “prores_ks” and that still gave the “command error” after restarting Topaz Video AI and after changing that and reselecting “export” of the ProRes 4444XQ encoder.

thank you for your reply

I checked the product release page

but it’s not on that page

the link i have is deleted

i forgot the last version
The name should be TopazVideoAI-3.0.0-XX.msi

ffmpeg -h encoder=prores_ks

Encoder prores_ks [Apple ProRes (iCodec Pro)]:
    General capabilities: threads 
    Threading capabilities: frame and slice
    Supported pixel formats: yuv422p10le yuv444p10le yuva444p10le
ProRes encoder AVOptions:
  -mbs_per_slice     <int>        E..V....... macroblocks per slice (from 1 to 8) (default 8)
  -profile           <int>        E..V....... (from -1 to 5) (default auto)
     auto            -1           E..V.......
     proxy           0            E..V.......
     lt              1            E..V.......
     standard        2            E..V.......
     hq              3            E..V.......
     4444            4            E..V.......
     4444xq          5            E..V.......
  -vendor            <string>     E..V....... vendor ID (default "Lavc")
  -bits_per_mb       <int>        E..V....... desired bits per macroblock (from 0 to 8192) (default 0)
  -quant_mat         <int>        E..V....... quantiser matrix (from -1 to 6) (default auto)
     auto            -1           E..V.......
     proxy           0            E..V.......
     lt              2            E..V.......
     standard        3            E..V.......
     hq              4            E..V.......
     default         6            E..V.......
  -alpha_bits        <int>        E..V....... bits for alpha plane (from 0 to 16) (default 16)

prores_ks only supports the pixel formats yuv422p10le (YUV 4:2:2 10bit), yuv444p10le (YUV 4:4:4 10bit) and yuva444p10le (YUVA 4:4:4 10bit).
I think you are getting an error because you are inputting in p416le(YUV 4:4:4, 16bit).

Prores_ks only supports up to 10-bit input, so 422HQ is the best option unless you want YUV444,YUVA444.

1 Like

Thanks. So in encoders.json what should be in the thing that I need to paste into it for Topaz Video AI to work for exporting with the ProRes 4444 codec in Windows 10 (instead of what was in the version I showed in my last post)?

note: if I input a video that has an alpha channel I’d like it to also output video with the alpha channel - upscaled, if the input video doesn’t have an alpha channel then the output video shouldn’t have one either).

Sometimes I want to output ProRes with the highest colour accuracy (and sometimes because it can store alpha channels) that’s why I sometimes want to use ProRes 4444 instead of ProRes 420.

    "text": "ProRes 4444 (YUV4:4:4 10bit)",
    "encoder": "-c:v prores_ks -profile:v 4 -vendor apl0 -bits_per_mb 8000 -pix_fmt yuv444p10le",
    "ext": [
    "transcode": "aac",
    "os": "windows",
    "minSize": [1,1],
    "maxSize": [16255,16255],
    "maxBitDepth": 10,
    "doNotScaleFullColorRange": "transcode"

Prores 4444(YUV 4:4:4 10bit).

TVAI currently cannot handle alpha channels.
It is converted to rgb48le (RGB 16bit) at the internal of veai_up filter, but the alpha channel is cut off in the process.
It would be nice to be able to convert YUVA to RGBA and process the RGB channel and alpha channel respectively…