Topaz Video AI v3.0.0

There was a very roundabout discussion on this with VEAI devs saying they can’t do it because of licensing, and multiple people saying that they, in fact, can. It appears that AVISynth input will not be coming back though.

I saw a discussion on licencing for other matters, but Avisynth acts as a frameserver and has a fully open public licence - there would not be a licence issue importing these scripts so this statement is confusing. Are you sure they were referring to licencing on this specific issue?

I even just did a search for Avisynth licence on this forum and it didn’t come up with anything in case I missed it.

EDIT: Found it, they were using different spelling of licence. But yes, reading that I am still confused - there should not be any licencing required for using the Avisynth script import.

I used an mp4 container, as I always used in the previous version.

I’m finding it really slow even with a 4090 card and having trouble importing any files from my NAS.
If i copy the files to my local drive, they all import fine.
Imports used to work fine from my NAS on the older Video Enhance AI.

1 Like

I’m normally not active on the forums but I felt I needed to respond to this release with my opinion. Feel free to disagree ofc.

Just like with Photo AI this is a huge letdown. After several hours of testing my conclusion is the same:

  1. Very buggy, it will take Topaz a year to get back to the same level of stability.
  2. The new UI is not better, just different (subjective) and one of many UI changes over the years.
  3. Most importantly: the end result does not look better. Nor is the process faster on my hardware.

Some users may be happy with some of the features I don’t personally use, like interpolation (I use flowframes for that) or command line, but for me personally this all seems pretty pointless and the time and effort would be better spent at trying to further improve the output quality.


Good luck convincing them. We tried.


@ida.topazlabs as you will see, a lot of people don’t like this version 3. you just have to keep updating the following version 2x like a 2.6.5. I completely agree with them this version 3 is a total regression, let’s all tell the VEAI team that it continues to update version 2x


As beta testers, we pointed all this stuff out for months. It’s embarrassing to see that this is what has been released as an actual product people will be paying for. It’s an obvious money grab.


Here is the answer from Developer,

1 Like

Is it possible to have installed v2.6.4 and v3.0.0 at the same time on the same machine? And if so, will the same license work for both versions? I would like to give v3 a try but given the good amount of bugs reported in this thread, I would like to keep the old version in parallel.

I have to stay with the old version 2.6.4. Everything in the new version is slower and worse. To me it looks like the programmer of the old version is gone and took the source code with him. Therefore all new and unfortunately worse. Whatever the cause. For me, the new version is an extreme disappointment because I’ve been looking forward to it for so long. It was always said: much faster, adapted to RTX cards, etc. None of this is true :frowning:


Clicking anywhere in the preferences window other than directly on a button or field pops up an unwanted “file open” dialogue. Incredibly annoying.


As an addendum to last issue post, it won’t preview either. Fails instantly:

2022-10-20 16-16-19 Thread: 57168 Debug passProcDone 0 5 5 1 0
2022-10-20 16-16-19 Thread: 57168 Info Removing video "" 4
2022-10-20 16-16-19 Thread: 57168 Info Close and delete path ""
2022-10-20 16-16-19 Thread: 57168 Debug 8
2022-10-20 16-16-19 Thread: 57168 Debug 9
2022-10-20 16-16-19 Thread: 57168 Debug Updating video info {"sar":1,"framerate":25,"startNumber":1,"frames":50,"progress":0,"status":0,"frame":0,"procStatus":{"status":0,"eta":0,"fps":0,"message":"","pass":1,"error":"Reading option 'C:/Users/Vaengence/AppData/Local/Temp/882222358/previews/V3 test_287289749_alq13/%06d.png' ... matched as output url.\nFinished splitting the commandline.\nParsing a group of options: global .\nApplying option hide_banner (do not show program banner) with argument 1.\nApplying option nostdin (enable or disable interaction on standard input) with argument 0.\nApplying option y (overwrite output files) with argument 1.\nApplying option loglevel (set logging level) with argument debug.\nApplying option nostats (print progress report during encoding) with argument 0.\nApplying option vsync (set video sync method globally; deprecated, use -fps_mode) with argument 0.\n-vsync is deprecated. Use -fps_mode\nPassing a number to -vsync is deprecated, use a string argument as described in the manual.\nApplying option filter_complex (create a complex filtergraph) with argument veai_up=model=alq-13:scale=0:w=1440:h=1080:device=0:vram=1:instances=1,noise=c0s=6:allf=t:all_seed=0,scale=w=1440:h=1080:flags=lanczos:threads=0.\nSuccessfully parsed a group of options.\nParsing a group of options: input url D:/Video/Voyager/V3 test/tiff%d.tiff.\nApplying option t (record or transcode \"duration\" seconds of audio/video) with argument 2.\nApplying option ss (set the start time offset) with argument 73.12.\nSuccessfully parsed a group of options.\nOpening an input file: D:/Video/Voyager/V3 test/tiff%d.tiff.\nCould find no file with path 'D:/Video/Voyager/V3 test/tiff%d.tiff' and index in the range 0-4\nD:/Video/Voyager/V3 test/tiff%d.tiff: No such file or directory","progress":0,"frame":0,"priority":3,"requestPos":2,"processorIndex":-1}}
2022-10-20 16-16-19 Thread: 49516 Debug Open Called for file "C:/Users/Vaengence/AppData/Local/Temp/882222358/previews/V3 test_287289749_alq13/%06d.png" 1
2022-10-20 16-16-19 Thread: 57168 Info EXITED: 5 1 0
2022-10-20 16-16-19 Thread: 49516 Critical Unable to open file "C:/Users/Vaengence/AppData/Local/Temp/882222358/previews/V3 test_287289749_alq13/%06d.png"
2022-10-20 16-16-19 Thread: 49516 Critical Unable to open file at "C:/Users/Vaengence/AppData/Local/Temp/882222358/previews/V3 test_287289749_alq13/%06d.png"
2022-10-20 16-16-19 Thread: 57168 Info  input video opened:  "" QMap(("audio", QVariant(uint, 0))("colorPrimaries", QVariant(int, 2))("colorRange", QVariant(int, 0))("colorSpace", QVariant(int, 2))("colorTrc", QVariant(int, 2))("duration", QVariant(qlonglong, 120000))("fps", QVariant(double, 25))("framerate", QVariant(double, 25))("height", QVariant(int, 540))("isImageSequence", QVariant(bool, true))("length", QVariant(qlonglong, 3000))("path", QVariant(QString, "D:/Video/Voyager/V3 test/tiff%d.tiff"))("pixelFormat", QVariant(QString, "rgb24"))("resolution", QVariant(QSize, QSize(720, 540)))("sar", QVariant(double, 1))("size", QVariant(QSize, QSize(720, 540)))("start", QVariant(qlonglong, 0))("startNumber", QVariant(qlonglong, 13300))("startOffset", QVariant(qlonglong, 0))("step", QVariant(qlonglong, 1))("subtitle", QVariant(uint, 0))("timebase", QVariant(double, 0.04))("timestep", QVariant(double, 40))("video", QVariant(uint, 1))("width", QVariant(int, 720)))
2022-10-20 16-16-19 Thread: 57168 Warning  input video opened FAILED:  ""
2022-10-20 16-16-19 Thread: 57168 Info ~TProcess(): destroyed
2022-10-20 16-16-19 Thread: 57168 Warning  input video opened FAILED:  ""
2022-10-20 16-16-19 Thread: 57168 Warning qrc:/videoplayer/TPreviewPane.qml:213:21: Unable to assign [undefined] to double

In theory yes, by specifying custom install, model, and temp folders. In reality, not knowing what they’ve hard coded into the software, there’s no way to really know. We’ve seen betas conflict with releases when they “shouldn’t”, and preferences ignored because of hard coding (seems to be fixed).

Thank you for your reply. So in theory it should be possible. But what about the license aspect? The software connects to the Topaz servers with login data. Won’t this cause problems?

Some bugs I have found in 3,0… Running windows 10

  1. Preview not working
  2. Export to MP4 with H264 creates video files that hyas just first frame playable.

Your license is good for any version of the same product. Regardless of the name change, it’s the same product you bought…at least it better be.

the veai team says they listen to us but in the end they don’t take anything back from what we tell them, the proof is there on this version 3. nothing has been retained on our side on their side. many people want to stay on the 2x version because it was more stable and faster, but the veai team don’t even consider that. they do what they want, that’s all. and behind us we pay for a bad product that is not stable and bad. shame. people ask to continue the 2x version but the team doesn’t give a damn, proof that they are not listening to us. we tell them that the 2x is better, stable, that we must continue to update our muses, add other options, but nothing happens in the end. it’s disappointing that the team doesn’t really listen to their customers, beta testers.


The export container is frozen in mov. I cannot select export to mp4 with AI v3.00

If I paid for the older ‘Video Enhance AI’ software last year, should I be paying for this new version of ‘Video AI’?
So far, I’ve lost Video Enhance AI which worked really well (as was asked to uninstall it during Video AI install) and it runs terrible and has cost me $99 too?
Now I’ve paid twice and have nothing that works really as can’t find an old download of Video Enhance AI.