Topaz Video AI v3.0.0

yes i noticed that too, several few frames late or in advance in interlaced mode.

Yes. I notice that it still behaves like this when switching to replay a preview that has already been rendered. You would imagine that it would just be playing the (preview) output at that point.

The other odd thing I noticed is that it doesn’t get out of synch when doing a Export.

I also noticed that it happens when changing from one preview to another. The left image is often from the previous preview, while the right side is the output from the currently selected one.

There are even more video files where the preview is messed up:

1 Like

Some awesome things that I just found: Apollo model is really fast compared to Chronos Slomo.
Secondly, the missing x5 speed can be entered into the model with the command line and it seems to work correctly.

good update that improves speed compared to previous betas! :slight_smile: the interface is the same, have the artemis and proteus models been updated or is it the same??

I think they are supposed to be the same, but I have found that AR 4:3 DVD to FHD Artemis HQ has many more artifacts and is much slower than the same DVD and settings in 2.6.4.

EDIT: I think what I am seeing is that I had also ran Chronos fast on the one I did in 2.6.4, so it added some general smoothing to every frame.
EDIT2: I take that back. Artemis HQ turns out smoother and more painted looking when run from 3.0.0 than when run from 2.6.4. It also washes out more texture details. Here’s an example of someone’s coat. Again. Same source, same model and same settings.
006520
Top is 3.0.0
Bottom is 2.6.4

1 Like

Completely understanding how complex this software is, with all due respect, I think I’ll drop back to 2.6.4 until the problems are worked out. I’m not having fun with this release at all.

10 Likes

i have never seen this in 3 years i’m using VEAI in any version. i’m not sure it’s a VEAI problem, unless you can send the video and have the team to look at it, it’s more looking like a codec issue or a decoder issue.
VEAI is just a Gui. the software behind is ffmpeg. maybe can you check the video with an another ffmpeg based software ? or just try the ffmpeg Cli command and see if the issue is still there ? same with the real ffmpeg (not the Topaz Fork).

did you installed a codec “bundle” pack ?
do you have the same issue with your AMD internal Gpu and Intel Cpu and RTX ?

2 Likes

Thank you :slight_smile:

Yes, it will get faster, also make sure that your memory usage is set to max in v3.0!

1 Like

Good catch!!! Thank you :slight_smile:

1 Like

You know timelines don’t actually mean anything here, right? This is still BETA in the truest sense of the word.

What does the input file look like on playback through a video player application? And what is the input file format?

2 Likes

An initial release is inevitably destined to be the first public beta.

3 Likes

Minor interface issue that will need correcting:

When downloading a model for the first time, the status jumps between ‘downloading model’ and ‘loading model’ which makes it appear as if things are broken. Please correct so status remains as ‘downloading model’ until the download completes and then changes to ‘loading model’ and ‘running model’. Also perhaps keep the ‘running model’ text on the progress bar for the entirety of the processing (it currently disappears and only shows the timer/countdown/ETA).

1 Like

I installed it, but it don’t open at all. 2.6.4 still open and Gigapixel, Noise and Sharpen also do. Not sure if the requirements changed so my laptop is no longer compatible or is some kind of bug. Using an Asus laptop with Windows 11 and NVIDIA GeForce RTX 3050.

Found a micro bug: scale always gets set to 0 resulting in the wrong model being used.
For example: Running standard NTSC AR 4:3 DVD on Artemis High Quality to FHD 1920x1080.
The generated command has this: veai_up=model=ahq-12:scale=0:w=1920:h=1080
But when I change the command to contain this veai_up=model=ahq-12:scale=2.25:w=1920:h=1080, the correct model is used and the processing runs just as fast as, and the results look like they do, in 2.6.4.

I know I said scale always get set to 0, well I’ve only tested this one situation.

1 Like

Cant import videos from another pc on my local network on windows like before, so I’m copying my files to my computer before importing them, anyways great update!

That’s been my experience as well. I was going to make a post like yours in fact… I still might, but I’m waiting for 2.6.4 to finish a job on Artemis LQ Strong Dehalo v2. I looked at the same frames in 3.0, on the same model, with the same settings (confirmed same file names for models in logs), and the results are even more different than your screenshots (2.6.4 being the superior result). And it takes significantly longer.

It clearly isn’t the same model… the model file names do in fact have different checksums for the same file name.

This is clearly not ready for public release! :confused:

4 Likes

Please don’t cross post the same comment in multiple topics - once is enough.

First I was pretty excited about the new release but now that I tried it with a GaiaHQ upscale, I am afraid I will have to keep 2.6.4 running after all. I can’t really put my finger on it but with this version GaiaHQ looks awful. There is maybe less “Acid-Rain” but I get plenty of artefacts which makes it look more like a Dione upscale, which were not present before.

I can only speculate that this stems from how Pixel-Ratio is handled now. In the old version I got a 1:1 output when I used a source with 8:9 ratio. That is now flipped into the opposite. I can now choose between stretching the image out of proportion or keeping the crappie ratio from my source. I actually found it pretty handy that VEAI corrects for that, so I only needed to care for deinterlacing. Or rather I didn’t need to introduce another algorithm into the mix which potentially corrupts my source-material.

3 Likes