Topaz Video AI Adding Problematic "Original Display Aspect Ratio" Field to Output MKV Files

I’ve discovered a problem in Topaz Video AI which is causing problems with correct playback of MKV files that have been upscaled. After ripping a video sample from DVD, I de-interlaced in Hybrid, before upscaling in Topaz Video AI. The DVD rip was SD, and I upscaled to a 1920x1080 resolution in Topaz Video AI. When the resultant MKV is ran through VLC or through Plex media player, the show is unwatchable, because it is flattened with what looks like a display aspect ratio < 1. This was not corrected, even after I added the correct values for a 2.10 display aspect ratio (and even the desired display pixel dimensions of 2268x1080) to the MKV metadata with a separate tool. Curious, I ran each file (the direct DVD rip, the file output by Hybrid, and the file output by Topaz AI) and found that Topaz AI was adding a metadata field called “original display aspect ratio”; in this case, the value of that field was 0.023. This field did not appear in the direct DVD rip, and it did not appear in the de-interlaced file produced by Hybrid. It appears that VLC media player and Plex preferentially read this field over the “display aspect ratio” fields. Unfortunately, I have no editor which will pull out the “original display aspect ratio” field. Thus, the file that I worked for hours on is ultimately unplayable in Plex. Do you have an editor that will allow me to remove the “original display aspect ratio” field? Can you update Topaz Video AI, so that it doesn’t add this field to the metadata? Obviously, no movie was intended to be watched at 0.023 display aspect ratio. Thanks.

I am not sure this issue qualifies as a bug to be honest, but rather on how to use the Tool. it could be this is an expected behaviour for your video/process use case.

Anyways, when you deinterlace your video in Hybrid, go to “Crop/Resize” Tab and convert your SD DVD video to PAR: 1x1 (Square Pixel).
1920x1080 is a Square Pixel resolution while your DVD 720x480 (NTSC) / 720x576 (PAL) is not. then execute the job in Hybrid (both deinterlace and pixel conversion at the same processing job). after that try upscaling it in TVAI.

NOTE: your Input PAR might be different values, that is OK. Mines was PAL 16x15. Hybrid should auto detect it.

P.S. better export your Video as lossless in Hybrid to minimize quality loss before feeding TVAI.

The Alternative if you do not wish to convert to square pixel in Hybrid, is to select “Square Pixel Type” in TVAI when upscaling and not used “Original Pixel Type”. this will convert your Video to square pixel in TVAI while upscaling (less recommended method as I noticed in TVAI there is a slight quality lose if you use both Square pixel conversion + upscaling at the same time/process).

1 Like

Thanks, Akila. I will give that a try and will give a report on if that adjustment prevents Topaz AI’s addition of the “original display aspect ratio field.”

1 Like

Please let me know if this works :slight_smile:

I’m in the process of running the original source file through Hybrid for de-interlacing and the pixel conversion, FWIW. I just did hear back from Topaz Support, however, and they seemed to confirm that the problem is with how the metadata is getting copied into the rendered file in TVAI. That makes more sense, since, prior to the last couple versions, I never had any difficulty with upscaling in TVAI, regardless of the source material PAR. The problematic output can be fixed for playback in VLC, by editing in the correct display dimensions or display aspect ratio in a tool like MKVToolNix, before remuxing. Unfortunately, nothing overrides the “original display aspect ratio” flag in Plex, and all that you get on the screen is a tall, pencil–thin strip of “what the heck is that?” You don’t get much with an assigned “original display aspect ratio” of 0.023. Too bad there isn’t a container editor which would allow you to delete the “original display aspect ratio” field.

Upscaling again. I’m not dealing with the fastest processor, so I’ll provide an update in about 2 days.

It could be it’s a glitch, what I suggested, could be looked at as a workaround to the issue.

why not just do a short clip from the entire video? you can cut a 10 sec clip with LosslessCut free tool and work on that one. it would be far faster then processing the entire video.

It looks like that would be a handy utility. I went to the page and saw 4 Linux releases, 4 Mac releases and no Windows version, unless I missed something. Thanks though!

Nevermind. When I clicked on the main GitHub page for LosslessCut, I found the Windows version.

1 Like

if you want UHD

then use the 2k

2560 x 1440

any update? I am intrigued.

Somewhat of an update. I’m still in the process of upscaling the video that I converted to 1:1 square pixel in Hybrid. I had already started the encoding before your last response.

In the meanwhile, the Topaz team did tell me that they found the problem and are preparing a fix. The problem was in the manner that TVAI wrote the metadata into MKV files (i.e., creating the “original display aspect ratio” field with unusual aspect ratios). It wasn’t happening with MP4 files, and it wasn’t happening with input sources that were square pixel.

I’m about 50% of the way through my encode, so I’ll let you know the results when it’s done.

1 Like

Okay, about 2 days later, and the file has been upscaled in TVAI, following de-interlacing and conversion to 1:1 square pixel in Hybrid. Converting to 1:1 square pixel did not prevent the “original display aspect ratio” from being added by TVAI; however, unlike the first case without conversion to square pixel, the “original display aspect ratio” correctly matches the “display aspect ratio” field, with both at 16:9. In the first case, without square pixel conversion, TVAI added the nonsensical “original display aspect ratio” of 0.023. I would prefer that the “original display aspect ratio” field be not added at all, since it’s one that can’t be edited with commonly available metadata tools.

1 Like

We are looking into giving users full control over DAR, SAR, etc at this time which I believe would resolve this issue entirely.

1 Like

That would be amazing! It’d also be nice to have the slider back to set the RF/CRF for X264/X264 encodes.

1 Like

Good idea! Can you create a new thread under the Ideas section?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.