Topaz Video AI 4.2.2

Hello everyone,

We have a new release available for Video AI.


Changelog from 4.2.1

  • Added 2x & 4x Upscaling to DaVinci Resolve OpenFX plugin.
  • Fixed preset issue with deinterlace 2x being overwritten to 1x.
  • Fixed problem where batch processing will only export one video.
  • Updated minimum trim length from 1sec to 6 frames of time.
  • Fixed inconsistent model labels in enhancement and second enhancement.
  • Fixed issue with ProRes reporting two Codec labels.
  • Fixed bug where opening preferences windows would stack infinitely.
  • Removed incompatible settings with mkv container.
  • Fixed interlace model resetting to Prob4
  • Fixed jittery output with Apollo Fast
  • Updated OpenVINO: compatible Intel devices will perform more reliably.

How to use 2x and 4x upscaling in DaVinci Resolve OFX Plugin:

  1. Create a new timeline that matches the desired output resolution for your video.
  2. Set the timeline to "center crop without resizing in the Timeline Settings panel.
  3. Apply the Enhance effect to any clips that require upscaling to the Edit panel in Resolve. (The plugin will not show scale modes in a Color node.)
  4. Select 2x or 4x scaling, an AI model, and a parameter mode.
  5. If your desired output resolution is not exactly 200% or 400% the size of the input video, use Resolve’s transform tools to crop/fit the video to the timeline.

Known Issues

  • EXR/DPX Exports may lose input frame number.
  • Inconsistent “Preview X frames” enable status.
  • Looping previews has a stutter.
  • Live preview can have frame de-sync.

Hmmmm…should be new release?


Correct, fixed :slight_smile:


Thanks… now I want to see if I continue to have problems with the AION model on my PC with 32GB of DDR5 RAM and my RTX 4070 Ti SUPER! :melting_face:


Please let me know. :slight_smile:
Downloading all files via the Model Manager worked flawlessly!

1 Like

Hi all! Sometimes I install it for testing. Today I installed 4.2.2, it works great!! Thanks to the team, you are great! ))
P.S. Will there be a plugin for FCPX? A new version of FCPX is coming out in April!

Is there any indication that you intend to fix broken previews with image formats? I was able to work out changing the preview to a video format allows me to actually see the preview now inside the program, but its an added step and irritation to keep changing it back for exports.

Sweet! Please let us know when/if Aion can get TensorRT acceleration! (I believe Apollo already has it?)

This question has already been answered here, and it doesn’t sound like anytime soon:

1 Like

Does anyone else encounter this issue when doing batch processing.

Basically say for example I’m doing 10 videos, all 1280x720 at 60fps at similar duration lengths.

While processing 3 videos at a time, when the first 3 are finished and begins processing the next 3 in the list, the processing time then takes up to 4x longer?

I had a batch of 6 videos of 1 hour each, same resolution input/output, fps and model + settings, but the first 3 videos took 7hrs to finish, then the next 3 were estimated to finish in over 1 day?

I then force closed the app then loaded the same 3 videos to process again then it went from 1 day to 9hrs? Similar to the first 3 videos in the batch. I don’t understand why the time drastically slows down when doing batches rather than restarting the app the remaining videos in the batch.

Still unable to test the Da Vinci Resolve plugin. Crashes as soon any model is selected.

Are you on Mac or Win? Can you send the logs?

Topaz Video AI 4.2.2 is now crashing after about 30 mins into a new encode. It worked flawlessly before the update.

I’m on an ASUS ROG Zephyrus G14 GA401QM factory built machine.
Windows 11 Home 10.0.22631 build 22631

Please give us an option to adjust the user interface text in the Topaz. On my screen the text EVERYWHERE is tiny and I have to physically get very close to the screen in order to see what im doing.

it would also be great if new updates don’t completely break the icons on the windows tray…I have resorted to not set up a quick launch icon on my windows task bar because there’s an update every week (which is great) but every time it breaks that link

1 Like

On Windows 10 but after looking to the log I found the issue. The plugin is looking for models in the “Program Data\Topaz Labs LLC\Topaz Video AI BETA” folder and not in the regular models folder set in the main app. And since for an unknown reason I have been removed from the Beta testing group since several months now, the latest models the plugin is looking for are missing and was trying to download them but my firewall was blocking the connection.
After fixing the firewall issue it’s now downloading the models and working.

About that why GAIA-HQ is missing in the plugin ? it’s still the best model in some cases.

Hi, there. I’ve just installed the latest version. And unlike Gigapixel v7.0.4 and v7.0.5 and Photo AI v4.2.1, the installation of Video AI was done correctly. And everything seems to work like clockwork :smiling_face:.

By the way, I’ve found that if I combine Artemis MQ + Dione Robuste v4 at the same time to denoise a sequence from Star Trek Voyager, not only does it denoise well, but it also deflowers the scene, rendering a certain skin texture in close-up shots of faces. And the set as a whole is sharper too.

So of course I first had to deinterlace the episodes via Handbrake, because Topaz’s deinterlacing wasn’t good enough. It creates flicker. But once deinterlaced, it’s fine using dione and Artemis.

Texture detail recovered

Visually, it looks like HD. Except that it’s still SD :slightly_smiling_face:

The skin is more detailed and the badge is sharper.

Even the carpet details are recovered

The sequence is debruited and it’s sharper. It’ll have a better quality on my next pass, which will be the scaling.


Is it entirely possible that certain studio drivers make Video AI perform slower? I’ve updated to the latest drivers and found my videos to be taking much longer than usual and haven’t changed anything else.

I’m upscaling a 720p 60fps 1hour video to 4K using IrisLQ manual with details at 100% h.265 and it’s taking 18hrs to finish at 3.8fps, seems much longer than before.

Using 4080 GPU, 12900K CPU and 128GB DDR4.

Is it possible to view render times for completed videos? I can see the estimated time but when its finished no time is shown.


I am replying within an area that may not be deemed appropriate. Such is the confusion generated by initially clicking on Video AI’s “Feedback”, then being redirected to a page that needed to verify I was a human, only to leave me suspended in cyberspace. A second click on Feedback brought me through to this thread. However, in true Irish irony I was bluntly reminded I could post a comment in a place comments were welcomed.

Moments ago I thought I would try out Topaz’ Video AI / Enhance in After Effects 2024. Ordinarily I use the app itself, but not this time. Opening the Topaz Labs’ plugin in AE crashed the host application. I have now removed the plugin from my AE 2023 and 2024.

1 Like

use nvidia old drivers. so faster