"Topaz Video AI 3.0" won't open

I recently updated to the 3.0 version of the program.

I had put in a video to enhance and had to minimize the program to look something up.

When I went to open the application again (from the task bar), the program would not open up. As in when I clicked it on the taskbar, it would not open back up.

Placing my mouse over the icon on the task bar, shows a window of the program, but it will not open.

I restarted my computer and cleared the cache and registry. When I go to open the program now, it will place an icon in the task bar after double clicking to open, but then it will not actually open. The program will be on the taskbar as if it is running, but clicking the icon does nothing. Hovering over it, does say it is running, see attached screen cap.

It will just stay permanently as displayed in the attached photo. Clicking on the taskbar icon does nothing. PC will stay at desktop.

PC Specs:
Windows 10
i5 11400f
GTX 1660 Super (6GB VRAM)

Tried program last night. Worked fine, if not a little janky. Previous version had no problems either.

Any help would be appreciated, thank you in advance.

I’ve run into the exact same problem. Sometimes the window won’t pop up when I start the program, even if I just rebooted the system. Other times it starts up normally, but after I switch to another task Topaz VAI 3.0.0 just stays minimized no matter what I do. Its ongoing processes continue to run in the background, and it still shows up on the taskbar and in the task manager.

I’ve already had to reinstall version 3.0.0 twice - that’s the only solution I’ve found so far.

Sorry that I can’t be of help, but the fact that the exact same issue occurs on different OS / hardware could be useful information for the developers.


Windows 11
RTX 3070 Ti

After fiddling with the program for awhile, I was in fact able to get it to open again. The process is not fun.

-Complete uninstall.
-CCleaner at max; registry clean & complete cache wipe.
-I had to then find a link within the forums (used the search function) to find a download link to the 2.6.4 installer.
-Download and install 2.6.4.
-Update to 3.0.0 through 2.6.4 update interface. {{{This Part is Essential}}}
-While updating delete v2.6.4 and replace.
-Never minimize the program ever.

It’s not ideal, but it is working now.

That said, this v3.0.0 could really use some love. I like the new features but it’s a bit janky. The preview feature is also abysmal now.

I have the same problem on Windows 10 (newest update).


  • AMD Ryzen 5950x
  • 3080Ti Nvidia
  • Nvidia drivers (newest)
  • 32 Gb Ram

Never had a problem with 2.6.4, it worked perfectly. After update within Topaz 2.6.4 up to 3.0 and separated fresh installation does not start at all.

Tried all steps above, nothing works. So weird problem with new version 3.0. Please help

1 Like

Topaz Video AI won’t start for me >90% of the time. The updated version 3.3.6 installed just now (July 25, 2023) has yet to start in over 30 attempts. Using Win 11. It’s hit or miss. Mostly miss.

Please do not use CCleaner, this app is known to cause significant issues with our apps.

@adam.boc please reach out to our support team and we will help you with this.

1 Like

Thanks to all for the good and useful inputs. I was just about to let CCleaner subscription expire anyway. :slight_smile: I am getting by. The program does start eventually.

1 Like

I had similar problem with v3.2.7 this morning. Was getting driver error. I did a clean disk check, rebooted, tried again and it worked. My system is a relic compared to all in here but that how I’ve always operated frugal as hell lol. 3x gtx970 on i7-3770 8gbs 1600 ddr3. It’s taking 18hrs (2.8fps) to interpolate to 60fps on 1440x1080p 53min video already enhanced. Video just enhanced was 1.92gb in size