Topaz Studio unable to open

I am wondering if the newest version of Studio will work with Mac OS 10.10.5.
When I tried to use studio tonight it stated that there was an available update.
After updating it will no longer open.

I use Mac 10.11.6 and have not had this issue.
You may want to restart your computer or reinstall Studio again?
Also I would be logged in and use the check adjustments updates option in Help in the menu bar of Studio.

We’ve seen some reports of issues with 1.11 on Mac OS X 10.10. For now, you’ll want to roll back to Studio 1.10, which is available on the Downloads page (https://topazlabs.com/downloads)

We’ll update the Studio Changelog with information on fixes that we implement when an update is released. You can find the changelog here:

JoeI downloaded and installed Studio 1.10.Now that version will not open either.I was successfully using it until I tried to update to 1.11That is when all of my problems began.I have tried to reset. That does not help.
Jeff Real

Thanks for this feedback, Jeff. We’re looking into a solution for this issue, but I must admit the best solution here is going to be to update your machine to macOS 10.11. We’re going to be dropping installation support for 10.10 in the coming months, when 10.14 releases, and you’ll need to update at that point anyways to continue to use the updates we release.