Topaz Studio Classic Will Not Open after Cloning Drive

I am a user of Classic Studio which is an excellent program for creative photography. I also have Studio 2 but do not find it as good. Recently, I had to clone my drive as I needed to get a new computer. The person who is working to replace my computer said that by cloning my drive, I would be able to use all my programs without having to reinstall them. He was correct, except for Topaz Studio! My other photography programs like DxO and Luminar all open fine, even Studio 2, but not Classic Studio. When I open it, the program attempts to open but after about 30 seconds it closes. I have reinstalled it from the Topaz Legacy site and have tried to open it in other compatibility modes (I am using Windows 10) but without any luck. If anyone has any ideas to try, please reply to my post. Thanks in advance!

Firstly do not post about Studio in the Video AI Section.

Secondly there is no support for Classic Studio, I would suggest using Studio 2 and you can try raising a support request at the main website.

Thirdly there must be an issue with your new PC as that shouldn’t have happened if the disk was cloned properly.

1 Like

What software did you use to clone your drive ? :thinking:

Thank you for trying to help me! My computer person used Samsung magician to clone my drive.

Thanks for your reply and sorry I posted in the wrong forum. I am hoping some clever user might have an idea for me to try. I have all my presets in Classic Studio and so using Studio 2 is not a solution. If the disk was not cloned properly, I wonder, why all the other programs work? Maybe there is something to try…

I had a similar problem re not being able to get Studio to open in my Win 11. It crashed on opening. It was fine in Win 10. This week I found in the Events Viewer that it was due to the LIBEAY 32.dll file. I didn’t want to try and download a newer version online so I searched my Program folder for the same file and found a number of them. I selected one which was a newer version in my Rebelle app folder, which works, and I copied it into the Topaz Studio folder after tagging old onto the original faulting file.
I then ran Studio again and it worked. This time the sign in box appeared and once I added account and logon key, the app updated and has worked fine. The only issue so far is I’ve not been able to get it to work as a Plugin, so have to use as standalone until I have time to figure out what is wrong. When I try to start it as a Plugin in PSP or PSE it fails and then the app crashes.

Thanks Patara for your response! My computer technician is helping me try to get Classic Topaz Studio working. He read your post but was not sure about the LIBEAY 32.dll file. We found it but was not sure what to do about it. We have reinstalled Classic Topaz using both Windows 10 and 11 but all it does it starts to open and then stops. I have a Lenovo computer now and Studio 2 works. Classic Studio was working on my old Dell computer. What type of computer do you have? I wonder if that could be a factor?

Jerve, I have Win 11 on a upgraded desktop. When I tried to open Studio after installing, it would start and then crash as it was loading. I looked in the Windows Events Viewer and for the crash it showed the faulting module was the LIBEAY 32.dll file. On searching I found that the file is part of Open SSL, an open source application utilised for establishing a secure SSL connection and that an old or corrupted version of the file could cause an app to crash.
I suggest you or your tech check the Events and see what is causing the crash on your system. In my case when I checked Events I found that same file was causing all my old, newly installed, Topaz apps to crash. These are the apps in Topaz Labs folder, not Topaz Labs LLC folder.
I searched online and found in a forum a thread discussing the same file but for a different app, It was suggested that the file was probably too old a version and the person with the problem was told to delete the file as that app didn’t need it.
I thought I would test that but what I did was rename that file by tagging old onto it in every faulting Topaz app folder. After doing that all my Topaz older apps opened up and I was now able to insert my reg key and they worked fine except for Studio, which did open up, and this time did show the account logon box, which it wasn’t doing before, but it wouldn’t log onto my account. I took from that that Studio must need that file for logging onto the website whereas the other old Topaz apps didn’t log into my Topaz account as they used a reg key.
I looked for a different version of the file on my system as I didn’t want to download unknown files from the internet. As I mentioned in my earlier post I found the same file in my Rebelle folder so I copied that over to the Studio folder and then on testing, Studio opened, the logon box appeared, I logged into my account, it connected online and Studio worked.
If your Events shows the same error then I presume you would need to do similar steps to me. You can get the newer LIBEAY 32.dll by downloading the Open SSL files from online but I wanted to avoid doing that hence me searching my Program folder for another version. I found approx. 7 versions of the file all with different dates and sizes in my Programs Files but I chose the Rebelle one as I knew Rebelle had no issues logging on to my online account so presumed the file must be working okay.