Topaz Studio artifacts in output, not in preview

Beein trying to use Topaz Studio, to use AI Clear.
The preview window in Topaz Studio shows a very nice cleaned picture.

When I save it, I get weird artifacts all around the picture. This also happens when using Topaz Studio as a plugin in photoshop.

The artifacts are less present on the bottom picture (maybe because the source image wasn’t as noisy?) but in the background clear there is still garbage (and around the face) that wasn’t there in Topaz Studio. Even with ‘HD Preview’ enabled and when zoomed in way past 100% to find the artifacts.

Is this a known issue in the community? If so, how long has this been a thing? (To set my hopes for there being a fix).

I guess you mean AI Clear in Studio and it would help if you post the settings you used as they look like JPEG artifacts.

Yes sorry, AI Clear.

The settings are not really relevant. The problem is the difference in what Topaz Studio is showing in the (HD) preview and what is really written to file when you click Save (or what is really returned to Photoshop when you click OK).

Just in case: I set AI Clear ‘Remove noise’ to ‘high’. I set ‘enhance sharpness’ to ‘low’ ,and I set ‘recover details’ to 0. Basically, fix as much noise as possible.

But again. my problem isn’t the results. It seems there is a bug on ‘saving’ the result that leads in artifacts.

My input file is always a RAW file from my camera saved as TIF (I tried both 16bit and 8bit) and I try saving as TIF. So no compression artifacts there. Or I try from Photoshop using Topaz Studio as a plugin, but then there can’t be any jpeg artifacts as well, since the whole chain is also uncompressed.

The artifacts also don’t really look like compression artifacts to me, it somethings looks more like a maze pattern, or like some random parts are just unprocessed.

Maybe this is a better example. This is a screenshot from Topaz Studio’s preview window:

This is good, and I’m happy with the result.

But upon saving (or returning to Photoshop) I get this:

Breaking news :slight_smile:

I just started the trial for ‘Reduce Noise’ adjustment, and I get the same effect there (even worse).
It seems Topaz Studio just adds artifacts to the output.

If I try to apply Topaz Studio from Photoshop without any adjustments at all, I get a very slight color-shift but otherwise I get input back as output without anything done as it should.
But even adding a basic but heavy ‘Gaussian blur’ yields artifacts in the output (although far less than with reduce noice and AI Clear).

Here is an example with a simple ‘blurs’ adjustment, type ‘gaussian blur’, ‘amount’ set to 0.25, ‘preserve edges’ left at 0.
This is the Topaz Studio preview window (good):

But this is what is returned to Photoshop:

So I editted the title of the thread, as it seems like a general problem in Topaz Studio and not (directly) related to AI Clear.

Are the debugging options, or a way to disable GPU support or something to test if that helps?

I think you should raise a support request, I haven’t seen those type of compression artifacts before. And I use CS6 and don’t see anything like this, but I do not add noise reduction through my RAW converter and the images are developed with correct brightness, white & black points before I use AI Clear.

I did already create a support ticket, but I don’t expect an answer in the same weekend :).

I did just try it on another computer, and here it works flawlessy, including AI Clear!!

Different video cards, my gut tells me it has something to do with that (even though my first computer I tried it on - with the artifacts - follows the required system specifications nicely).

Go to Help->Graphics info, press the copy button and paste the info here please.

Topaz Studio Ver: 1.14.3
Operating System: Windows 10
Graphics Hardware: Intel(R) UHD Graphics 620
OpenGL Driver: 3.3.0 - Build 25.20.100.6618
CPU RAM (MB): 16238
VRAM [Total, Used] (MB): 1500, 1200
Preview Limit (Pixels): 3466

Try reducing the size of the image as you are really on the basic recommendations. Remember Intel HD cards only have 112MB of dedicated memory so they share system RAM.

You can also help a little by allocating 16-32GB as the virtual memory on the PC … Manual allocation not system managed.

Thanks for thinking along.

Hm… although I don’t really ‘agree’ on the reasoning, ahem, you are on to something.

Decreasing image sizes (I started with a 6000x4000 24mp image) down by 80%, or 70%, or 65% all produces artifacts.
But from 60% and downwards they are gone and it looks fine. So image resolution does indeed seem to be a big factor here.

But the display adapter indeed has 128mb dedicated VRAM but also 4gb shared… That should be enough I’m guessing? My other PC with a dedicated GPU has 6GB of VRAM (none shared) and it works flawlessly at 24mp.

During the whole process my actual RAM usage is never coming close to being more than 12gb, let alone 16gb and that’s not even counting the swap file. Are those 2gb really the difference?

And why doesn’t Topaz Studio than show a message ‘not enough VRAM, decrease image size’ or something similar? Producing artifacts in the output instead of giving an error is never a good idea I think.

The reason image size is an issue is because the UHD 620 only has 24 execution units and shared RAM is a big issue because of the bus.

For example on one of my PCs I have from 2011 a NVIDIA GTX 540M which has 96 shading units, 16 texture mapping units and 4 ROPs. There is also 1,024 MB DDR3 memory on the card, which are connected using a 128-bit memory interface. The GPU is operating at a frequency of 672 MHz, memory is running at 900 MHz.

So, what you are seeing is that the GPU is older than yours but simply more powerful because of the execution units and the dedicated memory which isn’t using the system bus.

Probably has to do with the 3466 preview limit but, in the case of the 540M I have, the preview limit is 3000 pixels but have no problem with 6000 x 4000 (Canon) images. In fact no problem with 5DsR images either.

So, as you have noticed on the other PC you have, the dedicated RAM and a PCIe/SSE2 interface is much faster. On my other PC I have a GTX1050/4GB and that never has any problems.

well and that’s the thing.

yes I know it’s not powerful hardware… Pardon me, but 'duh, it’s an integrated video chip.

I wasn’t complaining about processing speed. I’m OK with the process taking MUCH longer, maybe even bypassing the GPU completely…

… but now I just can’t process my images at full resolution which is a shame.

And no where is it acceptable that the program generated images with artifacts if things aren’t alright. Because now I have to constantly double-check if the output file went through OK without creating garbage in some places.

I still consider this a bug (mainly because my video-adapter in Windows is showing as having 8gb of shared memory available (after raising it), which is more than my dedicated GPU. The ‘graphics info’ window is still showing the same amount of vram (1500) no matter what so I think something is wrong there.

and then my point still stands, even if it’s just not possible because of limitations, there should be a message indicating that instead of ‘sneakily’ producing garbage in the files.

Maybe there will be an option for CPU only processing in Studio like we have in GigaPixel AI and Sharpen AI which may be a future option. Obviously though, Adjustments such as Impression, AI Clear etc., will suffer with the speed … but if may be an option for those that don’t mind extended processing times. :slight_smile:

I have been struggling with the same issues. I will say that it did not seem to happen in the initial launch of the product but after one of their updates