Topaz Studio and A.I. Gigapixel don't start on Mac OS Mojave

Hi,

I have upgraded from MacOS High Sierra to Mojave (iMac (Retina 5K, 27’’, ultimo 2014); 3.5 GHz Intel Core i5; 24GB RAM; AMD Radeon R9 M290X 2048 MB). Since the upgrade Topaz Studio and A.I.Gigapixel do not start anymore. Not as a standalone and not as a plugin. If I doubleclick on the icons or on the name in the programs folder, nothing happens. There is no error message.Both programs worked fine on High Sierra.

I have re-installed both applications now several times, but that doesn’t help.As said, there is no error message. The programs just don’t start. Is there any way to find out why the apps don’t start?

On the web site there is a article about updating:

If this doesn’t help please raise a support request at the Need Help link above.

Hi Don,

Thanks for your reply. I have read this article already and I have contacted Topaz Customer Support a few weeks ago. Unfortunately, I haven‘t got any reply. I was hoping that someone in this group could help.

I did notice there were some issues mentioned on the Facebook page but you would have to scroll through to see if you could find and see if they were relevant to you. Other than that the only other thing I can say is make a post there and someone may be able to help.

The Facebook page is at:

I’m running Mojave 10.14.2 on a MacBook Air at the moment and Topaz Studio latest launches just fine.

Hi everyone!

Recently, I’ve gotten much more involved with our support effort, as we’ve brought on some help to expand our bandwidth in a few areas that has allowed me to refocus. I’ve looked into this problem, and discovered that there is an issue with our installation/deployment process that will limit the access of the Studio and A.I. Gigapixel software to the admin user that installed the application, with a normal install. This means that other admins and standard accounts are unable to launch the software after it is installed. This will be very easy to resolve by the development team, and I will be bringing it to their attention today. With the help of an enterprising user @rathbun-741103, we’ve discovered a few framework files had incorrect permissions, preventing launch on non-admin accounts.

While these won’t be desirable by all, one of the following workarounds will enable you to use your software again. We don’t typically recommend making these changes, but this is a bit easier for people uncomfortable with using the Mac Terminal:

  • Make sure the Mac user account you’re logged into is an admin user account
  • Login to your admin user account that was used to install the application

If you are comfortable with the Terminal, you can follow these steps to avoid using an admin account (recommended):

  1. Open Terminal
  2. Type: cd /Applications/Topaz\ Studio/Topaz\ Studio.app/Contents
  3. Press Enter/Return
  4. Type: sudo chmod -R 755 Frameworks
  5. Press Enter/Return
  6. That’s it!

Studio should now run correctly for you.

Thanks a lot, Joe! This works! And it is also working for A.I. Gigapixel.

1 Like

Just signed up to say that Joe’s suggestion worked for me too; thanks very much for looking into that :+1:

1 Like