Topaz Studio 2 v2.3.2 won't install

I have Topaz Studio 2 v 2.2 issued on 11/2019 and I am running on an iMac Last 2021 with M1 Chip with OS 13.3.1 (a). I have Topaz Studio 2 v2.2 saw that v2.3.2 was released March 2021 with v2.3.1 released in feb 2021,

I tried to update using the “Check for software updates” in the Help dropdown menu. I am told there isn’t any updates available I am running the latest version; however, I see by the release notes for Studio 2 that there have been two versions since my version 2.2, that is 2.3.1 and 2.3.2.

I downloaded v2.3.2 when I try to install it I get an error window, see below.

Why am I unable to update my version of Studio 2 to 2.3.2?

Thank you in advance for your help

All, I decided to delete my Studio 2 v 2.2, tried to install from Studio 2 v2.3.2 dmg, same issue. I then used Time Machine to go back to the April 20th 2023 version, restored it and lo and behold the version of Studio 2 was now v2.3.2, not sure why or what happened, but all is well it seems right now.