Topaz Studio 2 install offers Setup Wizard

I downloaded the latest Topaz Studio 2. After the download, it asked to sign-in before installing. I started to input my user name and PW but before finishing it went into the setup Wizard where it just hung up there forever. I had allowed uninstall for the prior version so now I cannot use TS 2 at all. It always does the same thing on sign-in and the setup wizard. I still have the original Topaz Studio installed so using that for now. Anyone else get this problem?

Please let me know which OS you are using and where you downloaded the file from as I have never heard of a setup wizard until it is actually installed. The setup wizard starts after you start the application and only asks you to login.

If you mean asking about file locations make sure there isn’t a warning dialog that isn’t in focus, i.e. you can’t see it as it may be behind the installer. If there is just switch to that.

Sounds like exactly what happened to me yesterday. Luckily I was able to restore toafew days before this happened so I have 2.1 installed again

So what happened to you yesterday during the install?

The latest Windows Studio 2 installer does indeed use a Setup Wizard.
This shows the first wizard dialogue and the last.

The Setup Wizard gives the user a choice of where they want to locate the Studio 2 resources, and also where they want to locate the user looks, filters, & textures

Whilst the installation of the update is a bit strange if initiated from within the previous version, if done as clean install using the online installer it works well, and being able to say where the resources are to go was appreciated.

1 Like

I had the same thing happen to me today (MacOS 10.13.6) when I opened Studio 1 and got the message that there is an update. I clicked the button to “update” and a few moments later, after some downloading took place the splash screen opened for me to sign in. As I started to sign in, a setup routine started.

The setup app said it had to remove all previous versions of Studio. I clicked OK and it asked me to authenticate with Admin credentials (my user account is not set up with Admin privileges) and it proceeded to uninstall my existing Studio 1.

The next step was to begin installation of the new version. Only problem was, it said that This User is Not Allowed to Install. No offer for authenticating with Admin credentials. The Uninstaller had no problem letting me toss the previous version, but somehow I was not important enough to replace it.

So, after adding Admin privileges to my regular account (requiring a restart), I downloaded an installer from the Topaz web site and installed the new version. Then, I removed the Admin privileges from my normal account (requiring yet another restart) and all is fine.

I had this same issue last week trying to update Gigapixel AI. Had to go through the same routine with adding Admin privileges to my regular account in order to get it installed and to run.

It seems as though whoever is coding the installers doesn’t understand how to do it. Every other software developer handles this without any fuss. Maybe Topaz can send some of their folks to look over the shoulder of (any) competitor to learn how to get it right.

I you are running Catalina there are many issues with the changes to security and root permissions. If that is so please report these to the developers by raising a support request at the Topaz Labs website.

I use a Dell XP’s 15 laptop with Windows 10. Last night I tried to download directly from my account on the TopazLabs web site. I went to the Topaz Studio installer and downloaded the latest version. It all seemed to go well and the application opened. I brought an image into it and made a couple of quick edits then closed it. All was well I thought. I then used it in my normal workflow - use of LR first then into PS. From PS, I went into TS 2. When it opened, it asked me to sign in. I put in my user name (e-mail) and before typing my PW, it flipped into the setup wizard and just hung up. I have heard other users response that the wizard has options to choose near the bottom. Mine does not as the setup wizard has small letters at the top heading but the rest fills the screen with blank - like it is enlarged with no way to minimize or reduce it to be able to view the entire page. My computer has a high res screen and some applications have had similar issues. Not sure this is the case here but mention it as a potential problem area. I still have the original Topaz Studio that works but TS2 not comparable with Adobe apparently in my case. Any other suggestions? Another commenter mentioned adding an administrator capability on the account but I did not find this when going to editing my account details on your web site.

There is no setup wizard, just an install wizard. You will need to shut down PS and LR before installing TS2. This is no different to installing any plugin, and TS2 must run as a standalone before you try to use it as an external editor (LR) or a plugin.

I use TS2 with PS/LR AP, C1 etc., and no issues but I don’t have a high res screen. I would set it to 100% zoom and try the install again, with LR and PS not running.

I have the same problem,using a Mac OS 10.14.6
I believe when downloading TS 2 the 'uninstall was not completed but i was directed
to complete the new installation. I did ! Now I have no Studio 2 at all

Should I go back to my hard drive and delete all and everything I still have that says TS 2 and start the process all over again?? Getting frustrating as this take a long time just to uninstall and still not knowing whether the ‘uninstall’ will really UNINSTALL’ !!

I did not have either PS nor LR active at the time of downloading TS 2. I checked for the application directly after download then opened up LR and PS to try.

How did you establish yourself as administrator? I don’t that anywhere on my account settings on

On Windows right-click on the installer downloaded and select Run as Administrator.

Then perhaps Topaz should change the wording on the opening dialogue of their “install” wizard so it reads “Install wizard” instead of “Setup Wizard” as it currently reads. Until/if that happens the official Topaz name for it will be seen as Setup Wizard.

See screen shots in post #5 in this thread
Topaz Studio 2 install offers Setup Wizard - #5 by Greyfox

You can raise a support request at the main website.

No, they’ve got more than they can handle as it is, and I don’t have a problem with it being called a Setup Wizard.:grinning:

I had pretty much the same installer issues. There is a brandnew TopazStudio2-Online-Installer.exe with which I could set up Studio 2.2.0 without any further annoyance.


Well, just actually read my post and you will see that I am NOT running Catalina. I’m on High Sierra (10.13) which has been around a couple of years.

And, I had opened a ticket about the Gigapixel problem. Support said they solved it with an updated installer, but that didn’t work either. I had to go through an hour or so of trial and error myself to finally discover that (at least Gigapixel) will only run within an account that installed it and had Admin privileges at the time of installation. After the install, Admin privileges can be removed and it will still run OK in THAT user account but not in any other account (whether or not it has Admin privileges).

You have to remember that the Support folks are likely the same ones who write the code in the first place, so expecting them to help solve a problem they don’t recognize doesn’t usually work to pretty well.