Topaz Studio 1.0.7 Crashes

Great shots! If you don’t mind my asking, what were your workarounds to stop from crashing? Since the 1.0.7 update, Studio is unusable to me as it goes into a “Not Responding” state whenever I do a save.

2 Likes

I can rarely use the stand-alone, and certainly not with tiffs, only jpgs. I can use it, with limitations, as a plug-in from Photoshop but I can’t use community presets, image layers, or use the apply button, I can’t use textures that have a transparent background, some other stuff. It’s always a nervous leap into the unknown.

1 Like

Nice images and processing with using Studio despite the problems you encounter. The colors and details are very appealing.

Seems by @mrgarcia response, that we are not the only ones having issues with Studio? I wonder if anyone has heard from @JoeFedric-TL or some other team member to what’s happening with Studio v.1.0.7???

Out of curiosity are you having an issue on a Mac or Windows?

Maybe start a separate thread to discuss your issues with a broader audience.

Regarding cre8art’s comment asking if I use Mac or Windows:
My issue is on a Windows 10 Home desktop computer. It’s getting older now, but not necessarily a dog yet considering a second generation Intel i7 processor with 16GB of memory. The graphics card is a middle of the road AMD card compared to the Topaz chart for recommended cards and has the most recent drivers. I had submitted an initial support ticket while using 1.0.5 after doing 30 minutes of work and Studio crashed when saving. I expressed my displeasure that there was no way to recover any of my work. Ashley was responsive and asked for the dump of my system hardware/software to look at, which I provided. Then she explained that she had been assigned to development and thought Joe would get back to me ASAP. I waited a week or so and never heard anything. Then I updated to 1.0.7 and a usable 1.0.5 version for me became unusable. 1.0.7 feels generally slower, but usually always goes into the “Not Responding” state when I save until I have to force it to close and lose the work. Also, the fit-to-screen button doesn’t work for me. A week ago I put in another support ticket to explain this assuming that my previous ticket was lost in the cracks after Ashley changed positions, but I still haven’t heard from Joe or other support personnel. I also asked for a way to easily go back to 1.0.5 but have been hoping for a quick turnaround for 1.0.8 and a version that works at least as good as 1.0.5 did for me. When seeing a post about “workarounds” I was hoping to learn of other ways to use Studio to keep it from becoming Not Responsive. From you’re comment I see that I’m not the only one with 1.0.7 issues. For now my workaround is to not use Studio, which is frustrating as I developed some personal effects in Studio that I would like to use now. I’m anxious for a newer working version of Studio to come out soon. I wish Topaz would at least acknowledge that there are issues and what they’re doing to address them. This is more of response than you asked for but I decided to share my experience in case its of any use/interest to anyone.

2 Likes

Regarding john811’s comment “Maybe start a separate thread to discuss your issues with a broader audience.”:
Thanks for the suggestion to start a separate, broader thread. I’m actually distracted now by preparing to hit the road for the rest of the week. See my reply to cre8art to see that I’m still hopeful for a newer Studio release that at least works as good as 1.0.5 did for me. Maybe when I get back home next week if Studio is still in a dismal state.

1 Like

My crashes on my Mac will Studio are only with accessing any Community Presets, other than that it does work and does not crash with using it.
I’m hoping for some response too. I guess because of the July 4th Holiday… we will hopefully have an answer soon?

I’d like to note that I am not in development, though I am the admin of this forum. My work does not relate directly to the image processing engine, which sounds like the problem being discussed here. I’m going to move this discussion into its own thread, since we’re taking away from the OP a bit.

Every week, we assess any new problems reported to us, and work on problems we’re already aware of. We’ll be discussing any new issues that have arisen since the last update. This is part of the reason we’re able to release so many updates in such a short period of time. We’ll continue doing just that :slight_smile:

Also, please make sure you follow the guidance here before submitting a ticket:

Please update to v1.0.8, and let us know if it helps with the crashes reported.

I just noticed this new thread created from previous comments of a different thread. I’ve been sending email replies regarding previous tickets of mine without responses from Topaz. So, maybe this forum is a better conduit for Topaz responsiveness? I’ll try. I did upgrade to Studio v1.0.8 when it came out, so maybe this isn’t the correct thread anymore and it should be a new or different thread. I’ll let moderators migrate it to a unique thread as needed.

The short answer is that 1.0.8 is working better for me than 1.0.7; but still pretty much unusable in that I can’t use effects that I created in v1.0.5 that worked great then, but now continue to cause Studio to go into the “Not Responding” state when I try to save my work. And it’s not just those effects. This is all since updating from 1.0.5. I don’t understand why this is happening. Note that this is not a “crashing” situation. I don’t get any crash logs that I can find from this situation. Studio goes into a “Not Responding” state until I end up with the two options to “Close Program” or “Wait for the program to respond.” But the program doesn’t respond no matter how long I wait, so my only real option is to close the program and lose any work I’ve done. An example of one of my effects uses 3 adjustments: Precision Contrast, Radiance, and Sharpen. Nothing radical, but Studio can’t seem to cope since I updated from 1.0.5.

In my original trouble ticket I was asked by Ashley to submit my system information. I’ve done that twice already. My expectation was that someone at Topaz would be able to look that over and tell me where I’m deficient or what I need to do to my system hardware or software for Studio to work with it. I’ve asked several times for that, but still no response from Topaz after several weeks. I’ve already done everything suggested by Topaz to ensure I’m meeting minimum requirements and have the latest drivers. Why can’t Studio work as well for me now as it did in v1.0.5? After an update my expectation is that new software will work at least as well as previous versions. That seems reasonable to me. I’ve been using all of Topaz’s products almost from the very beginning and have never had any real issues until now. I can go back to just using all the other Topaz products instead of Studio, like before, however after the time and expense I’ve invested in Studio to this point I’m reluctant to just chuck it.

Am I the only person to have these types of issues with Studio? That would be good to know too. Or has anyone with these types of issues been able to overcome them and can you share how you did so? Or if you’re having similar issues, please comment. If there are enough people with similar issues maybe it will become important enough to be a priority to Topaz. Thanks for any help!

@mrgarcia I came across this info on another post titled _Topaz Impression running fine, now crashes?
Don’t know if it pertains or can help fix your issue but thought I’d pass the info on to you?
I know it’s not the same driver as you have but maybe this is the cause?

Win 10 recently ‘updated’ my computer and put in it’s own MS driver (which naturally caused trouble).
I downloaded and installed the nVidia driver and all is fine again.
Why can’t MS realize that they know absolutely nothing about video card drivers?

Thanks @cre8art, I appreciate you looking out for me. I wish I could say the same about Topaz Labs Technical Support. I wish I could blame drivers. I’ve scoured my system drivers and made sure they are all the most recent. I’ve ensured my graphics card meets the minimum requirements and is supported by Topaz Labs for Studio and I’ve double checked that I have the most recent driver available, using AMD’s driver update utility to update as needed. Doing more research, AMD is not supporting further driver updates for my graphics card and the most recent driver is from early 2016, so I’m considering getting a more current and capable graphics card.

I just noticed a new v1.0.9 update available for Studio. I optimistically installed it with crossed-fingers, only to find that the same “Not Responding” condition occurs when I do a save after applying a simple effect I developed and used successfully with v1.0.5. So Studio is still not usable for me.

At this point I guess I’ll research graphics cards and hope that is the answer. Clearly Topaz Labs doesn’t consider this a priority. They claim that they read and answer every email and their trouble tickets indicate that they will get to it ASAP. They fail to mention if they will be responsive within any standards like within 24 hours or a business day or something similar. So I guess they can just not respond to my emails or trouble tickets and claim ASAP means a month or a year. I hate to be critical, but it’s frustrating to be ignored. I wish they would just say, “too bad, you’re on your own,” and at least I would have an answer. I’m just venting now, but maybe my experience will be of interest or use to someone else.

Sorry to hear about your experience with customer service. I too have found that their attention to tickets has been slipping off as well. It seems that they feel all issue’s will be fixed with the next update? Usually someone on the forum does have a possible answer/fix, in my opinion @AiDon is very knowledgeable with Windows issues… you may want to try sending him a PM or select the Invite button below and invite him to this topic to see if he can possibly shed some light on your issue? It’s worth a try and you may find an answer?

Good luck and hope you find a solution.

Thanks @cre8art for the additional suggestions and empathy. Right now I have a new graphics card on order that I should receive this week and install. It will be more capable and hopefully be supported for driver updates for at least a few years. My current card, though supported by Topaz, is no longer supported by AMD for further driver updates, so it is probably a good idea to replace it anyway.

I’m not sure if the graphics card is the issue or if a new one will fix it. If it doesn’t solve the problem I’ll seek @AiDon for an opinion. So far I feel I’ve done everything reasonable including verifying my system meets Topaz minimum requirements and my graphics card is supported, Windows 10 system scans (no issues found), Windows 10 restore health (just to be safe), registry scans and repair operations, Norton virus/health scans, Norton system optimization operations, checking and double-checking that the most recent drivers are installed, uninstalling and reinstalling Studio, updating to the most current versions of Studio when available, and submitting a couple of trouble tickets to Topaz a few weeks ago.

My Windows 10 system has had Windows updates since Studio v1.0.5, so I wouldn’t be surprised if that didn’t have something to do with my Studio issue. I asked that question specifically as part of my trouble tickets with Topaz Technical Support. Of course, no response from them. However, I haven’t noticed any problems with system or application software on my computer since, except for my Studio issue. All my other Topaz Products are working fine as usual. I’m not ruling out Windows specific issues, but it seems to me that the graphics card is a key element with Studio performance and perhaps Topaz hasn’t yet figured out that my specific AMD Radeon HD 6450 1GB card is no longer compatible?

I know you weren’t asking for all this detail, but again, I mention in case it is of use or interest to someone else. And who knows, maybe @JoeFedric-TL or Topaz Labs Technical Support will stumble into this and actually offer something useful. Thanks again!

Strange that everything else is working fine with your current Windows updates and graphics card and not Studio?
The only other thought I had was maybe it has something to do with the Norton App? I’m no tech but I think I have read about this on the forum once before? Maybe I’m wrong being everything else is working fine? I really hope @JoeFedric-TL does pick up on this post and can provide a solution for you or the new card does?

I’d be interested when you find a solution what it was.
Good luck

Suspecting Norton is a good idea considering Studio must be going out over the internet to bring in preset effects from the community. I double-checked Norton settings and Studio is already included in the list of Norton’s “Trusted” programs for internet access. Thanks for the suggestion. I’ll be sure to update with progress and a solution when that occurs.

1 Like

Hi @cre8art and anyone else who’s interested. I received my new graphics card and installed it. It’s an AMD Radeon RX550 with 4 GB memory. The short answer is that it appears to have solved my issue with Studio going into the “Not Responding” state when I save my work. I’ve used Studio quite a bit today and have not had any issues with it. So, I’m keeping my fingers crossed. I arrived at this solution on my own despite Topaz, not because of them.

Apparently, Studio has become so resource intensive that it is requiring more and more capable graphics cards (and computers?) to be able to reasonably use it. That’s my take on it anyway since I’ve never been contacted by @JoeFedric-TL or any Topaz technical support personnel regarding my “Not Responding” issue regardless of multiple requests specifically asking what I needed to do to my computer system hardware/software to be able to reasonably use Studio. This was after providing my system information, as requested by them over a month ago. I think only Topaz can comment for sure on how their software is programmed to work with computer system hardware and software and what are the things that will happen when resources are not adequate. Too bad they wouldn’t comment or help me with this. Apparently, my old graphics card, though meeting their minimum requirements and being supported by them, was adequate when Studio first came out, but became only marginally adequate at about V1.0.5, and was no longer adequate in subsequent versions. Given that, I think Topaz needs to reassess their minimum requirements for using Studio. I would recommend to anyone to ignore their minimum graphics card requirements and focus more on a system that is more aligned with their “Optimal” graphics card requirements to hopefully avoid any non-performance issues with their software. Don’t expect to get any real help from Topaz if you have any problems or issues. From what I can tell the only way to contact Topaz for problems is via trouble tickets or email and despite their claim that they respond to tickets ASAP and read and respond to every email, that is not the case. These are my personal opinions based on my experience and the absence of any responses from Topaz.

1 Like

I’ve replied to Michael’s ticket. It looks like he went from a Radeon HD 6450 to an RX 550. As you can see here, the upgraded card is about 10x (900%) faster than the card he was using:

http://gpu.userbenchmark.com/Compare/AMD-RX-550-vs-AMD-Radeon-HD-6450/3925vsm7821

I’ve made this argument ad nauseam about our OpenGL applications. If you use a slow card, expect bad performance. We cannot build software that makes slow hardware fast. It sounds like the application was timing out, because your graphics card was too slow to return your image to the application, before the operating system stepped in and stopped the application. This is something we cannot really plan for, because the operating system and hardware are what create this issue.

We did find a problem with the All and Trending preset list, which was addressed in 1.0.8 with a hotfix. You claimed in your ticket that 1.0.8 did not help enough to render the Studio application useful to you. This means that your GPU was 100% to blame for the crashes, rather than our application. The update to 1.0.9 provides a permanent fix to the All and Trending preset lists: pagination.

Unfortunately, we don’t really have a way at the moment to prevent you from loading images that are too large for your graphics card to process fast enough to prevent the operating system from interfering with the application, causing it to crash. As long as you meet the minimum requirements, it will run. There’s a reason we list minimum requirements, recommended requirements, and optimal requirements. Minimum is the absolute minimum to get Studio installed. Recommended is what we recommend you use to enjoy the product. Optimal is where you can start seeing near-instant processing in a number of our products, including Studio. Anything that performs poorly between Minimum and Recommended is to be expected.

We do respond as soon as possible. I’m just one person. I know you don’t want to hear an excuse or a sob story, but the fact of the matter is, I run support all by myself. We’re getting another agent to help cover the volume we receive next Tuesday, but I’ve been at this solo for 2+ years.

We have never ignored a customer, people always get responses. Sometimes, no matter how hard you try, its never enough ¯\ _ (ツ)_/¯