Topaz Photo AI v3.0.1

Hello,

There’s some important fixes going into this version of Photo AI. With this change, overall performance and memory usage with large batches of images is significantly improved. We will also continue to improve the performance of Photo AI for these scenarios in future releases.

We have also optimized other items related to exporting, brought more UI components in-line with our new Wonder UI framework, added a camera profile for the Sony ILCE-9M3, and more.

As always, a full change log is below.


Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports.


v3.0.1
Released April 25th, 2024
Mac: Download
Windows: Download


Full changelog since version 3.0.0:

  • Multiple exporting and batch optimizations, improving performance and significantly reducing memory usage with large batches of images
  • Fixed an issue where external editors did not work with RAW or DNG files
  • Fixed an issue where flipping the aspect ratio shrunk the selection in the crop tool
  • Added a camera profile for the Sony ILCE-9M3
  • Fixed an issue where the feathering slider did not appear
  • Removed old carousel images to reduce application size
  • Updated multiple components, tooltips, and icons to match Wonder UI
  • Fixed typos, sentence casing and icons in multiple locations
  • Automatic Lensfun update

Cheers,

Dakota Wixom
Product Manager
Topaz Labs

6 Likes

Thanks for the update.

It should be rather trivial to correct camera matrix for Nikon Z8, could you please prioritize this?

Adobe Camera Raw:

Topaz Photo AI 3.0.1

4 Likes

Thanks Michael! I’ve seen this mentioned before. We’re taking a look - please also let us know if you notice any other issues with other cameras as well, I’m keeping a log of all of these.

The memory leak issue does not appear to be resolved in this release, for those wondering. The memory footprint grows with every successive batch of images processed.

12 Likes

Hi Dakota, I just downloaded/installed this rel. and there are still serious usage issues with today’s .1 release.

Win 11 Pro desktop PC. Photoshop 2024 Plugin (used via File > Automate). Processor = AMD RX6800 XT. .Tiff image sent from Ps layer stack.

There’s still the problem (I’m really confused why it can’t be changed) that the processing preview status label is overlaid over the image in the workspace. It blocks image content. Why can’t that label be placed off any image content in the horizontal dark gray band at the top of the PAI UI?

Also, processed PAI content is Not sent back to my Ps layer stack (an empty layer is generated and labelled but the processed image content is not returned) and there is some kind of remnant of a message box that’s placed in the upper left of my Ps UI by PAI. I will have to roll back to 2.3.2 (again) b/c Ps is my only workflow venue. Can that be patched quickly?

I’m going to try what I often have to do after my Topaz AI commercial installs and completely reboot my PC to see if that helps.

I just had to use Task Mgr to end my Ps 2024 process in order to escape the screen I show above with the partial PAI label over my Ps workspace caused by using and saving from the PAI plugin.

3 Likes

3.0.0 worked well for me in most regards, and this is perhaps faster (not sure), but still the Preserve Text function does not work.

Here is the original…
Screenshot 2024-04-25 at 20.43.48
Noisy but clear

This done with 2.3.2 and Preserve Text
Screenshot 2024-04-25 at 20.44.39
Heavily denoised and clear

This is 3.0.1 and Preserve Text
Screenshot 2024-04-25 at 20.44.01
Same as 3.0.0 – Denoise mangles text and preserve does not preserve

…Sam

14 Likes

Hello David, based on our tests it should be much better than before. Please let us know if that is not the case for you. There’s still more work to do on this item though.

sharpen process twice,like GAI 7.1 ,3.00 no this problem

Thanks Fotomaker - I haven’t seen that issue before in PS.

Regarding the memory issue, it should be much improved, but we are continuing to work on this.

The only positive thing I can say is that the memory leak is somewhat slower.

Freshly loaded, no images processed:

After first batch of 30 images:

After second batch of 30 images:

And I’m sure the memory consumption will continue to go up until it crashes the application, or worse, my PC.

Compare this to 2.3.2 after processing multiple batches of images:

Sorry to be blunt, but y’all broke something when you went from 2.3.2 to 2.4.0 and it hasn’t been fixed yet.

:face_with_raised_eyebrow:

12 Likes

I just ran a folder of mostly raw images through autopilot and ran out of memory after about 315 of them. Before, it was doing so after 50 or 60. So there is definitely an improvement for those who batch process.
The “ghost faces” are still there on images to which cropping and face recovery have been applied.

I have also commented before on the intrusive progress box in the lower centre over each image.

4 Likes

Hi Dakota,

I just rebooted and same bug exhibited with the Ps plugin. (File > Automate access to PAI).

The processed image isn’t sent back to Ps layer stack. Just that truncated msg box and an empty/transparent, labelled PAI layer.

This product isn’t usable in Ps 2024… And, it’s impossible to remove it or even close Ps after it happens. Which is a ‘no no’…

1 Like

Okay, Dakota, just to be a thorough little tester… I just tried again (after having to shut down Ps via Task Mgr to get rid of the frozen by PAI save to Ps process).

This time I tried accessing this rel. of PAI plugin via the Filter > Topaz Labs menu in Ps (2024).

It still doesn’t work, but this time the issue is the same truncated message box and Ps UI freeze occurs before I’m even taken into the PAI .1 plugin. Snip below. Note the truncated msg box is in a diff position than where the failed File > Automate places it after a save.

Something is seriously wrong and needs surgery for the Ps plugin (Anthony, where are you?!).

Snip of what I see immediately after clicking Filter > Topaz Labs > PAI to use the Ps PAI .1 plugin:

1 Like

Updated in place (M2 Mac Mini, Ventura). Process worked; model downloads occurred but I couldn’t tell anything was happening until it finished:

Screenshot 2024-04-25 at 5.59.49 PM

Silly minor stuff:

Without checking “About”, you can no longer tell what version of PAI you’re running at quick glance (and it still looks like I have 3 messages from Topaz…):

Screenshot 2024-04-25 at 6.01.13 PM

Screenshot 2024-04-25 at 6.01.17 PM

Now for the sidebar! We are making no progress here! Notice the wasted space, the annoying Upscale message (I haven’t yet tested if it eventually goes away) and the truncated names of the upscale model being used (which is it? I don’t know!):

Oh no! Expanding the model selection does not reveal the full names either! Floating the dialog does not make a difference. This is really bad! Please offer the selection panel as per Gigapixel:

Screenshot 2024-04-25 at 6.08.13 PM

Results (old map found online):

I think I like to denoise within Upscale better than adding DeNoise as an additional enhancement (the latter result looks “cleaner” but details are “dirtier”, especially the handwriting):

More comparison work need to be done here…

While I was working I noticed Memory Cleaner salvaging large chunks of RAM as I went along. Even while preparing a screenshot of this, more RAM was salvaged (this is out of 16GB). I see this occasionally but with PAI open it’s almost constant:

Screenshot 2024-04-25 at 6.18.12 PM

I wonder if our PC users can install a similar app to do battle with RAM usage while PAI does its thing?

8 Likes

I’m sure we could, but we shouldn’t have to. It just needs to be fixed.

9 Likes

Of course, but until then…

3 Likes

Thanks plugs - for making more space for the image, you can undock the controls and collapse the side bar. Do you prefer to edit with it expanded and docked?

Appreciate the notes, as always. You, Fotomaker, and David are always first on the scene.

Cheers

2 Likes

I am downloading 3.0.1 now and will setup a batch of 200 images or so to run overnight. I’ll report my results when this is done.

2 Likes

Thanks Dakota, I just tried that… It involves a LOT of clicking to go back and forth to make further adjustments.

For instance, to change the Subject area being sharpened, I have to re-expand the Sharpen panel to make my menu selection and click again to collapse it.

The Navigation icon does not pop that “tool” option out, you have to expand the whole sidebar again.

As for being quick, I checked earlier and saw no update but came back later and saw it was up for a few hours!

And thank you for your engagement here as well. Now go put some pressure on the UI guy and get this thing fixed :wink:

4 Likes

In the previous version, tiff was the only option as an output to LrC if a RAW was sent to TPAI via plugin-extras. In this case Adjust Lighting and Balance Color filters were always applied.

“Please note that exports will still generate TIFF files if the Adjust Lighting or Balance Color filters are applied.” Does this mean that Adjust Lighting and Balance Color filters can be disabled in this situation? I need an answer before I bother updating.

1 Like