Topaz Photo AI v1.3.10 - v1.3.11

@Bob_Blaylock @rayinsanmiguel @wbhovis55 We are currently preparing 1.3.11 which should fix this issue. I expect it to be out soon. For now I’ll list it as a known issue on the top post.

For reference I believe this would only affect RAW images and potentially cropped images.


Thanks for the update! The images I had the rectangle issue with were not cropped; and when launching via “Edit In” from LRC the resulting image had odd texture artefacts that were not in the previous version.

If you have it moved to your D drive already then it may be an issue with the library we use since I’m relying on them to get the temp directory path. If this message is annoying you can always turn it off under Preferences > General.

Seems to have fixed the problem - thanks

ugh… Mangled DNGs are back… One is a straight Jpg of the NEF, one is a returned TIF via “edit in”, and one is the returned DNG processed as a Plug-in Extra.

Guess which one is the DNG…

1 Like

Is this with 1.3.10 or 1.3.11?

Just tested again… same results v1.3.11


I uploaded a bunch to @yazi.saradest

1 Like

Just use PAI as a stand alone app. You can the save it and open with another program of your choice.

Hi and thank you for reply but as I wrote after the last release we need to be able to send from whatever DAM we use to TP and then have an option to open on applications of choice to PP as you can do when opening directly from Windows Explorer, not having to go round the houses to get there.


1 Like

On another note, I have something to call out about performance.

As I mentioned about my spider image, other bugs aside, Photo AI took more than two hours to process it. It does not usually take nearly that long to process an image of that size, but it doesn’t take a trivial amount of time, either. Perhaps fifteen to thirty minutes is a rough guess on my part as to how long it usually takes.

So, having failed at using Photo AI to process that image, I ran it instead through your older programs, Denoise AI and Sharpen AI.

I’d noticed it before, but this is the first time I’ve thought to mention it here, but your older programs are a •LOT• faster. Photo AI, when it works, is more convenient, because I only have to run my image through one program, instead of two or three to get similar results, but it does nearly always end up taking quite a bit longer.

If you are mainly doing non-portrait images you can go to Preferences > Autopilot and turn off Face Detection. That tends to take a fair amount of time. Also if you do not use subject detection or subject sharpening you could also optionally turn off Subject Detection in the same place. At least on my machine turning off both of those cuts Autopilot runtime drastically, although of course you will get different Autopilot results with those off.

1 Like

I have done so.

I haven’t squawked about it, but my experience so far, when I have enabled Face Detection, is that where actual faces are detected and processed, it usually doesn’t produce any better results (some times it does but not usually) and it makes the program slower and more prone to crashing.

Thanks Adam, as it turns out I had moved all User Data I could to the D drive but I hadn’t assigned new locations for the TEMP/TMP locations in the system variables.

Shall get back to you if the problem persists.

Hi Adam, well I reassigned the Temp/TMP directories and the message doesn’t appear anymore. But there must have been other issues as Subject Detection now works after I posted that it doesn’t work in this post earlier:

So there other things that may be happening because of the Temp directory such as this case of the Subject Detection.

Getting the same kind of problems as AiDon with the kittens. The auto pilot, doesn’t do it’s job well this version. I ran some quick Photo AI runs with the previous version and they looked OK (still have some issues with the issue that is now under development). This version only enables Sharpen or Remove Noise (no Face Recovery) and doesn’t do that very good.

Enabling sharpen or denoise and recover faces by hand makes it a bit better, but not what it was with the previous version

With dark images it introduces a lot of white pixels that aren’t present in the original; mainly on the head and in the hair.

1 Like

Above image is taken in Nikon Z8 not being recognised by Topaz AI

These bugs are being observed across many Photo Ai releases:
A. Initial Zoom (cmd +) jumps to top left.
B. Zoom 200%, after that enable input scale 2x and observe the madness of zoom scale jumps.

Why were the wonderful Zoom-shortcuts Cmd-2,3,4 not transitioned to Photo AI from previous AI apps?

1 Like