Topaz Photo AI v1.1.4

Opening a few thousands of images takes forever. Gigapixel opens the same images within a few seconds. :eyes:

Lightroom Classic has AI masking, but it allows you to add/subtract using non-AI brushes to get exactly what you want.

1 Like

Getting blur where I don’t think there should be any. Same with low light in De Noise (which I gather is what you use here). Image had a high dynamic range and I’d brought the shadows up and sent a tiff to PAI. Think I need to run De Noise at different settings and merge the images!

I don’t know how to disable the autopilot. I know that I can set own settings and then apply these to all images, but I can not turn on the face recognition if the current image shows no faces but later images maybe.

Then I don’t understand why they’re recommending to use the raw processing method…

Unfortunately it doesn’t seem that AI can process RAW images in the way you want them processed without input from you.

Ai photo’s Achilles heel is removing noise from cloth texture. It sees texture detail as noise. Ai noise does not have this issue and retains texture detail on clothes.


I am getting an unresponsive Photo AI if I bring in 700+ images when I try to apply settings to all. Initially it works, but even after letting it sit there for 4+ hours after Apply All it never returned. Menu options greyed out except OS ones like fullscreen/exit full screen, no spinning beach ball cursor, just non-responsive.

I am needing to sharpen a video and Video Enhance isn’t doing a thing to it, so I break it up in to frames. Sharpen AI had no problem, but no go with Photo AI.

I lose all metadata too. I just started testing Photo AI. As far a I know there is currently no way to keep this info. If I am wrong maybe someone can correct me. If I am correct this is a near deal breaker for me and hopefully they will correct this soon.

Some images appear way too saturated in the Photo AI app. They appear as expected when exported and opened in my editing app (Capture One) and so are useless for making changes based on the preview. Is there something I can do, or is this a previewing issue with the current build of Photo AI? .cr3 files from a Canon R5.

You really need to provide information such as your OS, what options you use in LR for the Edit in and do you save to LR or save as.

I just ran this test from Lightroom Classic and used Edit in → Edit a Copy with Lightroom Adjustments (TIFF, ProPhotoRGB, 16 bit, resolution 300, No compression):

And I get all the EXIF, Keywording back etc., when using Save to Adobe Lightroom Classic:


I use Windows 11 pro. In Lightroom Classis I use edit in with edit a copy with lightroom adjustments (tiff, srgb, res 300, zip). I use save to lightroom. I don’t get the metadata back. The only exception is when Photo Ai also upscales the image. Then the metadata stays. I have the problem from v1.1.4.

I didn’t upscale and got all back. I use win 11 also.

Dan, thanks for your response. I’m on Mac OS 12.6.1. I’m editing the Raws through Capture One and returning DNGs. I’ve tried both “Edit With” and “Open With” in Capture One. I’ve also tried this using the application directly through the Mac Finder. None of these preserves the metadata. It looks like Topaz has put the most effort into integrating with Lightroom and if your metadata is preserved when editing the Raw files and outputting DNGs then they have done a better job with this integration. It makes it likely they could fix this.

1 Like

Color shifting on all output except DNG. Clockwise dng (matches NEF) jpeg, png, tif. Last 2 are current sharpen and Gpixel tif files. They come out about .5 stops darker but not the color shift. I tried various adjustments and I cannot get the other formats to the correct color.

1 Like

I use Photo Mechanic to cull my photos and add metadata, then run them through Photo AI to denoise and sharpen the raw files before importing them into Lightroom. The output files from Photo AI do not include the metadata when imported into Lightroom. The metadata imports fine if I import the raw files directly from Photo Mechanic into Lightroom without using Photo AI. This is a recent problem and I wonder if it is a bug in one of the recent updates.

Update I discovered that the problem was a setting in Photo Mechanic that apparently didn’t affect the Lightroom import but was necessary for Photo AI to read the metadata.

Hi I don’t edit RAWs directly as the RAW images don’t retain any metadata entered in any RAW processor as that is held in XMP sidecars and/or the catalog.

I have no issue with camera metadata/EXIF and application metadata when processed from Capture One (21), ON1 Photo RAW or LR as a TIF with changes applied.

Camera metadata is also retained when directly editing the RAW image in Photo AI.

Photo AI v1.1.4 sharpens unselected areas of the image.
After refining a mask and a clicking on ‘Done’ I see that unselected areas of the image are sharpened.



it would be very useful, if you could crop the image before you save it. Especially when you enhance Resolution.
Thank you.

1 Like

‘Enhance Respolution’ was not activated. The unwanted sharpening of blossom parts was the result of the activated ‘Remove Noise’ tool.