Topaz Photo AI v1.0.7


This week we have a nice bug fixing update! There’s some crash fixes, quality of life changes, and just in general improved stability. AI Brush was related to a lot of these changes, but still has many improvements in the works that’ll just take a bit longer before they’re ready, like undo/redo and brush sizes. We’d still love to hear your feedback on the direction you’d like us to take AI Brush!

If you own DeNoise, Sharpen, and Gigapixel with up-to-date licenses then you already have access to Topaz Photo AI!

Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports. If there’s a specific image you’d like us to see, you can send it us at this dropbox link.

Released October 27, 2022
Mac: Download
Windows: Download

Changes since 1.0.6:

  • While making a mask brush stroke, the feathering won’t be rendered so you can see what precisely is being selected
  • The Face Recovery filter is now enabled if there are detected faces, and will automatically select all or no faces on toggle, as appropriate
  • Enabled the mask softness slider when the subject is set to “None”
  • The “Activate” button in the login dialog now reactivates after a couple seconds, in case the user closes their browser / tab
  • Fixed crash when starting a mask brush in the margins of the preview
  • Fixed crash caused by switching images rapidly
  • Fixed crash on certain images due to lens correction
  • Fixed CLI hanging if an image fails to write
  • Fixed installer claiming some versions of AVX as not supported that actually are
  • Fixed issues with the AI Brush appearing in the wrong spot in some situations
  • Fixed Mac not opening files as an external editor sometimes
  • Fixed instances not merging on Windows when files are located on external drives (causing issues like LrC appearing to not open all your files in TPAI if you have many selected)
  • Fixed images opened on Windows using “Open With” not saving if set to “original folder”
  • Fixed some plugin files on Mac being owned by root rather than the user, preventing things like PhotoShop 2023 automatically copying them over to the new plugins folder
  • Fixed face indicators in navigator appearing incorrectly on large faces

We still have a lot more planned! Here’s some of the things we are actively working on improving:

  • AI Brush
  • Performance of the preview panel (particularly when zoomed out on large images)

I’d like to think I’m a special person. . . but the links do appear to be missing. :stuck_out_tongue:

1 Like

Well we haven’t forgotten yet, because the post is still unlisted - so in this case, you are in fact reading it because you’re special / a moderator


Thanks for listening. Looking forward to the improvement.

At the moment, what i realy want like to see would be a upscale model that does look like a real raw image with like ISO 100 noise in the output.

This would facilitate further editing of the images.

I would rather have something that I can improve according to my ideas than that is fixed what I should use.

Installed PAI 1.0.7 to Win 11 Pro desktop PC. Processor = Auto. A.P. Prefs noted in snip below.

Tested Standalone & Ps (2022, not upgraded to 2023 yet) Plugin. Using Canon raw (CR2) images. No prior processing to either of the test images.

I honestly don’t see any real step forward improvements. And, some ops were worse than 1.0.6. I realize it’s still an early-mid beta stage product. But, like some other testers have stated, I think this will have to be it for my tests until I see some changes or improvements to usage elements I’d need for a “real-life” usage tool, or wishlist features I’ve proposed incorporated, etc. given the many hours I spend testing, organizing test notes and reporting findings in the hope they’ll aid prod dev …

Here are my AutoPilot Prefs. If I have it set wrong I’d like to know what to fix. I want all Sharpening sensed (even if I’m going to manually tweak it). I don’t want Subject detected (or the default set to ‘Only Sharpen Subject’ - I wouldn’t want that setting to be on by default even if the product accurately detected subjects; which it doesn’t)

Standalone (relevant labelled snips below each version’s experience comments)

** I included a detailed, bulleted list of desired Masking Brush features in one of the 1st posts for rel. 1.0.6 - I won’t reiterate them here. I’m not sure they’d be incorporated and it wouldn’t be a good use of my time. The only one I didn’t mention previously is the need for a “Cancel Masking” button to return to the regular UI; which is diff. than “Done” if someone started masking & wants to abort.

Ps (2022) Plugin (labelled snips for issues below)

  • The plugin launched.
  • I used a different image from the same set - this time the need for Sharpening was detected. I modified the levels manually to my taste.
  • B/c Sharpening detected on the 2nd image - I checked and A.P. is still defaulting to Only Std model as its choice. Both images of mine for these tests improved significantly using the Motion Blur model (applied manually).
  • The manual Brush Masking was same as Standalone’s - impossible to control (hops around to lay down random patches), takes a long time to brush b/c can’t enlarge size, etc.
  • This time - b/c of the image I used - the Overlay Color for the Masking “Brush” was a significant issue. If there was a color option I would have changed it b/c of closeness of the Overlay color to the Subject’s color.
  • Image saved back to Ps Layer. I didn’t notice a significant “hop” when I turned the Ps layer eye icon on/off.

Sadly, my Windows computer has a Intel Xeon E5620 CPU, which does not support the AVX instruction set, so of course the install aborted.
Folks can find out if their CPU supports this instuction set by downloading and installing HWinFO at

This is a safe open-source program.
Dan Johnson

Yes, the masking brush is still not much use. Still not using Photo AI for real because of this. Sharpen/DeNoise rule OK

Still having distinct problems with oversaturation of ProPhotoRGB images as you can see from the comparison below of the original image and then the image displayed in Photo AI … and this is only the display and not the output.


Display in PHOTO AI

I guess I’ll just keep posting this since I can’t seem to get a response.Still struggling to get PAI working as a plugin in Photoshop. Works fine in LRC. Have removed and reinstalled both programs. Even when PAI is uninstalled it still shows up as a filter in PS. I’ve tried deleting every mention of PAI on the computer, and that makes no difference. One thing I’ve noted is that in the plugin folder for PS, there are folders containing the plugins for Denoise and Sharpen, but the plugin for PAI is just there without a folder. I even tried to make a folder but it made no difference. Is this what it’s supposed to do, install without a folder?

I should note that Ling from Topaz has already remoted in to my computer and was not able to find the problem. Adobe support says the problem may be some remnants from old installs but I’ve removed every possible remnant I could find. I did note that when installing a popup appears asking for access to a remote drive. Today with the new version I denied that access, but it didn’t make any difference. The filter appears in PS along with the other Topaz plugins, but nothing happens when it’s selected: no dialog box or anything. I’d appreciate any help. Really frustrating since the LRC plugin works perfectly

Screen Shot 2022-10-28 at 6.57.20 AM

and I’ll add that the reason Adobe says it must be related to something left on the computer is the fact that after removing every trace of PAI from the computer, it still appears as a filter in PS.

Are you on a Mac? It would appear from your screenshots that you are. Have you upgraded to the new OS, Ventura, yet? It would be a good idea to do a clean install and then your computer would be free of any little files that might be causing this problem can’t offer any other suggestions as I’m not really very tech minded.

I haven’t upgraded yet. Would obviously prefer not to do a complete clean install, but it’s a great idea if I can’t find an alternative…thanks.

When I switch between multiple opened images the application always resets my zoom level to the default 100 % even if I have choosen a different zoom level on the same image before. :confused:

1 Like

Can you answer my question about the placement of the plugin in the Photoshop plugin folder? Assuming you have a Mac as well. Does your folder have just the plain plugin for PAI but folders for the others?

I had several similar issues a year or more ago before I upgraded my Intel Mac Mini to a new Mac Mini M1… and was forced to re-install most of my stuff from scratch… it was a tedious couple of days, but in the long run, well worth it…

1 Like

Unfortunately, I can’t help you further since I don’t use Photoshop. I haven’t tested the Photoshop plug-in with ON1 Photo RAW which is my main photo editor. Photoshop plug-ins do work with it in theory.

I’ll take a look over the weekend when I get back home.

1 Like

While I was able to successfully drop/scan/set up 7 PNG images in queue, each one being shown and processed, pressing “Save 7 images” immediately crashed the program with c0000005 exception and exception offset 000000000002cd29 in KERNELBASE.DLL library. I ran the program with admin rights.
I think it was the situation, where I was on an image, which didn’t trigger face detection (last, 7th file), whereas first image did trigger and had set up face detection. The app did “think” for a moment, like loading a routine, then crashed.

Second attempt did crash the program again, in the middle of 3-file queue. Again, from an image without face-detect to an image with face detect. It crashed during saving the PNG file (incomplete file, just before it “reached” the face, readable by Imagine plugin for Total Commander 10.50, but not by XnViewMP).

I also had a crash occurring a moment after dropping a single image, this time in ntdll.dll library, c0000005 exception, with 00000000000705fb offset. Second attempt to do it with the same PNG file didn’t crash the program. The PNG files have Stable Diffusion headers written in them (they’re generated PNG files), with parameters like prompt and some other data. I’m assuming that data is ignored by every viewer/program out there.

Where should I put ZIP with logs and crashdumps, made by Windows? I use Win10 21H2 with latest updates, 64GB of RAM and RTX 3090 with newest Studio driver, 522.30.

We’re now at 1.07 and yet, the window resize issue has not been addressed.
Seriously, am I the only one with this problem?

Open an image and work on it. Fine.

quit the app and open again.

Please, please fix this.

Kind Regards


No, you are not alone.

1 Like