Topaz Gigapixel AI 7.0.5 - extremely slow

Hi, I need help. I have installed Topaz Gigapixel AI 7.0.5 and it is extremely slow in processing. I’ve tried different settings for the AI processor, but it’s always the same slow processing. I used to use version 6 and it took about 35 seconds to process. I don’t know why version 7 is so slow, processing takes about 2 minutes. I have a 13th Gen Intel(R) Core™ i5-13500 2.50 GHz processor, 64 GB RAM, 64-bit OS, x64 platform processor, Windows 11 Pro. Thanks for the advice.

1 Like

Please send me your system profile to help@topazlabs.com

I can assist you from there!

Thank you. I wrote to them.

1 Like

Two minutes sounds wonderful. Working on a MacBookPro (last model with Intel processor) and a simple 2X upscale could take 10 plus minutes. Downloaded the latest PS and LR and the latest Gigapixel only to find the clock can spin for 20 minutes. LR to PS edit in show black screen and GP – when it finally uprises – shows 1,1,1 for size. Tried converting files from 16 bit to 8 and saving as TIFF to no avail. What garbage!