Topaz Denoise does not show preview when called from LR

I’m running on Windows 10 Pro. All my applications and OS are always up to date. Since a week or so Topaz Denoise does not show a preview when I call it from within Lightroom Classic. When I first open Topaz Denoise and then select an image from Windows File Explorer, all is fine. Windows 10 Photos also displays the RAW (ARW) images correctly. So I guess it’s not a Codec problem. Anyone any views on this issue?

What types of files are you pasding to DeNoise from Lightroom?

Please also go to Help-Graphics info press Copy and paste the info here.

Don,

I have Canon CR2 and Sony ARW image files, but LR turns them into TIF before calling Denoise.

Help-Graphics info:
Application & Version: Topaz DeNoise AI Version 2.2.11
Operating System: Windows 10 (10.0)
Graphics Hardware: Radeon ™ RX 470 Graphics
OpenGL Driver: 3.3.13587 Core Profile Forward-Compatible Context 20.4.2 26.20.15029.27017
CPU RAM: 32711 MB
Video RAM: 4096 MB
Preview Limit: 8000 Pixels

Hi, I see what the issue is I guess you see something like this when you call it from LR:

After testing I think the problem lies with the preferences and I suspect yours looks something like this:

image

(Note: in your case OpenVINO may or may not be selected but Enable discrete GPU is NO)

Please open your preferences from the File main and make sure they look like this by setting Enable discrete GPU to YES:

image

Forgot to mention you will need to cancel from DeNoise and call it from Lightroom again.

Don,

My preferences are identical to yours, except for the Allowed Memory Consumption, which I specified as High.

(Tried to add a screenshot but I get the message that I’m not allowed to do that.)

I changed the Allowed Memory Consumption to Medium, and then I saw the preview again. Weird!! However, after re-booting, Denoise is up to its old tricks. Cannot see the preview, with your suggested Preferences in place.

I would be grateful for any further suggestions!!

1 Like

Some times I have similar problem.