Topaz DeNoise AI batch mode generates Blank/Dark images


When I use DeNoise on multiple Images I have problems.
Topaz DeNoise does not recognize Canon CR3 files.
As a workaround, I use Adobe DNG convertor and convert them to Camera RAW 7.1 or later images.
I try batch processing I choose Dnoise AI for all images and start the batch.
Initially I get an output, but after a few initial images the remaining output images are all black/blank. this has happened consistently.
For those that work the image generated is darker than the source. it gets progressively darker every image processed
I have Intel UHD graphics 630 and NVIDIA GeForce GTX 1650 Graphic cards, with the latest drivers.
If there is any more information needed please let em know.

Files which converted and output file darker

File that generated a blank file or maybe too dark

I assume you are using v2.0.0?

Firstly would you open DeNoise and go to Help-> Graphics info and see which GPU is in use. If the GTX1650 isn’t in use, go to the Win 10 Settings, Graphics Settings, and then search for the DeNoise executable, add it to the list and under its Options choose High Performance.

If you continue to get Black output with the GPU switch over to Intel OpenVINO (CPU) processing in the Preferences (Advanced) after setting GPU to No.

RAW processing is still being tuned and is currently ‘flat’, but CR3 is not on the horizon. Typically I use DPP to generate TIFs from the images from my M50 and use those.

1 Like

Yes I use 2.0.0
Your solution worked, it was using the intel graphic card. Once i changed it to the NVIDIA, it processed the files properly.

Thanks for the advice and help.

I can manage the CR3, i use lightroom which is not a subscription and have to use DPP in the first step so its good enough for me.


For what it’s worth, I was seeing the same problem when just doing a single image (not batch processing).
I also convert my CR3 files to DNG’s and process them in Paint Shop Pro 2019 and DeNoise 2 as a plug in.
Changing the video setting to High Performance (on my HP laptop) fixed the problem. I’m on the road, so when I get back to the office in a couple of weeks, I’ll see if the same problem exists on my desktop PC.