Topaz AI Incorrectly Changing Aspect Ratio

Hello everyone,

Hoping someone can help me understand why my output is changing AFTER i use Topaz AI.

I am attempting to upscale DVD content 720 X 480 (16:9) to 4K 60 FPS output to be watched in Plex, but for some reason I am finding that Topaz changes the aspect ratio such that when i watch on Plex the video is not full screen. It appears with black bars all around.

My de-interlaced (via handbrake) source file is 720 X 480 (16:9).
The output file comes out at 3840 X 2160, but with a 2:107 aspect ratio.

In Topaz I have selected the following output options:
3840 X 2160 (4K)
Original Pixel Type
Letterbox/ Pillarbox (I have also tried crop to fill and same result)
60 FPS

This screen shows my source file info

This screen shows my output file info

Any help on this would be greatly appreciated.


1 Like

I’m guessing it’s to do with the wrong pixel type. Your original 720x480 file will have non square pixels to be 16:9, but at 4K you need the pixels to be square to give that aspect ratio.

Agreed. Change it to square pixels.


Thank you both for the recommendations. I tried that in preview mode and it worked. @alanhusband-677420 you mention square pixels are required for the aspect ratio… is that just a known thing? Does it only apply to certain output resolutions? or is it based on source content compared to desired output?

Would it make sense for the application user experience to “force” the change to square pixels when a certain output like 4K is chosen?

It will depend on the source and the output resolution. 3840x2160 UHD 4K has a pixel ratio of 16:9, so if the content your upscaling to that resolution is meant to be displayed at 16:9 (like your dvd), you should use square pixels for the output.

But UHD 4K should not be forced to square pixels by the app because not all content is meant to be displayed at 16:9 (such as cinema widescreen formats).